Bug 1013834 - puppet module tool version 3.3 gives "bad component(expected absolute path component)"
puppet module tool version 3.3 gives "bad component(expected absolute path co...
Status: CLOSED DUPLICATE of bug 1014001
Product: Pulp
Classification: Community
Component: puppet-support (Show other bugs)
2.2
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: pulp-bugs
pulp-qe-list
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-30 17:30 EDT by koweblomke
Modified: 2013-10-02 11:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-02 11:44:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description koweblomke 2013-09-30 17:30:40 EDT
Description of problem:
running $ puppet module install puppetlabs-java gives 
"bad component(expected absolute path component)" 

Version-Release number of selected component (if applicable):
puppet 3.3
pulp 2.2

How reproducible:
with puppet 3.3 and pulp 2.2 installed on 1 machine and mirroring the puppet forge on the pulp server; try to install any module with the puppet module tool gives "bad component(expected absolute path component)"

Steps to Reproduce:
1. install pulp 2.2
2. add a puppet repo with some puppet modules
3. install puppet
4. configure puppet to use module_repository = http://.:<repo-id>@localhost
5. run puppet module install <some-module>

Actual results:
Error: "bad component(expected absolute path component)"

Expected results:
the puppet module installed

Additional info:
I tested with puppet 3.2.3 and it still worked.
I'm not shure if this is a puppet or a pulp bug.
(see https://github.com/puppetlabs/puppet/commit/2cb57bfaca)
Comment 1 Sayli Karmarkar 2013-10-02 11:44:01 EDT

*** This bug has been marked as a duplicate of bug 1014001 ***

Note You need to log in before you can comment on or make changes to this bug.