Bug 1014001 - puppet 3.3.0 release breaks pulp compatibility
puppet 3.3.0 release breaks pulp compatibility
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: puppet-support (Show other bugs)
2.2
Unspecified Unspecified
high Severity high
: ---
: 2.4.0
Assigned To: Michael Hrivnak
Preethi Thomas
: Triaged
: 1013834 (view as bug list)
Depends On:
Blocks: 927466
  Show dependency treegraph
 
Reported: 2013-10-01 04:56 EDT by Abhay Chrungoo
Modified: 2014-08-09 02:54 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-09 02:54:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Abhay Chrungoo 2013-10-01 04:56:55 EDT
Description of problem:
puppet module install fails when talking to a pulp based 'forge'


Version-Release number of selected component (if applicable):

[root@ycprepo ~]# rpm -qa |grep pulp
pulp-nodes-admin-extensions-2.2.0-1.el6.noarch
python-isodate-0.5.0-1.pulp.el6.noarch
python-pulp-rpm-common-2.2.0-0.25.beta.el6.noarch
pulp-builtins-consumer-extensions-2.2.0-0.25.beta.el6.noarch
python-pulp-rpm-extension-2.2.0-0.25.beta.el6.noarch
createrepo-0.9.9-21.2.pulp.el6.noarch
pulp-agent-2.2.0-0.25.beta.el6.noarch
pulp-puppet-consumer-extensions-2.2.0-0.25.beta.el6.noarch
pulp-server-2.2.0-0.25.beta.el6.noarch
m2crypto-0.21.1.pulp-8.el6.x86_64
mod_wsgi-3.4-1.pulp.el6.x86_64
pulp-selinux-2.1.1-1.el6.noarch
python-pulp-bindings-2.2.0-0.25.beta.el6.noarch
python-pulp-client-lib-2.2.0-0.25.beta.el6.noarch
pulp-admin-client-2.2.0-0.25.beta.el6.noarch
pulp-rpm-plugins-2.2.0-0.25.beta.el6.noarch
pulp-puppet-admin-extensions-2.2.0-0.25.beta.el6.noarch
pulp-nodes-common-2.2.0-1.el6.noarch
python-oauth2-1.5.170-3.pulp.el6.noarch
python-pulp-agent-lib-2.2.0-0.25.beta.el6.noarch
pulp-builtins-admin-extensions-2.2.0-0.25.beta.el6.noarch
pulp-puppet-plugins-2.2.0-0.25.beta.el6.noarch
pulp-rpm-consumer-extensions-2.2.0-0.25.beta.el6.noarch
pulp-puppet-handlers-2.2.0-0.25.beta.el6.noarch
pulp-nodes-parent-2.2.0-1.el6.noarch
python-rhsm-1.8.0-1.pulp.el6.x86_64
python-pulp-common-2.2.0-0.25.beta.el6.noarch
python-pulp-puppet-common-2.2.0-0.25.beta.el6.noarch
pulp-consumer-client-2.2.0-0.25.beta.el6.noarch
pulp-rpm-admin-extensions-2.2.0-0.25.beta.el6.noarch
pulp-rpm-handlers-2.2.0-0.25.beta.el6.noarch


How reproducible:


Steps to Reproduce:
1. Upgrade to / Install puppet 3.3.0
2. Configure puppet.conf to talk to the pulp forge. (or use cmd line arguments in the next step)
3. puppet module install author/module

Actual results:
rpm -qa |grep puppet
puppet-3.3.0-1.el6.noarch
puppetlabs-release-6-7.noarch


[root@ziraffe puppet]# rm -rf modules
[root@ziraffe puppet]# puppet module --modulepath '/etc/puppet/modules' install --ignore-dependencies ycp/jbossapplication
Notice: Preparing to install into /etc/puppet/modules ...
Notice: Created target directory /etc/puppet/modules
Notice: Downloading from http://.:ycpforge@ycprepo.myco.com ...
Error: bad component(expected absolute path component): http://ycprepo.myco.com/pulp/puppet/ycpforge/system/releases/y/ycp/ycp-jbossapplication-2.2.0.tar.gz
Error: Try 'puppet help module install' for usage


Expected results:
[root@ziraffe puppet]# rpm -qa |grep puppet
puppet-3.2.4-1.el6.noarch

[root@ziraffe puppet]# puppet module --modulepath '/etc/puppet/modules' install --ignore-dependencies ycp/jbossapplication
Notice: Preparing to install into /etc/puppet/modules ...
Notice: Downloading from http://.:ycpforge@ycprepo.myco.com ...
Notice: Installing -- do not interrupt ...
/etc/puppet/modules
└── ycp-jbossapplication (v2.2.0)


Additional info:

mhrivnak@irc suggested that https://github.com/puppetlabs/puppet/commit/d2acfbd
might have something to do with this issue.
Comment 1 Sayli Karmarkar 2013-10-02 11:44:01 EDT
*** Bug 1013834 has been marked as a duplicate of this bug. ***
Comment 2 Barnaby Court 2013-11-07 16:15:07 EST
Transitioning back to pulp-bugs to focus on sprint work.
Comment 3 Randy Barlow 2013-12-23 16:40:20 EST
I assume jdob is no longer working on this one :)
Comment 4 Kim Johansen 2014-01-03 13:45:59 EST
Got it to work:

https://github.com/pulp/pulp_puppet/pull/96

# puppet module --verbose --debug install --modulepath '/etc/puppet/modules' --module_repository=http://<consumer>:.@<host> base/sshd
Notice: Preparing to install into /etc/puppet/modules ...
Notice: Downloading from http://<consumer>:.@<host> ...
Notice: Installing -- do not interrupt ...
Debug: Executing 'tar xzf /var/lib/puppet/puppet-module/cache/http_<onsumer>_<host>-12058a42b986e51863bf9bdd754c7303efc94034/base-sshd-1.0.3.tar.gz --no-same-owner -C /var/lib/puppet/puppet-module/cache/tmp-unpacker-4bc80c076cb71a1712785f180aa73ef7cbdd1dd1'
Debug: Executing 'find /var/lib/puppet/puppet-module/cache/tmp-unpacker-4bc80c076cb71a1712785f180aa73ef7cbdd1dd1 -type d -exec chmod 755 {} +'
Debug: Executing 'find /var/lib/puppet/puppet-module/cache/tmp-unpacker-4bc80c076cb71a1712785f180aa73ef7cbdd1dd1 -type f -exec chmod a-wst {} +'
Debug: Executing 'chown -R 0:0 /var/lib/puppet/puppet-module/cache/tmp-unpacker-4bc80c076cb71a1712785f180aa73ef7cbdd1dd1'
/etc/puppet/modules
└── base-sshd (v1.0.3)
Comment 5 Michael Hrivnak 2014-01-29 15:34:47 EST
Kim, I'm seeing the following using your patch and puppet 3.3.0. Thoughts?

$ puppet module install --module_repository=http://.:foo@localhost puppetlabs/stdlib
Notice: Preparing to install into /home/mhrivnak/.puppet/modules ...
Notice: Downloading from http://.:foo@localhost ...
Error: userinfo not supported.  [RFC3986]
Error: Try 'puppet help module install' for usage
Comment 6 Michael Hrivnak 2014-02-10 15:33:14 EST
https://github.com/pulp/pulp_puppet/pull/103
Comment 7 Jeff Ortel 2014-04-03 09:35:36 EDT
build: 2.4.0-0.7.beta
Comment 8 Preethi Thomas 2014-06-06 09:44:34 EDT
verified
[root@hp-dl380pgen8-01 ~]# rpm -qa |grep pulp-puppet
pulp-puppet-consumer-extensions-2.4.0-0.19.beta.fc20.noarch
python-pulp-puppet-common-2.4.0-0.19.beta.fc20.noarch
pulp-puppet-admin-extensions-2.4.0-0.19.beta.fc20.noarch
pulp-puppet-tools-2.4.0-0.19.beta.fc20.noarch
pulp-puppet-handlers-2.4.0-0.19.beta.fc20.noarch
pulp-puppet-plugins-2.4.0-0.19.beta.fc20.noarch
[root@hp-dl380pgen8-01 ~]# rpm -qa puppet
puppet-3.4.3-3.fc20.noarch

[root@hp-dl380pgen8-01 ~]# pulp-admin puppet consumer install run --consumer-id kitkat -u puppetlabs/apache
Install task created with id [ 797c46cb-de9b-4c66-8d49-98329af1b467 ]

This command may be exited via ctrl+c without affecting the request.



1 change was made

Install Succeeded
Comment 9 Randy Barlow 2014-08-09 02:54:22 EDT
This has been fixed in Pulp 2.4.0-1.

Note You need to log in before you can comment on or make changes to this bug.