Bug 101385 - Citrix wfica client segfaults.
Citrix wfica client segfaults.
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: glibc (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
: 101452 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-31 12:18 EDT by Stephen John Smoogen
Modified: 2016-11-24 10:22 EST (History)
8 users (show)

See Also:
Fixed In Version: 2.3.2-77
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-27 09:52:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of ltrace command (36.17 KB, text/plain)
2003-08-25 19:21 EDT, Christian Thibodeau
no flags Details

  None (edit)
Description Stephen John Smoogen 2003-07-31 12:18:39 EDT
Description of problem:

The ICAClient from Citrix, wfica, segfaults during file opens. The client works
perfectly well with Red Hat Linux 9 and 7.3.


[smoogen@smoogen1 tmp]$ ldd /usr/lib/ICAClient/wfica
        /lib/libNoVersion.so.1 => /lib/libNoVersion.so.1 (0x00363000)
        libXaw.so.6 => /usr/X11R6/lib/libXaw.so.6 (0x003fe000)
        libXt.so.6 => /usr/X11R6/lib/libXt.so.6 (0x00887000)
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x00111000)
        libdl.so.2 => /lib/libdl.so.2 (0x00f0f000)
        libc.so.6 => /lib/libc.so.6 (0x00667000)
        libXmu.so.6 => /usr/X11R6/lib/libXmu.so.6 (0x002bb000)
        libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x00997000)
        libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x001f0000)
        libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x00207000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x0026b000)

(gdb) where
#0  0x004157e7 in _IO_seekoff_unlocked () from /lib/libc.so.6
#1  0x0041a8fd in fseek () from /lib/libc.so.6
#2  0x0807189c in InitFileCacheEntry ()
#3  0x08071df4 in ReadOneLine ()
#4  0x080d88f1 in LoadINIFileSection ()
#5  0x0810f341 in host_language_string ()
#6  0x0810f7ae in HostInit ()
#7  0x0806e029 in OldMain ()
#8  0x08110f94 in PlatAppMain ()
#9  0x080e9bd2 in AppMain ()
#10 0x08110f3d in main ()

The trace ends at:
open("/usr/share/pixmaps/gnome/cursors/00000000000000000000000000000000",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/pixmaps/gnome/index.theme", O_RDONLY) = -1 ENOENT (No such file
or directory)
open("/home/smoogen/.icons/crystalsvg/cursors/00000000000000000000000000000000",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/home/smoogen/.icons/crystalsvg/index.theme", O_RDONLY) = -1 ENOENT (No
such file or directory)
open("/usr/share/icons/crystalsvg/cursors/00000000000000000000000000000000",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/icons/crystalsvg/index.theme", O_RDONLY) = -1 ENOENT (No such
file or directory)
open("/usr/share/pixmaps/crystalsvg/cursors/00000000000000000000000000000000",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/pixmaps/crystalsvg/index.theme", O_RDONLY) = -1 ENOENT (No such
file or directory)
lstat64("/usr/lib/ICAClient/config/.server", {st_mode=S_IFREG|0444, st_size=0,
...}) = 0
lstat64("/home/smoogen/.ICAClient/wfclient.ini", {st_mode=S_IFREG|0600,
st_size=1438, ...}) = 0
open("/home/smoogen/.ICAClient/wfclient.ini", O_RDONLY) = 4

The home directory is an NFS mounted partition. I have moved the permissions to
various modes but does not seem to have an effect.
Comment 1 Bill Nottingham 2003-07-31 12:21:33 EDT
Do you know the last version of Red Hat and/or glibc that it worked on?
Comment 2 Stephen John Smoogen 2003-07-31 17:40:21 EDT
Red Hat Linux 9
glibc-2.3.2-27.9.i686.rpm
kernel-smp-2.4.20-19.9.i686.rpm
Comment 3 Bill Nottingham 2003-08-01 15:19:43 EDT
*** Bug 101452 has been marked as a duplicate of this bug. ***
Comment 4 Need Real Name 2003-08-16 13:07:28 EDT
I get the same behaviour with a stock RH 9 install on a uniprocessor x86 
machine.  After upgrading to glibc 2.3.2-53 (via compiling source), Citrix ICA 
client no longer works.
Comment 8 Keith 2003-08-19 15:40:07 EDT
Same behavior - Taroon.

Adding cc
Comment 9 Jakub Jelinek 2003-08-25 07:28:00 EDT
Wow, a real glibc 2.0 application, thought Applixware was the last one.
Can you please ltrace it?
Comment 10 Christian Thibodeau 2003-08-25 19:21:17 EDT
Created attachment 93919 [details]
Output of ltrace command

This is the ltrace output of running the /usr/lib/ICAClient/wfica
Comment 11 Luca Tosolini 2004-02-28 15:40:14 EST
I see that this bug is closed and there is a fix. But where is it?
What should I do to have wfica working again, apart from downgrading
glibc?
Comment 12 Jakub Jelinek 2004-02-28 15:59:26 EST
It is fixed in glibc-2.3.2-77 and later, e.g. RHEL3 GA glibc, FC1
glibc, RHEL3 U1 glibc etc.

Note You need to log in before you can comment on or make changes to this bug.