Bug 1014055 - Need f-stream build of iproute-2.6.32-26.el6 for netns support in RHOS
Need f-stream build of iproute-2.6.32-26.el6 for netns support in RHOS
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: iproute (Show other bugs)
4.0
Unspecified Unspecified
urgent Severity urgent
: beta
: 4.0
Assigned To: Marcela Mašláňová
Rami Vaknin
: AutoVerified, TestBlocker
Depends On:
Blocks: 1014056
  Show dependency treegraph
 
Reported: 2013-10-01 06:38 EDT by Perry Myers
Modified: 2016-04-26 15:49 EDT (History)
7 users (show)

See Also:
Fixed In Version: iproute-2.6.32-130.el6ost.netns.2
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Iproute is a collection of utilities for controlling TCP / IP networking and traffic control. The iproute packages contain networking utilities (for example, ip and rtmon), which are designed to use the advanced networking capabilities of the Linux kernel. These updated iproute packages include numerous bug fixes and enhancements, as noted in Red Hat Enterprise Linux 6.5 Technical Notes: * While monitoring IP neighbor cache with the ip monitor neigh command, the cache experienced the layer 2 network miss. Consequently, ip monitor neigh command could not decode the miss event generated by the kernel. To fix this bug, code for neighbor cache events for entry deletion and entry miss have been back-ported from upstream and ip monitor neigh now recognizes cache miss event and format it properly with a miss keyword on the output. * Previously, Red Hat Enterprise Linux 6 was missing a functionality to set up IPv6 token-only network configuration. As a consequence, the user had fewer networking options. The IPv6 token feature has been implemented in both kernel (BZ#876634) and a userspace interface to iproute. Users can now setup IPv6 token-only networking, optionaly receiving network prefixes later. * Red Hat Enterprise Linux 6.5 shipped with VXLAN (Virtual Extended LAN), a VLAN-like layer 3 encapsulation technique support in the kernel, so a userspace interface was required for users and applications to utilize the VXLAN feature. With this update, the ip utility recognizes and supports the 'vxlan' devices. * When larger rto_min (the minimum TCP Retransmission TimeOut to use when communicating with a certain destination) was set, the ip route show command did not return correct values. A patch has been provided to fix this bug and ip route show now handles rto_min as expected. * Prior to this update, the manual page for the lnstat utility was referring wrongly to non-existent directory, the iproute-doc instead of iproute-<package version> directory. The incorrect documentation could confuse the user. To fix this bug, the file-system path has been corrected. * Previously, there was an inconsistency between the lnstat utility's interval option behavior and its documentation. Consequently, lnstat exited after a number of seconds instead of refreshing the view, making the interval option useless. The interval option behavior has been changed to refresh the data every N seconds, thus fixing the bug. * Previously, the ip utility was mishandling netlink communication, which could cause hangs under certain circumstances. Consequently, listing network devices with the ip link show command hung in a SELinux restricted mode. With this update, the ip utility checks for the result of the rtnl_send() function before waiting for a reply, avoiding an indefinite hang. As a result, it is now possible to list network devices in a SELinux restricted environment. * Prior to this update, the tc utility documentation lacked description of the batch option. To fix this bug, the tc manual pages have been updated including the description of the batch option.
Story Points: ---
Clone Of:
: 1014056 (view as bug list)
Environment:
Last Closed: 2013-12-19 19:25:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2013:1859 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2013-12-20 19:01:48 EST

  None (edit)
Description Perry Myers 2013-10-01 06:38:08 EDT
Description of problem:
RHEL 6.5 includes a new build of iproute: 2.6.32-26.el6

The latest f-stream version of iproute in RHOS 3.0.z and 4.0 is:
2.6.32-23.el6ost.netns.2

This means that RHEL 6.5 users will get a newer version of iproute from base RHEL repositories that does not contain the network namespace support.

With each new build of iproute in RHEL 6, we need a corresponding new build of iproute in RHOS 3.0.z and 4.0 with a higher NVR so that RHOS users get the packages with the netns functionality

The new package should probably follow the same rules that we used for kernel f-stream in RHOS 3.0.z, by incrementing the release field by +100 so that if there is a short delay between release of a new RHEL base iproute build that it does not override the RHOS f-stream build of iproute.

So iproute-2.6.32-26.el6 would be built in RHOS 3.0.z and 4.0 f-stream as:
iproute-2.6.32-126.el6ost

This bug will need to be cloned to RHOS 3.0.z so that we can have new builds tagged and released in both 4.0 and 3.0.z streams.
Comment 1 Marcela Mašláňová 2013-10-01 08:18:14 EDT
Hi Perry,
could you give me a link to product pages, so I could see when is deadline for this bug?
Does your request mean, we should merge 6.5 branch into rhos f-stream branch? In RHEL-6.5 branch might be additional changes in next few days.

Thanks for clarification.
Comment 11 Rami Vaknin 2013-10-16 16:14:50 EDT
Verified on rhos 4.0 running on rhel6.5, namespaces work well.

iproute-2.6.32-30.el6.x86_64 : Advanced IP routing and network device
                             : configuration tools
Repo        : rhel-server
Matched from:



iproute-2.6.32-130.el6ost.netns.2.x86_64 : Advanced IP routing and network
                                         : device configuration tools
Repo        : installed
Matched from:
Other       : Provides-match: iproute



[root@puma10 ~]# ip netns
qlbaas-8203635c-3f93-4748-abec-4e2a9f25e45d
qrouter-7ef63e50-0898-4b73-9553-bc5a3d2985fc
[root@puma10 ~]#
Comment 13 errata-xmlrpc 2013-12-19 19:25:32 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.