This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1014056 - Need f-stream build of iproute-2.6.32-26.el6 for netns support in RHOS
Need f-stream build of iproute-2.6.32-26.el6 for netns support in RHOS
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: iproute (Show other bugs)
4.0
Unspecified Unspecified
urgent Severity urgent
: z3
: 3.0
Assigned To: Marcela Mašláňová
Ofer Blaut
: ZStream
Depends On: 1014055
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 06:40 EDT by Perry Myers
Modified: 2016-04-26 09:25 EDT (History)
8 users (show)

See Also:
Fixed In Version: iproute-2.6.32-123.el6.netns.2
Doc Type: Bug Fix
Doc Text:
Iproute is a collection of utilities for controlling TCP / IP networking and traffic control. The iproute packages contain networking utilities (for example, ip and rtmon), which are designed to use the advanced networking capabilities of the Linux kernel. These updated iproute packages include numerous bug fixes and enhancements. Space precludes documenting all of these changes in this advisory. Users are directed to the Red Hat Enterprise Linux 6.5 Technical Notes for information on the most significant of these changes: https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux /6/html/6.5_Technical_Notes/index.html
Story Points: ---
Clone Of: 1014055
Environment:
Last Closed: 2013-11-18 10:16:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Perry Myers 2013-10-01 06:40:29 EDT
+++ This bug was initially created as a clone of Bug #1014055 +++

Description of problem:
RHEL 6.5 includes a new build of iproute: 2.6.32-26.el6

The latest f-stream version of iproute in RHOS 3.0.z and 4.0 is:
2.6.32-23.el6ost.netns.2

This means that RHEL 6.5 users will get a newer version of iproute from base RHEL repositories that does not contain the network namespace support.

With each new build of iproute in RHEL 6, we need a corresponding new build of iproute in RHOS 3.0.z and 4.0 with a higher NVR so that RHOS users get the packages with the netns functionality

The new package should probably follow the same rules that we used for kernel f-stream in RHOS 3.0.z, by incrementing the release field by +100 so that if there is a short delay between release of a new RHEL base iproute build that it does not override the RHOS f-stream build of iproute.

So iproute-2.6.32-26.el6 would be built in RHOS 3.0.z and 4.0 f-stream as:
iproute-2.6.32-126.el6ost

This bug will need to be cloned to RHOS 3.0.z so that we can have new builds tagged and released in both 4.0 and 3.0.z streams.
Comment 3 Ofer Blaut 2013-10-29 08:48:08 EDT
new iproute used in openstack-quantum-2013.1.4-3.el6ost.noarch

iproute-2.6.32-123.el6ost.netns.2.x86_64
Comment 7 errata-xmlrpc 2013-11-18 10:16:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1510.html

Note You need to log in before you can comment on or make changes to this bug.