Bug 1014098 - Intermittently produced wrong TEST-org.jboss.as.clustering.infinispan.subsystem.*.xml reports
Intermittently produced wrong TEST-org.jboss.as.clustering.infinispan.subsyst...
Status: CLOSED DUPLICATE of bug 1124348
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Testsuite (Show other bugs)
6.1.1,6.2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Ondřej Žižka
Pavel Jelinek
Russell Dickenson
:
Depends On:
Blocks: 996500
  Show dependency treegraph
 
Reported: 2013-10-01 08:18 EDT by Pavel Jelinek
Modified: 2014-10-25 08:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-30 04:02:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RHEL5x86 reports (9.51 KB, application/zip)
2013-10-01 08:18 EDT, Pavel Jelinek
no flags Details
RHEL5x86_64 reports (9.53 KB, application/zip)
2013-10-01 08:22 EDT, Pavel Jelinek
no flags Details
RHEL6x86 example report (9.28 KB, application/zip)
2013-10-01 08:25 EDT, Pavel Jelinek
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBQA-10147 Major Open TEST-org.jboss.as.clustering.infinispan.*.xml reports are produced wrongly 2017-12-11 05:53 EST

  None (edit)
Description Pavel Jelinek 2013-10-01 08:18:01 EDT
Created attachment 805890 [details]
RHEL5x86 reports

maven-surefire-plugin often produces wrong reports for org.jboss.as.clustering.infinispan.subsystem test package. 

e.g.
<testsuite failures="0" time="0" errors="0" skipped="1" tests="1" name="org.jboss.as.clustering.infinispan.subsystem.OperationsTestCase">
  <properties>
    ...
  </properties>
  <testcase time="0" classname="org.jboss.as.clustering.infinispan.subsystem.SubsystemParsingTestCase" name="org.jboss.as.clustering.infinispan.subsystem.SubsystemParsingTestCase">
    <skipped/>
  </testcase>
</testsuite>

One of the consequences is incorrect number of run tests presented by jenkins, example runs (differnet count of run tests for same package, all tests are passed or skipped) : 

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-AS-Testsuite/job/eap-60-as-testsuite-RHEL-matrix-OracleJDK6/99/jdk=java16_default,label_exp=RHEL5%26%26x86/testReport/org.jboss.as.clustering.infinispan.subsystem/

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-AS-Testsuite/job/eap-60-as-testsuite-RHEL-matrix-OracleJDK6/99/jdk=java16_default,label_exp=RHEL5%26%26x86_64/testReport/org.jboss.as.clustering.infinispan.subsystem/

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-AS-Testsuite/job/eap-60-as-testsuite-RHEL-matrix-OracleJDK6/99/jdk=java16_default,label_exp=RHEL6%26%26x86/testReport/org.jboss.as.clustering.infinispan.subsystem/

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-AS-Testsuite/job/eap-60-as-testsuite-RHEL-matrix-OracleJDK6/99/jdk=java16_default,label_exp=RHEL6%26%26x86_64/testReport/org.jboss.as.clustering.infinispan.subsystem/
Comment 3 Radoslav Husar 2013-10-01 10:08:16 EDT
Seems to really be a problem with the report. Looking at the log, for e.g. 

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-AS-Testsuite/job/eap-60-as-testsuite-RHEL-matrix-OracleJDK6/97/jdk=java16_default,label_exp=RHEL5%26%26x86_64/testReport/org.jboss.as.clustering.infinispan.subsystem/

shows only 4 test classes being run.

However, all the tests have been run, only the report is lacking:

-------------------------------------------------------
 T E S T S
-------------------------------------------------------
Concurrency config is parallel='false', perCoreThreadCount=true, threadCount=2, useUnlimitedThreads=false
Running org.jboss.as.clustering.infinispan.subsystem.OperationsTestCase
Tests run: 4, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 4.433 sec
Running org.jboss.as.clustering.infinispan.subsystem.InfinispanSubsystemTestCase
Tests run: 25, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 21.592 sec
Running org.jboss.as.clustering.infinispan.subsystem.InfinispanSubsystemTransformerTestCase
Tests run: 5, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 8.669 sec
Running org.jboss.as.clustering.infinispan.subsystem.OperationSequencesTestCase
Tests run: 5, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 3.816 sec
Running org.jboss.as.clustering.infinispan.subsystem.OperationsTestCase
Tests run: 1, Failures: 0, Errors: 0, Skipped: 1, Time elapsed: 0 sec
Running org.jboss.as.clustering.infinispan.DefaultEmbeddedCacheManagerTest
Tests run: 24, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.136 sec

I don't see anything clustering specific, assigning to testsuite component.
Comment 4 Pavel Jelinek 2014-07-30 04:02:37 EDT

*** This bug has been marked as a duplicate of bug 1124348 ***

Note You need to log in before you can comment on or make changes to this bug.