Bug 1124348 - [QE] (6.4.0) Wrong usage of 'parallel' option in infinispan unit tests
Summary: [QE] (6.4.0) Wrong usage of 'parallel' option in infinispan unit tests
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Clustering, Testsuite
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: DR1
: EAP 6.4.0
Assignee: Petr Kremensky
QA Contact: Petr Kremensky
URL:
Whiteboard:
: 1014098 (view as bug list)
Depends On:
Blocks: 996500 1124367
TreeView+ depends on / blocked
 
Reported: 2014-07-29 09:51 UTC by Petr Kremensky
Modified: 2019-08-19 12:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1124367 (view as bug list)
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker JBQA-10147 Major Open TEST-org.jboss.as.clustering.infinispan.*.xml reports are produced wrongly 2014-08-20 06:50:48 UTC

Description Petr Kremensky 2014-07-29 09:51:09 UTC
Description of problem:
According to [1] the option 'parallel' is used wrongly in clustering/infinispan/pom.xml. This is causing that the name of SubsystemParsingTestCase (class is annotated with @Ignore) is always substituted with the name of fist test from set and junit report of the fist test is overwritten by the ignored test case report.

[1] - http://maven.apache.org/surefire/maven-surefire-plugin/test-mojo.html#parallel

Version-Release number of selected component (if applicable):
EAP 6.3.0.ER10

How reproducible:
Always

Steps to Reproduce:
1. cd jboss-eap-6.3-src/clustering/infinispan
2. mvn test

Actual results (see the ignored test):
-------------------------------------------------------
 T E S T S
-------------------------------------------------------
Concurrency config is parallel='false', perCoreThreadCount=true, threadCount=2, useUnlimitedThreads=false
Running org.jboss.as.clustering.infinispan.DefaultEmbeddedCacheManagerTest
Tests run: 24, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.216 sec
Running org.jboss.as.clustering.infinispan.subsystem.OperationSequencesTestCase
Tests run: 5, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 2.217 sec
Running org.jboss.as.clustering.infinispan.subsystem.InfinispanSubsystemTestCase
Tests run: 30, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 7.553 sec
Running org.jboss.as.clustering.infinispan.subsystem.OperationsTestCase
Tests run: 4, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.318 sec
Running org.jboss.as.clustering.infinispan.DefaultEmbeddedCacheManagerTest
Tests run: 1, Failures: 0, Errors: 0, Skipped: 1, Time elapsed: 0 sec
Running org.jboss.as.clustering.infinispan.subsystem.InfinispanSubsystemTransformerTestCase
Tests run: 7, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 8.5 sec
...
Tests run: 71, Failures: 0, Errors: 0, Skipped: 1
Jenkins reports - Test run: 47

Expected results (see the ignored test):
-------------------------------------------------------
 T E S T S
-------------------------------------------------------
Concurrency config is parallel='false', perCoreThreadCount=true, threadCount=2, useUnlimitedThreads=false
Running org.jboss.as.clustering.infinispan.DefaultEmbeddedCacheManagerTest
Tests run: 24, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.216 sec
Running org.jboss.as.clustering.infinispan.subsystem.OperationSequencesTestCase
Tests run: 5, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 2.217 sec
Running org.jboss.as.clustering.infinispan.subsystem.InfinispanSubsystemTestCase
Tests run: 30, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 7.553 sec
Running org.jboss.as.clustering.infinispan.subsystem.OperationsTestCase
Tests run: 4, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.318 sec
Running org.jboss.as.clustering.infinispan.SubsystemParsingTestCase
Tests run: 1, Failures: 0, Errors: 0, Skipped: 1, Time elapsed: 0 sec
Running org.jboss.as.clustering.infinispan.subsystem.InfinispanSubsystemTransformerTestCase
Tests run: 7, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 8.5 sec
...
Tests run: 71, Failures: 0, Errors: 0, Skipped: 1
Jenkins reports - Test run: 71

Additional info:
Remote the <parallel>false</parallel> from pom.xml

Comment 3 Pavel Jelinek 2014-07-30 08:02:38 UTC
*** Bug 1014098 has been marked as a duplicate of this bug. ***

Comment 4 Petr Kremensky 2014-09-19 07:22:51 UTC
Verified on EAP 6.4.0.DR1.1


Note You need to log in before you can comment on or make changes to this bug.