Bug 1014111 - [RFE - RHDS9] CLI report to monitor replication
[RFE - RHDS9] CLI report to monitor replication
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
6.4
x86_64 Linux
high Severity high
: rc
: 6.6
Assigned To: mreynolds
Sankar Ramalingam
: FutureFeature
: 1014109 1014208 1120694 (view as bug list)
Depends On:
Blocks: 1061410 1108895
  Show dependency treegraph
 
Reported: 2013-10-01 08:37 EDT by Chris Hudson
Modified: 2014-10-14 03:51 EDT (History)
6 users (show)

See Also:
Fixed In Version: 389-ds-base-1.2.11.15-39.el6 389-ds-base-1.2.11.15-40.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1108895 (view as bug list)
Environment:
Last Closed: 2014-10-14 03:51:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
New repl-monitor.pl (38.34 KB, application/x-perl)
2013-10-14 15:03 EDT, mreynolds
no flags Details

  None (edit)
Description Chris Hudson 2013-10-01 08:37:04 EDT
A strategic customer (has a TAM) is requesting a simple script to monitor replication. This would be something similar to the administration express replication status web page, but on the command line.

The justification is that the customer needs a way to quickly determine the status of replication when a browser is not available.

It was suggested by an RH employee that repl-monitor.pl could be tweaked to have an option to output a simple text report instead of html.
Comment 2 Rich Megginson 2013-10-01 09:46:06 EDT
Upstream ticket:
https://fedorahosted.org/389/ticket/47538
Comment 4 Rich Megginson 2013-10-01 10:17:04 EDT
*** Bug 1014208 has been marked as a duplicate of this bug. ***
Comment 5 mreynolds 2013-10-14 15:01:56 EDT
Fix has been pushed to master(1.3.3)

commit 76abd736d3bf763cc0e7bc1987fe76c27159db6f

Attaching new script for customer.
Comment 6 mreynolds 2013-10-14 15:03:33 EDT
Created attachment 812175 [details]
New repl-monitor.pl
Comment 7 Nathan Kinder 2013-10-30 21:31:30 EDT
*** Bug 1014109 has been marked as a duplicate of this bug. ***
Comment 8 Noriko Hosoi 2014-03-11 19:52:39 EDT
Mark, we are including this fix in RHEL-6.6.  Could you backport/cherry-pick the patch to 1.2.11 (as well as 1.3.1 & 2)?
https://fedorahosted.org/389/attachment/ticket/47538/0001-Ticket-47538-RFE-repl-monitor.pl-plain-text-output-c.patch
Thanks!
Comment 9 mreynolds 2014-03-11 20:41:16 EDT
(In reply to Noriko Hosoi from comment #8)
> Mark, we are including this fix in RHEL-6.6.  Could you backport/cherry-pick
> the patch to 1.2.11 (as well as 1.3.1 & 2)?

No problem, first thing tomorrow!

> https://fedorahosted.org/389/attachment/ticket/47538/0001-Ticket-47538-RFE-
> repl-monitor.pl-plain-text-output-c.patch
> Thanks!
Comment 10 mreynolds 2014-03-12 09:55:39 EDT
Fixed upstream.
Comment 12 Milan Kubík 2014-06-19 04:48:05 EDT
Hi,
is it enough to verify the functionality of the new '-s' option to verify the RFE or do I need to test all the changes made to this tool in order to verify this?

I do certainly plan to test all the modifications, though. I'm just concerned about the scope of this bugzilla right now.

Thanks,
Milan
Comment 13 Rich Megginson 2014-06-19 10:11:32 EDT
(In reply to Milan Kubík from comment #12)
> Hi,
> is it enough to verify the functionality of the new '-s' option to verify
> the RFE or do I need to test all the changes made to this tool in order to
> verify this?

I don't know.  Mark?

> 
> I do certainly plan to test all the modifications, though. I'm just
> concerned about the scope of this bugzilla right now.
> 
> Thanks,
> Milan
Comment 14 Noriko Hosoi 2014-07-24 19:08:26 EDT
*** Bug 1120694 has been marked as a duplicate of this bug. ***
Comment 16 mreynolds 2014-08-05 14:45:04 EDT
Fixed upstream...
Comment 18 Sankar Ramalingam 2014-08-07 09:59:46 EDT
The reported problem is not fixed yet. Hence, assigning back to Dev.

/usr/bin/repl-monitor.pl -p 38001 -h hp-sl2x170zg6-02.rhts.eng.bos.redhat.com -f /tet/tetframework/testcases/DS/6.0/system/reliab15/out/repl.conf 
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN"><html>
<meta http-equiv="Content-Type" content="text/html;charset=UTF-8">
<head><title>Replication Status</title>
<style text/css>
Body, p, table, td, ul, li {color: #000000; font-family: Arial, Helvetica, sans-serif; font-size: 12px;}
A {color:blue; text-decoration: none;}
BODY {font-family: arial, helvetica, sans-serif}
P {font-family: arial, helvetica, sans-serif}
TH {font-weight: bold; font-family: arial, helvetica, sans-serif}
TD {font-family: arial, helvetica, sans-serif}
.bgColor1  {background-color: #003366;}
.bgColor4  {background-color: #cccccc;}
.bgColor5  {background-color: #999999;}
.bgColor9  {background-color: #336699;}
.bgColor13 {background-color: #ffffff;}
.bgColor16 {background-color: #6699cc;}
.text8  {color: #0099cc; font-size: 11px; font-weight: bold;}
.text28 {color: #ffcc33; font-size: 12px; font-weight: bold;}
.areatitle {font-weight: bold; color: #ffffff; font-family: arial, helvetica, sans-serif}
.page-title {font-weight: bold; font-size: larger; font-family: arial, helvetica, sans-serif}
.page-subtitle {font-weight: bold; font-family: arial, helvetica, sans-serif}
</style></head>
<body class=bgColor4>
<table border=0 cellspacing=0 cellpadding=10 width=100% class=bgColor1>
<tr><td><font class=text8>Thu Aug  09:58:38 7</font></td>
<td align=center class=page-title><font color=#0099CC>Directory Server Replication Status</font>
</td><td align=right valign=center width=25%><font class=text8>Version 1.1</font></td></table>
Login to hp-dl360egen8-01.rhts.eng.bos.redhat.com:38001=38001 as "*" failed
Comment 19 mreynolds 2014-08-07 10:13:16 EDT
Sankar, what is in your repl.conf file?

Thanks,
Mark
Comment 20 Sankar Ramalingam 2014-08-07 10:27:58 EDT
connection]
hp-dl360egen8-01.rhts.eng.bos.redhat.com:38000=38000:*:Secret123:*
hp-sl2x170zg6-02.rhts.eng.bos.redhat.com:38001=38001:*:Secret123:*
hp-z800-01.rhts.eng.bos.redhat.com:38002=38002:*:Secret123:*
intel-s3ea2-04.rhts.eng.bos.redhat.com:38003=38003:*:Secret123:*
intel-waimeabay-hedt-01.ml3.eng.bos.redhat.com:38004=38004:*:Secret123:*
dell-pec6220-01.lab.eng.bos.redhat.com:38005=38005:*:Secret123:*
hp-dl580g7-02.rhts.eng.bos.redhat.com:38006=38006:*:Secret123:*
ibm-x3650-02.ovirt.rhts.eng.bos.redhat.com:38007=38007:*:Secret123:*
intel-chiefriver-02.khw.lab.eng.bos.redhat.com:38008=38008:*:Secret123:*
amd-pike-05.khw.lab.eng.bos.redhat.com:38009=38009:*:Secret123:*

hp-dl360egen8-01.rhts.eng.bos.redhat.com:38100=38000:*:Secret123:*
hp-sl2x170zg6-02.rhts.eng.bos.redhat.com:38101=38001:*:Secret123:*
hp-z800-01.rhts.eng.bos.redhat.com:38102=38002:*:Secret123:*
intel-s3ea2-04.rhts.eng.bos.redhat.com:38103=38003:*:Secret123:*
intel-waimeabay-hedt-01.ml3.eng.bos.redhat.com:38104=38004:*:Secret123:*
dell-pec6220-01.lab.eng.bos.redhat.com:38105=38005:*:Secret123:*
hp-dl580g7-02.rhts.eng.bos.redhat.com:38106=38006:*:Secret123:*
ibm-x3650-02.ovirt.rhts.eng.bos.redhat.com:38107=38007:*:Secret123:*
intel-chiefriver-02.khw.lab.eng.bos.redhat.com:38108=38008:*:Secret123:*
amd-pike-05.khw.lab.eng.bos.redhat.com:38109=38009:*:Secret123:*

[alias]
M1 = hp-dl360egen8-01.rhts.eng.bos.redhat.com
M2 = hp-sl2x170zg6-02.rhts.eng.bos.redhat.com
M3 = hp-z800-01.rhts.eng.bos.redhat.com
M4 = intel-s3ea2-04.rhts.eng.bos.redhat.com
H1 = intel-waimeabay-hedt-01.ml3.eng.bos.redhat.com
H2 = dell-pec6220-01.lab.eng.bos.redhat.com
C1 = hp-dl580g7-02.rhts.eng.bos.redhat.com
C2 = ibm-x3650-02.ovirt.rhts.eng.bos.redhat.com
C3 = intel-chiefriver-02.khw.lab.eng.bos.redhat.com
C4 = amd-pike-05.khw.lab.eng.bos.redhat.com

[color]
0 = #ccffcc
5 = #FFFFCC
60 = #FFCCCC
Comment 21 mreynolds 2014-08-07 12:11:19 EDT
(In reply to Sankar Ramalingam from comment #20)
> connection]
> hp-dl360egen8-01.rhts.eng.bos.redhat.com:38000=38000:*:Secret123:*
> hp-sl2x170zg6-02.rhts.eng.bos.redhat.com:38001=38001:*:Secret123:*
> hp-z800-01.rhts.eng.bos.redhat.com:38002=38002:*:Secret123:*
> intel-s3ea2-04.rhts.eng.bos.redhat.com:38003=38003:*:Secret123:*
> intel-waimeabay-hedt-01.ml3.eng.bos.redhat.com:38004=38004:*:Secret123:*
> dell-pec6220-01.lab.eng.bos.redhat.com:38005=38005:*:Secret123:*
> hp-dl580g7-02.rhts.eng.bos.redhat.com:38006=38006:*:Secret123:*
> ibm-x3650-02.ovirt.rhts.eng.bos.redhat.com:38007=38007:*:Secret123:*
> intel-chiefriver-02.khw.lab.eng.bos.redhat.com:38008=38008:*:Secret123:*
> amd-pike-05.khw.lab.eng.bos.redhat.com:38009=38009:*:Secret123:*
> 
> hp-dl360egen8-01.rhts.eng.bos.redhat.com:38100=38000:*:Secret123:*
> hp-sl2x170zg6-02.rhts.eng.bos.redhat.com:38101=38001:*:Secret123:*
> hp-z800-01.rhts.eng.bos.redhat.com:38102=38002:*:Secret123:*
> intel-s3ea2-04.rhts.eng.bos.redhat.com:38103=38003:*:Secret123:*
> intel-waimeabay-hedt-01.ml3.eng.bos.redhat.com:38104=38004:*:Secret123:*
> dell-pec6220-01.lab.eng.bos.redhat.com:38105=38005:*:Secret123:*
> hp-dl580g7-02.rhts.eng.bos.redhat.com:38106=38006:*:Secret123:*
> ibm-x3650-02.ovirt.rhts.eng.bos.redhat.com:38107=38007:*:Secret123:*
> intel-chiefriver-02.khw.lab.eng.bos.redhat.com:38108=38008:*:Secret123:*
> amd-pike-05.khw.lab.eng.bos.redhat.com:38109=38009:*:Secret123:*
> 
> [alias]
> M1 = hp-dl360egen8-01.rhts.eng.bos.redhat.com
> M2 = hp-sl2x170zg6-02.rhts.eng.bos.redhat.com
> M3 = hp-z800-01.rhts.eng.bos.redhat.com
> M4 = intel-s3ea2-04.rhts.eng.bos.redhat.com
> H1 = intel-waimeabay-hedt-01.ml3.eng.bos.redhat.com
> H2 = dell-pec6220-01.lab.eng.bos.redhat.com
> C1 = hp-dl580g7-02.rhts.eng.bos.redhat.com
> C2 = ibm-x3650-02.ovirt.rhts.eng.bos.redhat.com
> C3 = intel-chiefriver-02.khw.lab.eng.bos.redhat.com
> C4 = amd-pike-05.khw.lab.eng.bos.redhat.com
> 
> [color]
> 0 = #ccffcc
> 5 = #FFFFCC
> 60 = #FFCCCC

This looks like a new bug, as this config file fails for ALL versions of 389.  The problem is that "*" is not converted to the default value.  Working on a new patch...
Comment 22 mreynolds 2014-08-07 13:25:35 EDT
Issue with asterisks not being assigned the default values has been fixed upstream.
Comment 23 Sankar Ramalingam 2014-08-22 07:37:39 EDT
Requesting you to add verification steps. What tests do we need to carry out to verify this feature?
Comment 24 mreynolds 2014-08-22 10:05:16 EDT
The original feature request was to create a human readable report when running the repl-monitor.pl script.  Previously it only generated a html file.

Simply add the command line switch "-s", or "--text" in addition to the other usual arguments, and this should generate a plain text report(no html).  So to verify it, make sure you don't see any html tags like "<head>" in the output.
Comment 25 Sankar Ramalingam 2014-09-10 07:45:47 EDT
repl-monitor.pl script works fine for options -s and --text. It display the non-html report in the command line. Hence, marking the bug as Verified.

Build tested - 389-ds-base-1.2.11.15-44.

[root@iceman ~]# rpm -qa |grep -i 389-ds-base
389-ds-base-libs-1.2.11.15-44.el6.x86_64
389-ds-base-1.2.11.15-44.el6.x86_64
389-ds-base-devel-1.2.11.15-44.el6.x86_64

[root@iceman ~]# repl-monitor.pl -v
Directory Server Replication Monitor - Version 1.1

[root@iceman ~]# /usr/bin/repl-monitor.pl --text -p 38001 -h idm-qe-02.lab.eng.rdu2.redhat.com -f /export/repl.conf  |more
Directory Server Replication Status (Version 1.1)

Time: Wed Sep 10 2014 07:36:26

Master: nu5.idm.lab.eng.rdu2.redhat.com:38001 ldap://nu5.idm.lab.eng.rdu2.redhat.com:38001/
Replica ID: 1
Replica Root: o=my_suffix.com
Max CSN: 541038ad000600010000 (09/10/2014 07:40:29 6 0)
Receiver: nu1.idm.lab.eng.rdu2.redhat.com:38104 ldaps://nu1.idm.lab.eng.rdu2.redhat.com:38104/
Type: hub
Time Lag: - 0:05:51
Max CSN: 5410374e000100010000 (09/10/2014 07:34:38 1 0)
Last Modify Time: 9/10/2014 07:40:30
Supplier: nu5.idm.lab.eng.rdu2.redhat.com:38001
Sent/Skipped: 263967 / 0
Update Status: 0 Replica acquired successfully: Incremental update started
Update Started: 09/10/2014 07:17:30
Update Ended: n/a
Schedule: always in sync
SSL: SSLCLIENTAUTH
Supplier: nu5.idm.lab.eng.rdu2.redhat.com:38100
Sent/Skipped: 263981 / 0
Update Status: 0 Replica acquired successfully: Incremental update started



[root@iceman ~]# /usr/bin/repl-monitor.pl -s -p 38001 -h idm-qe-02.lab.eng.rdu2.redhat.com -f /export/repl.conf  |more
Directory Server Replication Status (Version 1.1)

Time: Wed Sep 10 2014 07:36:58

Master: nu5.idm.lab.eng.rdu2.redhat.com:38001 ldap://nu5.idm.lab.eng.rdu2.redhat.com:38001/
Replica ID: 1
Replica Root: o=my_suffix.com
Max CSN: 541038ce000000010000 (09/10/2014 07:41:02)
Receiver: nu1.idm.lab.eng.rdu2.redhat.com:38104 ldaps://nu1.idm.lab.eng.rdu2.redhat.com:38104/
Type: hub
Time Lag: - 0:06:02
Max CSN: 54103764000200010000 (09/10/2014 07:35:00 2 0)
Last Modify Time: 9/10/2014 07:41:03
Supplier: nu5.idm.lab.eng.rdu2.redhat.com:38001
Sent/Skipped: 264089 / 0
Update Status: 0 Replica acquired successfully: Incremental update started
Comment 26 errata-xmlrpc 2014-10-14 03:51:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1385.html

Note You need to log in before you can comment on or make changes to this bug.