Bug 1014365 - [Doc] Suggestions for improvement of section 6.5.5. Building Object Storage Service Ring Files
[Doc] Suggestions for improvement of section 6.5.5. Building Object Storage S...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Installation_and_Configuration_Guide (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: 4.0
Assigned To: Don Domingo
ecs-bugs
: Documentation, Triaged
Depends On:
Blocks: 1011085
  Show dependency treegraph
 
Reported: 2013-10-01 16:02 EDT by Javier Peña
Modified: 2014-01-07 00:56 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build Name: 15807, Installation and Configuration Guide-3-1 Build Date: 16-09-2013 12:31:40 Topic ID: 16079-471123 [Latest]
Last Closed: 2014-01-06 23:30:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Javier Peña 2013-10-01 16:02:54 EDT
Title: Building Object Storage Service Ring Files

Describe the issue:
The example command line shown when adding a storage device to the ring can be misleading. It looks like this:

swift-ring-builder /etc/swift/account.builder add zX-127.0.0.1:6002/device_mountpoint partition_count

I have two suggestions:

1- While the text below specifies that you could change the IP (127.0.0.1) to a real IP, the example is still using the loopback address. This contradicts what is being set earlier in section "6.5.2. Configuring the Object Storage Service Storage Nodes", since we are setting bind_ip to the real IP. 

2. The device_mountpoint description is confusing, at least to me (non-native speaker). It took me a long while until I discovered what I had to specify, and only after checking the upstream documentation. A commented example would be really handy.
Suggestions for improvement:
1. I'd suggest to change the loopback IP in the example to use the real IP.
2. I'd propose to add an example. Let's say the real IP of your node is 10.0.0.3, your zone number is 1, and your device is mounted at /srv/node/account. Then, the command line would look like:

swift-ring-builder /etc/swift/account.builder add z1-10.0.0.3:6002/account 100

Additional information:
Comment 4 Don Domingo 2013-12-04 19:36:26 EST
changes:

* replaced loopback address (127.0.0.1) with replaceable "SERVICE_IP"
* clarified that SERVICE_IP should match the bind_ip value set during "Configuring the Object Storage Service Storage Nodes".
* split step 2 into step 2+3; in previous versions, step 2 used to be split up into 3 substeps that featured the same command with minor tweaks. 
* other minor improvements throughout.

orig is here:

https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/4-Beta/html/Installation_and_Configuration_Guide/Building_Object_Storage_Ring_Files.html

Note You need to log in before you can comment on or make changes to this bug.