Bug 1014463 - systemd-fstab-generator[886]: Failed to create mount unit file /run/systemd/generator/sysroot.mount, as it already exists. Duplicate entry in /etc/fstab?
systemd-fstab-generator[886]: Failed to create mount unit file /run/systemd/g...
Status: CLOSED DUPLICATE of bug 1024858
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dracut (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: dracut-maint
Bruno Goncalves
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-02 02:43 EDT by Bruno Goncalves
Modified: 2013-10-30 12:58 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-30 12:58:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Goncalves 2013-10-02 02:43:38 EDT
Description of problem:

When trying to install the OS on a system booting via iSCSI with 2 session the following error happens.

[   32.230373] systemd-fstab-generator[886]: Failed to create mount unit file /run/systemd/generator/sysroot.mount, as it already exists. Duplicate entry in /etc/fstab?
dracut-initqueue[590]: iscsistart: version 6.2.0.873-14
dracut-initqueue[590]: iscsistart: initiator reported error (15 - session exists)
dracut-initqueue[590]: iscsistart: initiator reported error (15 - session exists)
[  OK  ] Started dracut initqueue hook.
         Starting dracut pre-mount hook...
[  OK  ] Started dracut pre-mount hook.
         Mounting /sysroot...
[FAILED] Failed to mount /sysroot.
See 'systemctl status sysroot.mount' for details.


:/# cat /etc/fstab
/dev/root /sysroot auto ro,x-initrd.mount 0 0
/dev/root /sysroot auto ro,x-initrd.mount 0 0

:/# systemctl status sysroot.mount -l
sysroot.mount - /sysroot
   Loaded: loaded (/etc/fstab)
   Active: failed (Result: exit-code) since Wed 2013-10-02 02:16:52 UTC; 20min ago
    Where: /sysroot
     What: /dev/root
  Process: 925 ExecMount=/bin/mount /dev/root /sysroot -t auto -o ro,x-initrd.mount (code=exited, status=32)

Oct 02 02:16:52 localhost systemd[1]: Mounting /sysroot...
Oct 02 02:16:52 localhost mount[925]: mount: /dev/sdc is already mounted or /sysroot busy
Oct 02 02:16:52 localhost systemd[1]: sysroot.mount mount process exited, code=exited status=32
Oct 02 02:16:52 localhost systemd[1]: Failed to mount /sysroot.
Oct 02 02:16:52 localhost systemd[1]: Unit sysroot.mount entered failed state.


Version-Release number of selected component (if applicable):
systemd-207-2.el7.x86_64
dracut-033-3.el7

How reproducible:
100%

Steps to Reproduce:
1.Try to install a iSCSI boot that has 2 sessions configured

2.Installation fails with error above
Comment 4 David Lehman 2013-10-02 09:17:14 EDT
Is this happening when you try to boot the installer or when you try to reboot after installation has completed?
Comment 5 Bruno Goncalves 2013-10-02 09:53:32 EDT
It happens at the installer, just after the iSCSI disks are connected, then the installation fails.
Comment 6 Harald Hoyer 2013-10-29 07:02:44 EDT
please add "rd.debug" to the kernel command line and attach the console.log again.
Comment 7 Bruno Goncalves 2013-10-30 05:27:13 EDT
The problem seems to be caused by adding rd.iscsi.firmware to kernel command line.

Can it be closed as not a bug?
Comment 8 Harald Hoyer 2013-10-30 12:58:37 EDT

*** This bug has been marked as a duplicate of bug 1024858 ***

Note You need to log in before you can comment on or make changes to this bug.