Bug 1024858 - dracut: adding kernel option "rd.iscsi.firmware" to iSCSI boot causes installation to fail
dracut: adding kernel option "rd.iscsi.firmware" to iSCSI boot causes install...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dracut (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: dracut-maint
Bruno Goncalves
:
: 1014463 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 10:08 EDT by Bruno Goncalves
Modified: 2014-06-17 23:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:36:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
serial console log with rd.debug (349.09 KB, text/plain)
2013-10-30 13:43 EDT, Jeff Burke
no flags Details

  None (edit)
Description Bruno Goncalves 2013-10-30 10:08:52 EDT
Description of problem:
Trying to install a server using "rd.iscsi.firmware" in the kernel options command line causes installation to fail.

sysroot.mount mount process exited, code=exited status=32  
[      
FAILED   
] Failed to mount /sysroot.  
See 'systemctl status sysroot.mount' for details.  
[      
DEPEND   
] Dependency failed for Initrd Root File System.  
[      
DEPEND   
] Dependency failed for Reload Configuration from the Real Root.


Version-Release number of selected component (if applicable):
dracut-033-26.el7

How reproducible:
100%

Steps to Reproduce:
1.Try to install a iSCSI boot system and add "rd.iscsi.firmware" to installation kernel command line.

2.Check error when mounting device on serial port.
Comment 3 Harald Hoyer 2013-10-30 10:14:38 EDT
Note: only happens, when there is no "root=..." parameter
Comment 4 Harald Hoyer 2013-10-30 12:58:37 EDT
*** Bug 1014463 has been marked as a duplicate of this bug. ***
Comment 5 Jeff Burke 2013-10-30 13:43:52 EDT
Created attachment 817550 [details]
serial console log with rd.debug

(In reply to Harald Hoyer from comment #3)
> Note: only happens, when there is no "root=..." parameter

This happens during install. I am not sure who/when that option is added during install. I believe Anaconda adds it to the 'kernel command line' with a grubby command.

In my configuration. I have a iBFT entry and a local disk. Once the install is complete, I review which disks were used. It never even tried to use the iSCSI disk. It was like Anaconda was unaware that I wanted to use iSCSI.

If I reinstall, modify the pxe entry and add in rd.iscsi.firmware=1 then run my install I ge this during install.

---------------<snip>----------------
dracut-initqueue[663]: iscsistart: version 6.2.0.873-14  
dracut-initqueue[663]: iscsistart: initiator reported error (15 - session exists)  
[    
  OK     
] Started dracut initqueue hook.  
         Starting dracut pre-mount hook...  
[    
  OK     
] Started dracut pre-mount hook.  
         Mounting /sysroot...  
[      
FAILED   
] Failed to mount /sysroot.  
See 'systemctl status sysroot.mount' for details.  
[      
DEPEND   
] Dependency failed for Initrd Root File System.  
[   18.872695] systemd[1]: Starting Emergency Shell... 
[   18.873761] systemd[1]: Stopped Device-Mapper Multipath Device Controller. 
[   18.873869] systemd[1]: Starting Journal Service... 
[   18.875578] systemd-journald[100]: Received SIGTERM 
[   18.876390] systemd[1]: Starting Journal Service... 
[   18.876631] systemd[1]: Started Journal Service. 
[   18.878102] systemd-journald[925]: Vacuuming done, freed 0 bytes 
[      
DEPEND   
] Dependency failed for Reload Configuration from the Real Root.  
 
Generating "/run/initramfs/rdsosreport.txt" 
  
Entering emergency mode. Exit the shell to continue. 
Type "journalctl" to view system logs. 
You might want to save "/run/initramfs/rdsosreport.txt" to a USB stick or /boot 
after mounting them and attach it to a bug report. 
:/# 
---------------</snip>----------------
Comment 7 Bruno Goncalves 2013-11-01 07:56:13 EDT
Verified, tried adding rd.iscsi.firmware to kernel command line when installing the OS and iSCSI session got established.

dracut-033-39.el7.
Comment 9 Bruno Goncalves 2013-11-01 07:57:45 EDT
Should kernel option "rd.iscsi.firmware" be added to all iSCSI boot servers that have the iSCSI configuration stored on BIOS?
Comment 10 Ludek Smid 2014-06-13 06:36:51 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.