Bug 1014562 - BPEL/RTGov tables are created multiple times
BPEL/RTGov tables are created multiple times
Status: CLOSED DUPLICATE of bug 1029007
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Configuration (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Steve Johnson
Len DiMaggio
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-02 06:58 EDT by Jiri Pechanec
Modified: 2013-11-15 08:16 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-14 11:50:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
DB log file (84.65 KB, text/x-log)
2013-10-02 06:59 EDT, Jiri Pechanec
no flags Details

  None (edit)
Description Jiri Pechanec 2013-10-02 06:58:22 EDT
See attached log file, RTGOV_* tables are dropped/created twice. The problem is probably cause by having the same tables process both by 
overlord-rtgov-epn.overlord-rtgov-epn.*
overlord-rtgov.overlord-rtgov-activity.*
Comment 1 Jiri Pechanec 2013-10-02 06:59:15 EDT
Created attachment 806379 [details]
DB log file
Comment 2 Jiri Pechanec 2013-10-02 07:11:33 EDT
The issue is present also for BPEL - 4 times
Comment 3 Julian Coleman 2013-10-02 07:31:01 EDT
The problem occurs because the schema for each project has to be created at project build time.  This means that if two projects reference the same set of classes, then multiple copies of the tables for those appear when these projects are combined.

The solution is probably to post-process the created schema for all the combined projects, and to remove the duplicates.  This will involve creating a tool/plugin to do this.
Comment 4 Len DiMaggio 2013-10-02 10:01:26 EDT
Is this only a blocking issue for PostgreSQL?
Comment 5 Steve Johnson 2013-11-13 13:28:41 EST
The work being carried out on https://bugzilla.redhat.com/show_bug.cgi?id=1029007 is aimed at resolving this issue.

The tool cannot resolve into one big schema (or one sql file) as the installer chooses what projects it needs to install and its associated tables.

Therefore, the build time hibernate plugin is being updated to post process each project sql and add guards to the table creation to stop it trying to recreate tables that already exist.

Any superfluous drop statements will also be removed.
Comment 6 Julian Coleman 2013-11-14 11:50:58 EST

*** This bug has been marked as a duplicate of bug 1029007 ***

Note You need to log in before you can comment on or make changes to this bug.