Bug 1029007 - Remove multiple drop table statements and guard against multiple create table statements.
Remove multiple drop table statements and guard against multiple create table...
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Configuration (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity urgent
: ER7
: 6.0.0
Assigned To: Steve Johnson
Pavel Macik
:
: 1014562 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-11 08:18 EST by Steve Johnson
Modified: 2014-02-06 10:26 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-06 10:26:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Johnson 2013-11-11 08:18:56 EST
Description of problem:


As part of installation, a number SQL schemas are run against database account.  As these SQL files come from different projects and share some common tables they must not drop tables and also must be guarded against creating tables that already exist.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Run an installation and view sqlresults.log for sqlexceptions caused by multiple table creates and for the existence of drop table statements. 
2.
3.

Actual results:


Expected results:

That no sqlexceptions exist due to multiple table creates or that no drop table statements have been run.


Additional info:
Comment 2 Julian Coleman 2013-11-14 11:50:58 EST
*** Bug 1014562 has been marked as a duplicate of this bug. ***
Comment 3 Pavel Macik 2013-12-20 11:04:47 EST
Verified in ER7

Note You need to log in before you can comment on or make changes to this bug.