Bug 1014813 - Clicking through the package count view for a repo results in non-contextual/functional "Back to Results" button
Clicking through the package count view for a repo results in non-contextual/...
Status: CLOSED DUPLICATE of bug 1091844
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Walden Raines
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-02 16:35 EDT by Corey Welton
Modified: 2014-07-09 13:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-09 13:44:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2013-10-02 16:35:53 EDT
Description of problem:
When clicking through to package count/view for a repo, user is taken to what is basically a content search page.  On this page is a "Back to Results" button.  This button is out of context for this workflow (since user did not get here from a standard content search) and causes infinite cursor.

Version-Release number of selected component (if applicable):
katello 1.4.6-15.el6sat


How reproducible:


Steps to Reproduce:
1.  Create a provider, product, repo and upload some RPMs to it.
2.  Navigate to Content > Repositories > Products > $product_name
3.  On the ensuing product view page, click $product_name and click the number representing package count on that page.  OR just click the package count that exists on the main view itself.
4.  On the ensuing content view page, note the 'Back to Results' button
5.  Click button once, then twice.

Actual results:
Upon clicking, contents are cleared; upon clicking again, user gets an infinite spinner.

Expected results:
I'm not sure how to best handle this, but this button makes no sense, contextually, when a user gets here from this path.  If a user is using content search and gets to such a result, it makes sense, but when navigating in via a product/repo view, it does not.

Additional info:
Comment 2 Walden Raines 2014-06-12 09:24:18 EDT
This was filed before the bastion rewrite of these pages.  Please check to see if this is still applicable.
Comment 3 Walden Raines 2014-06-12 09:25:49 EDT
(In reply to Walden Raines from comment #2)
> This was filed before the bastion rewrite of these pages.  Please check to
> see if this is still applicable.

Just kidding, wrong bug.
Comment 4 Walden Raines 2014-07-09 13:44:26 EDT
Duplicate of bug #1091844

*** This bug has been marked as a duplicate of bug 1091844 ***

Note You need to log in before you can comment on or make changes to this bug.