Bug 1091844 - Content view: need to click "go back" twice to return from content Packages/Errata
Summary: Content view: need to click "go back" twice to return from content Packages/E...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Errata Management
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Walden Raines
QA Contact: sthirugn@redhat.com
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1014813 1115307 1118587 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-28 07:47 UTC by gaoshang
Modified: 2019-09-26 18:16 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:08:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 6391 None None None 2016-04-22 16:24:08 UTC
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description gaoshang 2014-04-28 07:47:22 UTC
Description of problem:
In "Content Views"-->"Content"-->"Repositories" page, click the Packages/Errata link, it will show all the Packages/Errata in this product, I need to click go back button in browser twice to go back to "Content Views" page.

the first click, url show in browser:
https://10.66.100.124/katello/content_search#/!=&search[subgrid][repo_id]=25&search[subgrid][type]=repo_packages&!=&envs[]=1
the second click, url show in browser:
https://10.66.100.124/katello/content_search#/!=&search[subgrid][repo_id]=25&search[subgrid][type]=repo_packages&!=

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. 
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 RHEL Program Management 2014-04-28 07:55:22 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Walden Raines 2014-06-25 18:12:15 UTC
Created redmine issue http://projects.theforeman.org/issues/6391 from this bug

Comment 4 Walden Raines 2014-07-07 15:54:32 UTC
PR: https://github.com/Katello/katello/pull/4394

Comment 5 Walden Raines 2014-07-07 17:33:19 UTC
commit 2981725d394f819c062f5cbedbe4402917620fc6
Merge: 7af1e2c 81020d7
Author: Walden Raines <walden@redhat.com>
Date:   Mon Jul 7 13:32:23 2014 -0400

    Merge pull request #4394 from waldenraines/6391
    
    Fixes #6391/BZ1091844 - use complete links for content search.

commit 81020d7bb364c1391494120a113984b7b527961d
Author: Walden Raines <walden@redhat.com>
Date:   Mon Jul 7 11:52:44 2014 -0400

    Fixes #6391/BZ1091844 - use complete links for content search.
    
    The links for content search were missing part of the required
    structure for the "back to results" button to function correctly.
    
    http://projects.theforeman.org/issues/6391
    https://bugzilla.redhat.com/show_bug.cgi?id=1091844

Comment 6 Walden Raines 2014-07-08 14:41:27 UTC
*** Bug 1115307 has been marked as a duplicate of this bug. ***

Comment 7 Jan Hutař 2014-07-08 21:57:07 UTC
QE: When testing this, please also test scenario from bug 1115307 which was closed as a duplicate of this one.

Comment 8 Walden Raines 2014-07-09 17:44:26 UTC
*** Bug 1014813 has been marked as a duplicate of this bug. ***

Comment 9 Walden Raines 2014-07-16 14:55:07 UTC
*** Bug 1118587 has been marked as a duplicate of this bug. ***

Comment 11 sthirugn@redhat.com 2014-09-04 14:35:11 UTC
Failed.  The back button did not take me back to content view.

Version Tested:
GA Snap 7 - Satellite-6.0.4-RHEL-6-20140829.0

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.23-1.el6_5.noarch
* candlepin-common-1.0.1-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.23-1.el6_5.noarch
* candlepin-tomcat6-0.9.23-1.el6_5.noarch
* elasticsearch-0.90.10-6.el6sat.noarch
* foreman-1.6.0.42-1.el6sat.noarch
* foreman-compute-1.6.0.42-1.el6sat.noarch
* foreman-gce-1.6.0.42-1.el6sat.noarch
* foreman-libvirt-1.6.0.42-1.el6sat.noarch
* foreman-ovirt-1.6.0.42-1.el6sat.noarch
* foreman-postgresql-1.6.0.42-1.el6sat.noarch
* foreman-proxy-1.6.0.30-1.el6sat.noarch
* foreman-selinux-1.6.0.14-1.el6sat.noarch
* foreman-vmware-1.6.0.42-1.el6sat.noarch
* katello-1.5.0-30.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.62-1.el6sat.noarch
* openldap-2.4.23-34.el6_5.1.x86_64
* openldap-devel-2.4.23-34.el6_5.1.x86_64
* pulp-katello-0.3-4.el6sat.noarch
* pulp-nodes-common-2.4.1-0.5.rc1.el6sat.noarch
* pulp-nodes-parent-2.4.1-0.5.rc1.el6sat.noarch
* pulp-puppet-plugins-2.4.1-0.5.rc1.el6sat.noarch
* pulp-puppet-tools-2.4.1-0.5.rc1.el6sat.noarch
* pulp-rpm-plugins-2.4.1-0.5.rc1.el6sat.noarch
* pulp-selinux-2.4.1-0.5.rc1.el6sat.noarch
* pulp-server-2.4.1-0.5.rc1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch

Comment 13 Bryan Kearney 2015-02-18 23:02:10 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6391 has been closed
-------------
Walden Raines
https://github.com/Katello/katello/pull/4394
-------------
Walden Raines
Applied in changeset commit:katello|81020d7bb364c1391494120a113984b7b527961d.

Comment 14 Walden Raines 2015-02-23 22:56:25 UTC
I am seeing this occurring when going back from any non-bastion page to a bastion page.  You can more easily reproduce this by simply going to Content -> Products and then Content -> Red Hat Repositories and clicking the back button.

Comment 15 Walden Raines 2015-03-13 15:35:11 UTC
Moving bugs I'm not currently working on back to NEW

Comment 16 Bryan Kearney 2015-08-25 17:56:38 UTC
Upstream bug component is Content Management

Comment 17 Bryan Kearney 2015-08-25 17:58:14 UTC
Upstream bug component is WebUI

Comment 18 Bryan Kearney 2015-08-25 20:02:49 UTC
Upstream bug component is WebUI

Comment 19 Bryan Kearney 2015-08-25 20:23:06 UTC
Upstream bug component is Errata Management

Comment 20 Walden Raines 2016-03-11 18:35:27 UTC
This bug is no longer valid because these content search links have been replaced with links to new pages.

Moving to ON_QA so QE can verify if they like.

Comment 21 sthirugn@redhat.com 2016-03-18 19:44:36 UTC
Verified in Satellite 6.2.0-beta-snap4.

Comment 24 errata-xmlrpc 2016-07-27 09:08:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.