Bug 1014951 - [abrt] homebank-4.5-3.fc20: homebank_lastopenedfiles_save: Process /usr/bin/homebank was killed by signal 6 (SIGABRT)
[abrt] homebank-4.5-3.fc20: homebank_lastopenedfiles_save: Process /usr/bin/h...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: homebank (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Filipe Rosset
Fedora Extras Quality Assurance
abrt_hash:0831ba8b0869e1473eb3fa51a12...
:
: 1031676 (view as bug list)
Depends On: 1009081
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 03:56 EDT by Kamil Páral
Modified: 2013-12-22 00:46 EST (History)
4 users (show)

See Also:
Fixed In Version: homebank-4.5.4-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-13 22:01:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (15.66 KB, text/plain)
2013-10-03 03:56 EDT, Kamil Páral
no flags Details
File: build_ids (3.36 KB, text/plain)
2013-10-03 03:57 EDT, Kamil Páral
no flags Details
File: cgroup (159 bytes, text/plain)
2013-10-03 03:57 EDT, Kamil Páral
no flags Details
File: core_backtrace (7.74 KB, text/plain)
2013-10-03 03:57 EDT, Kamil Páral
no flags Details
File: dso_list (8.65 KB, text/plain)
2013-10-03 03:57 EDT, Kamil Páral
no flags Details
File: environ (1.89 KB, text/plain)
2013-10-03 03:57 EDT, Kamil Páral
no flags Details
File: limits (1.29 KB, text/plain)
2013-10-03 03:57 EDT, Kamil Páral
no flags Details
File: maps (42.62 KB, text/plain)
2013-10-03 03:57 EDT, Kamil Páral
no flags Details
File: open_fds (661 bytes, text/plain)
2013-10-03 03:57 EDT, Kamil Páral
no flags Details
File: proc_pid_status (951 bytes, text/plain)
2013-10-03 03:57 EDT, Kamil Páral
no flags Details
File: var_log_messages (224 bytes, text/plain)
2013-10-03 03:57 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2013-10-03 03:56:55 EDT
Description of problem:
After upgrading from F19 to F20, I started homebank and it crashed immediately. I can start homebank if I remove ~/.config/homebank, but with my old database it crashes on start. I can't even manually pick the .xhb file.

Version-Release number of selected component:
homebank-4.5-3.fc20

Additional info:
reporter:       libreport-2.1.7
backtrace_rating: 4
cmdline:        homebank
crash_function: homebank_lastopenedfiles_save
executable:     /usr/bin/homebank
kernel:         3.11.2-301.fc20.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (2 frames)
 #5 homebank_lastopenedfiles_save at homebank.c:493
 #6 ui_mainwindow_open_internal at dsp_mainwindow.c:1419
Comment 1 Kamil Páral 2013-10-03 03:56:59 EDT
Created attachment 806907 [details]
File: backtrace
Comment 2 Kamil Páral 2013-10-03 03:57:03 EDT
Created attachment 806908 [details]
File: build_ids
Comment 3 Kamil Páral 2013-10-03 03:57:06 EDT
Created attachment 806909 [details]
File: cgroup
Comment 4 Kamil Páral 2013-10-03 03:57:09 EDT
Created attachment 806910 [details]
File: core_backtrace
Comment 5 Kamil Páral 2013-10-03 03:57:12 EDT
Created attachment 806911 [details]
File: dso_list
Comment 6 Kamil Páral 2013-10-03 03:57:16 EDT
Created attachment 806912 [details]
File: environ
Comment 7 Kamil Páral 2013-10-03 03:57:19 EDT
Created attachment 806913 [details]
File: limits
Comment 8 Kamil Páral 2013-10-03 03:57:22 EDT
Created attachment 806914 [details]
File: maps
Comment 9 Kamil Páral 2013-10-03 03:57:25 EDT
Created attachment 806915 [details]
File: open_fds
Comment 10 Kamil Páral 2013-10-03 03:57:28 EDT
Created attachment 806916 [details]
File: proc_pid_status
Comment 11 Kamil Páral 2013-10-03 03:57:32 EDT
Created attachment 806917 [details]
File: var_log_messages
Comment 12 Kamil Páral 2013-10-04 07:57:31 EDT
This can be trivially reproduced by purging ~/.config/homebank, then starting homebank and selecting "open an example database" in the welcome wizard.
Comment 13 Kamil Páral 2013-10-21 12:04:14 EDT
I removed these packages:
homebank-4.5-3.fc20.x86_64
libofx-0.9.9-1.fc20.x86_64

and manually downloaded and installed these packages from Fedora 19:
homebank-4.5-1.fc19.x86_64
libofx-0.9.5-4.fc19.x86_64

After that, homebank works ok even in Fedora 20. Therefore this really seems to be a problem in homebank.
Comment 14 Kamil Páral 2013-10-21 12:20:02 EDT
Maybe this could be a related upstream bug report?
https://bugs.launchpad.net/homebank/+bug/1103668

We need a new homebank release.
Comment 15 Jean-François Fortin Tam 2013-11-14 16:08:07 EST
Kamil: AFAIK there have been multiple homebank bugfix releases since then: http://homebank.free.fr/ChangeLog

someone needs to update the packages in Fedora...
Comment 16 Filipe Rosset 2013-11-14 16:09:00 EST
I'll update in next hours
Comment 17 Filipe Rosset 2013-11-14 21:57:08 EST
Hi guys, it's already fixed in master branch, but I'm unable to run fedpkg commands from the hotel network... I'm flying home tomorrow so I'll be able to fix everything next Saturday. Thanks.
Comment 18 Jean-François Fortin Tam 2013-11-15 08:15:09 EST
Cheers Filipe, much appreciated ;)
Comment 19 Kamil Páral 2013-11-26 04:06:51 EST
Hello Filipe, any updates on this?
Comment 20 Fedora Update System 2013-11-26 20:56:09 EST
homebank-4.5.4-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/homebank-4.5.4-1.fc20
Comment 21 Fedora Update System 2013-11-26 21:01:07 EST
homebank-4.5.4-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/homebank-4.5.4-1.fc19
Comment 22 Filipe Rosset 2013-11-26 21:05:00 EST
*** Bug 1031676 has been marked as a duplicate of this bug. ***
Comment 23 Kamil Páral 2013-11-27 07:26:06 EST
Thanks! Homebank finally starts and works.
Comment 24 Fedora Update System 2013-11-27 11:09:48 EST
Package homebank-4.5.4-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing homebank-4.5.4-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22266/homebank-4.5.4-1.fc20
then log in and leave karma (feedback).
Comment 25 Fedora Update System 2013-12-13 22:01:19 EST
homebank-4.5.4-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 26 Filipe Rosset 2013-12-21 15:29:52 EST
remove Flag: needinfo
Comment 27 Fedora Update System 2013-12-22 00:46:39 EST
homebank-4.5.4-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.