Bug 101504 - Mylex/buslogic driver missing
Mylex/buslogic driver missing
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Coughlan
Mike McLean
:
: 104683 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-01 19:08 EDT by Sander Steffann
Modified: 2007-11-30 17:06 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-18 20:34:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sander Steffann 2003-08-01 19:08:12 EDT
Description of problem:
The Mylex/buslogic driver is missing in the installation images. This makes it 
very difficult to install this RedHat Linux version in a VMWare virtual machine. 
The only solution seems to stop using SCSI virtual disks and switch to IDE.

Actual results:
No harddisks found during installation

Expected results:
Usable harddisks
Comment 1 Jeremy Katz 2003-08-01 21:28:32 EDT
This is because the buslogic driver is in kernel-unsupported which means that
it's not available during installation.
Comment 2 Dee-Ann LeBlanc 2003-08-06 12:19:19 EDT
Is it going to be added, Jeremy? It's awfully difficult to install under VMWare
without it.
Comment 3 Jonathan Schatz 2003-08-07 14:19:38 EDT
Voting doesn't seem to be enabled in this bugzilla installation, so consider
this a vote. What exactly determines when a piece of code goes into
kernel-unsupported? Is it based on Red Hat qa tests, or based on the actual
maintainer of that code?
Comment 4 Jonathan Schatz 2003-08-27 19:32:36 EDT
we've got a kb article about this now:

http://www.vmware.com/support/kb/enduser/std_adp.php?p_lva=&p_faqid=1101

hopefully this situation has changed w/ beta 2, but the ftp directories seem to
still be locked...
Comment 5 Jonathan Schatz 2003-08-28 18:27:19 EDT
driver is still missing. can anyone from redhat comment on this situation? is
there a way to make kernel-unsupported available to an installation?
Comment 6 Tom Coughlan 2003-08-29 08:53:01 EDT
We received some Mylex cards and did the QA, so the DAC960 driver was removed
from the unsupported list on Aug. 11.  Assuming this is the driver you are
referring to, it should be available in recent kernels.
Comment 7 Jonathan Schatz 2003-08-29 15:53:08 EDT
I can't seem to find any info in the kernel dosc about the DAC960 driver (the
Readme.Mylex points me to the Readme.Buslogic), but the generic buslogic support
is what we really need. If we send you some copies of vmware  to qa, could this
driver still make it into the final release?
Comment 9 Tom Coughlan 2003-09-03 15:30:48 EDT
We have a report that the BusLogic driver can crash the system when it is in
error recovery. In addition, this driver has not been maintained for years. This
is why the BusLogic driver is in the unsupported rpm.  

The drivers/block/DAC960 driver that I mentioned earlier is for a different
family of Mylex adapters (AcceleRAID/eXtremeRAID PCI RAID Controllers), so it
will not help with the VMWare issue.  Unless... Is it possible for VMWare to
switch to a more modern driver that is actually maintained?

The deadline for driver changes in RHEL 3 was over a month ago.  It is too late
to make any changes in this driver at this time.

It would appear that, for the initial release of RHEL 3, it will be necessary
for VMWare to use emulated IDE storage as opposed to emulated SCSI/BusLogic
storage. I understand that this imposes a performance penalty.  If it is not
possible for VMWare to change to a different driver, we will consider adding
support for the BusLogic driver in an update to the RHEL 3 release.
Comment 10 Tom Coughlan 2003-09-18 09:45:10 EDT
We agreed to remove the BusLogic driver from modules-unsupported, and add a
release note saying that the BusLogic driver is only supported with VMWare.  

VMWare will be responsible for all support matters on the BusLogic driver when
used in the VMWare VM, as well as any other problems that are are shown to
occcur only when running Linux as a guest o.s. in VMWare.
Comment 11 Jeremy Katz 2003-09-18 19:24:16 EDT
*** Bug 104683 has been marked as a duplicate of this bug. ***
Comment 12 Tim Burke 2003-09-18 20:34:07 EDT
Reopening to change the state from "closed deferred" to "closed currentrelease"
to note that this feature request was provided.
Comment 13 Jonathan Schatz 2003-10-01 16:28:54 EDT
I can confirm that this bug has been fixed in the release candidate.

Note You need to log in before you can comment on or make changes to this bug.