Bug 1015085 - [BEAKER] [0.15.0] New Matrix is skewed
[BEAKER] [0.15.0] New Matrix is skewed
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.15
Unspecified Unspecified
unspecified Severity urgent (vote)
: 0.15.1
: ---
Assigned To: Raymond Mancy
tools-bugs
: Regression
: 1014941 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 08:42 EDT by PaulB
Modified: 2014-12-07 20:16 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-23 03:00:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description PaulB 2013-10-03 08:42:55 EDT
Description of problem:
 Looking at matrix job view for Kernel Tier 1 testing,
tasks in task column are unclear and kernel/arch columns are not in line. 

Version-Release number of selected component (if applicable):
 Version 0.15.0

How reproducible:
 Consistently

Steps to Reproduce:
1. Open a matrix for a job with multiple tasks testing multiple arches

Actual results:
 Task text is unclear.
 Columns are not in line with header.

Expected results:
 Clear display of job matrix.

Additional info:
Comment 2 PaulB 2013-10-03 08:49:52 EDT
All,
Actually this is  a bit more problematic, as I am unable to scroll right in order to view the entire job :/

Best,
-pbunyan
Comment 4 Bill Peck 2013-10-03 09:01:53 EDT
The workaround is to disable javascript but this is painful because so much of beaker ui relies on it.  You can't even see task results because it relies on javascript.

As a *horrible* workaround I did this:

% firefox -new-instance -P matrix
(RHEL 6 firefox use -no-remote instead of -new-instance)

Create a new profile called matrix if it doesn't exist.

Turn off javascript in that version
about:config
toggle javascript enabled to off.

load the matrix page here..  and if you need to review any results you have to copy & paste the url to the other firefox instance that has javascript running.

Ugh.. This is extremely painful.
Comment 9 Raymond Mancy 2013-10-13 18:57:14 EDT
gerrit.beaker-project.org/#/c/2353
Comment 10 Raymond Mancy 2013-10-14 07:32:43 EDT
*** Bug 1014941 has been marked as a duplicate of this bug. ***
Comment 14 Nick Coghlan 2013-10-17 05:24:47 EDT
This is much improved, but still isn't quite rendering reliably across all browsers (the row alignment depends on how viewport scrollbars are added). Bug 1020198 covers that issue, since it isn't the same underlying problem as the original rendering bug that made the matrix completely unusable.
Comment 15 Raymond Mancy 2013-10-23 03:00:41 EDT
beaker 0.15.1 has been released.

Note You need to log in before you can comment on or make changes to this bug.