Bug 1015114 - Sorting columns in My subscription tab on Quantity is ambiguous
Sorting columns in My subscription tab on Quantity is ambiguous
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.0
Assigned To: candlepin-bugs
John Sefler
:
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2013-10-03 09:15 EDT by Sharath Dwaral
Modified: 2015-03-22 21:14 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-22 10:22:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sorting in My Subscription tab on Quantity (805.92 KB, image/png)
2013-10-03 09:15 EDT, Sharath Dwaral
no flags Details

  None (edit)
Description Sharath Dwaral 2013-10-03 09:15:50 EDT
Created attachment 807081 [details]
Sorting in My Subscription tab on Quantity

Description of problem:
Sorting columns in My subscription tab on Quantity is ambiguous. Not only do the subscriptions (parents) get sorted but also the stacked (children) quantities; which may be the expected behavior. 

If the Parent subscriptions are being sorted it is not clear on what criteria. This can be seen from the attachment.

Version-Release number of selected component (if applicable):
# subscription-manager version 
server type: Red Hat Subscription Management
subscription management server: 0.8.28-1
subscription-manager: 1.10.2-1.git.53.5d7d98f.el6
python-rhsm: 1.10.2-1.git.4.3048ab5.el6

How reproducible:
Always

Steps to Reproduce:
1. Edit facts so that subscriptions can be stacked
2. Stack different subscriptions from different group
3. Play with quantity header in My Subscription tab to sort them

Actual results:
See Attachment

Expected results:
It doesn't make sense to me why we are sorting on quantity in the first place when we have ignore it in "Contract Selection Window" and "All Available Subscriptions" tab. So I would prefer sorting on quantity be removed entirely.

If opted to retain this feature then it should be sorted in a better way as I find this to be confusing/ambiguous.

More Info:
https://bugzilla.redhat.com/show_bug.cgi?id=817938
Comment 2 Carter Kozak 2014-01-22 10:22:37 EST
This appears to be working as intended.  it sorts by quantity on root rows first, which is empty string when there is a stack header.  The child rows are sorted properly in that case, so I don't think there's a problem, or a better way we could do this.  We do not ever want to break apart stacks.

Note You need to log in before you can comment on or make changes to this bug.