Bug 1015192 - URGENT: Cannot provision after a "Take" of a system.
URGENT: Cannot provision after a "Take" of a system.
Status: CLOSED DUPLICATE of bug 1015328
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.15
All Unspecified
urgent Severity urgent (vote)
: ---
: ---
Assigned To: beaker-dev-list
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 11:34 EDT by Prarit Bhargava
Modified: 2014-08-12 00:32 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-03 23:03:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prarit Bhargava 2013-10-03 11:34:58 EDT
Description of problem:  Before the upgrade when I did a "take" of a system I was able to immediately provision the system.  After the upgrade, I "take" and then I see the following message under the provision tab:

"You do not have access to schedule a job on this system. "


Version-Release number of selected component (if applicable):0.15.0

How reproducible: 100%


Steps to Reproduce:
1. Take system (after verifying I am in the group)
2. Attempt to Provision.


Actual results: Cannot provision.


Expected results: I should be able to provision.


Additional info:  This is reproducible across several users in kernel engineering.  This should be treated as a critical bug.
Comment 2 Prarit Bhargava 2013-10-03 11:52:34 EDT
Working alongside bpeck ...

It looks like this is a permissions issue.  The system is owned by kernel-hw, but the kernel-hw group has not been properly added to the access policy by default.

P.
Comment 4 Nick Coghlan 2013-10-03 23:03:48 EDT
Indeed, it turns out the conversion scripts for the new ACLs didn't correctly migrate all existing permissions :(

*** This bug has been marked as a duplicate of bug 1015328 ***

Note You need to log in before you can comment on or make changes to this bug.