Bug 1015328 - 0.15 database migration for access policies is not complete
0.15 database migration for access policies is not complete
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: scheduler (Show other bugs)
0.15
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 0.15.1
: ---
Assigned To: Dan Callaghan
tools-bugs
:
: 1015129 1015192 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 19:25 EDT by Dan Callaghan
Modified: 2018-02-05 19:41 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-23 02:59:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Callaghan 2013-10-03 19:25:55 EDT
The SQL to migrate existing Shared/groups to access policies in the 0.15 upgrade notes is not complete. It doesn't add rules for:

* non-admin groups of shared systems => reserve permission
* admin groups of shared systems => all permissions
Comment 2 Nick Coghlan 2013-10-03 19:59:00 EDT
*** Bug 1015129 has been marked as a duplicate of this bug. ***
Comment 3 Nick Coghlan 2013-10-03 23:03:48 EDT
*** Bug 1015192 has been marked as a duplicate of this bug. ***
Comment 4 Dan Callaghan 2013-10-04 02:31:25 EDT
On Gerrit: http://gerrit.beaker-project.org/2331
Comment 5 Nick Coghlan 2013-10-10 04:18:05 EDT
The updated release notes are now online at http://beaker-project.org/docs-release-0.15/whats-new/upgrade-0.15.html#database-changes
Comment 7 wangjing 2013-10-15 02:42:59 EDT
verified on beaker-qe env Version 0.15.0(beaker-server-0.15.0-1.git.23.4a69b21.el6eng.noarch.rpm)-->pass

sinarios:
1. non-admin groups of shared systems => reserved permission to the group-->pass
2. admin groups of shared systems => all permissions to the group-->pass
3. admin groups of non-shared systems => all permissions to the group-->pass
4. non-group and shared systems => reserved permission to everybody-->pass
Comment 8 Raymond Mancy 2013-10-23 02:59:03 EDT
beaker 0.15.1 has been released.

Note You need to log in before you can comment on or make changes to this bug.