Bug 1015329 - Can't connect to management console
Can't connect to management console
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wildfly (Show other bugs)
20
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Marek Goldmann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 19:25 EDT by Eldar Yusupov
Modified: 2013-10-04 03:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-04 03:30:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eldar Yusupov 2013-10-03 19:25:58 EDT
Description of problem:
Unable to start console

Version-Release number of selected component (if applicable):
wildfly-8.0.0-0.9.Alpha4.fc20.noarch

How reproducible:
Always

Steps to Reproduce:
1. Start wildfly via service or via standalone.sh
2. Try to connect to localhost:9990/console

Actual results:
Error 404 is returned

Expected results:
Management console should appear

Additional info:

Info from server log:
22:01:45,200 WARN  [org.jboss.as.webservices] (ServerService Thread Pool -- 48) JBAS015506: Cannot load WS deployment aspects from /META-INF/stack-specific-deployment-aspects.xml
22:01:45,279 INFO  [org.jboss.as.server.deployment.scanner] (MSC service thread 1-5) JBAS015012: Started FileSystemDeploymentService for directory /usr/share/wildfly/standalone/deployments
22:01:45,290 INFO  [org.jboss.as.remoting] (MSC service thread 1-1) JBAS017100: Listening on 172.30.15.46:9999
22:01:45,293 ERROR [org.jboss.as.domain.http.api.undertow] (MSC service thread 1-7) JBAS015102: Unable to load console module for slot main, disabling console


It seems that the problem is that WildFly can't find file META-INF/stack-specific-deployment-aspects.xml in /usr/share/wildfly/modules/system/layers/base/org/jboss/as/webservices/main/jbossws-cxf-resources.jar

Comparing the file with the one from upstream package shows that in F20 package there are several directories for various jboss/wildfly versions:
     0 Tue Jan 01 00:00:00 GMT 1980 resources/jbossws-jboss712/
     0 Tue Jan 01 00:00:00 GMT 1980 resources/jbossws-jboss712/jbossws.beans/
     0 Tue Jan 01 00:00:00 GMT 1980 resources/jbossws-jboss712/jbossws.beans/META-INF/
  3834 Tue Jan 01 00:00:00 GMT 1980 resources/jbossws-jboss712/jbossws.beans/META-INF/jaxrpc-deployment-aspects.xml
  3706 Tue Jan 01 00:00:00 GMT 1980 resources/jbossws-jboss712/jbossws.beans/META-INF/stack-specific-deployment-aspects.xml
     0 Tue Jan 01 00:00:00 GMT 1980 resources/jbossws-jboss713/
     0 Tue Jan 01 00:00:00 GMT 1980 resources/jbossws-jboss713/jbossws.beans/
     0 Tue Jan 01 00:00:00 GMT 1980 resources/jbossws-jboss713/jbossws.beans/META-INF/
  3834 Tue Jan 01 00:00:00 GMT 1980 resources/jbossws-jboss713/jbossws.beans/META-INF/jaxrpc-deployment-aspects.xml
  3706 Tue Jan 01 00:00:00 GMT 1980 resources/jbossws-jboss713/jbossws.beans/META-INF/stack-specific-deployment-aspects.xml
....
     0 Tue Jan 01 00:00:00 GMT 1980 resources/jbossws-wildfly800/
     0 Tue Jan 01 00:00:00 GMT 1980 resources/jbossws-wildfly800/jbossws.beans/
     0 Tue Jan 01 00:00:00 GMT 1980 resources/jbossws-wildfly800/jbossws.beans/META-INF/
  3706 Tue Jan 01 00:00:00 GMT 1980 resources/jbossws-wildfly800/jbossws.beans/META-INF/stack-specific-deployment-aspects.xml

While in the upstream package jbossws-cxf-resources-4.2.0.Final-wildfly800.jar seems to contain only resources relevant to wildfly800 in the /META-INF directory:
     0 Fri Jul 26 18:52:48 MSK 2013 META-INF/
   313 Fri Jul 26 18:52:46 MSK 2013 META-INF/MANIFEST.MF
  3706 Fri Jul 26 18:52:46 MSK 2013 META-INF/stack-specific-deployment-aspects.xml
Comment 1 Marek Goldmann 2013-10-04 03:30:49 EDT
This is expected behavior, since the management console isn't packaged yet. The main reason is that we do not have GWT available in Fedora yet. Once GWT will become available - I'll do the packaging work for the console.

Note You need to log in before you can comment on or make changes to this bug.