Bug 1015436 - [portal.war] unable to update package content via UI
[portal.war] unable to update package content via UI
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Content (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity high
: ER05
: JON 3.2.0
Assigned To: Jirka Kremser
Mike Foley
:
: 1020884 (view as bug list)
Depends On:
Blocks: 1012435
  Show dependency treegraph
 
Reported: 2013-10-04 05:04 EDT by Libor Zoubek
Modified: 2015-11-01 19:43 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-02 15:34:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot IE9 (268.48 KB, image/png)
2013-10-22 08:01 EDT, Libor Zoubek
no flags Details

  None (edit)
Description Libor Zoubek 2013-10-04 05:04:54 EDT
Description of problem: Probably because portal.war was removed, I am not able to update package content via UI


Version-Release number of selected component (if applicable):
JON 3.2.0.ER2

How reproducible: always


Steps to Reproduce:
1. have some deployment on AS7
2. go to it's content and try to upload new version

Actual results: once you select "Upload package" and dialog for uploading new file pops up, then you upload a file, content of that dialog completely screws up. It shouws css styles or JSP, there is no way to finish the dialog


Expected results: you're able to upload file and continue, then package content get's updated


Additional info:
Comment 1 Jirka Kremser 2013-10-09 08:19:09 EDT
I had a lot of troubles with this issue, but at the end it worked well in FF, but was failing in Chrome. Because we don't support Chrome and this will be rewritten to GWT in the future versions, I wouldn't consider it as a bug / JON32 blocker.

Could you please try to reproduce it in IE9? I think, I was trying it and it worked, but I am not sure.
Comment 2 Libor Zoubek 2013-10-22 08:00:35 EDT
On IE9, I was able to select a file and upload it, but when I clicked the final "UPload package" I got an error

The page reauested cannot be displayed

/portal/rhq/resource/content/confirm-create-plain.xhtml
Comment 3 Libor Zoubek 2013-10-22 08:01:13 EDT
Created attachment 814953 [details]
screenshot IE9
Comment 5 Jirka Kremser 2013-10-29 13:34:43 EDT
branch:  release/jon3.2.x
link:    http://git.fedorahosted.org/cgit/rhq/rhq.git/commit/?id=5e686f214
time:    2013-10-29 18:32:44 +0100
commit:  5e686f21429e224669de50be81c89849ea5d452a
author:  Jirka Kremser - jkremser@redhat.com
message: [BZ 1015436] - [portal.war] unable to update package content via UI -
         JSF navigation rules magic (cherry picked from commit
         1ff05771a922f171f18be00cb634f092aa021c3c)

branch:  release/jon3.2.x
link:    http://git.fedorahosted.org/cgit/rhq/rhq.git/commit/?id=69a56fde7
time:    2013-10-29 18:33:14 +0100
commit:  69a56fde70b7212a372bf73063d73f4cbfeeea8a
author:  Jirka Kremser - jkremser@redhat.com
message: [BZ 1015436] - typo ("/" was missing) (cherry picked from commit
         4b256be9c4e29e340e720db5bff8a35c9680cce2)
Comment 6 Simeon Pinder 2013-11-06 21:18:03 EST
Moving to ON_QA for test with new brew build.
Comment 7 Libor Zoubek 2013-11-15 11:07:25 EST
verified on ER5 on IE9
Comment 9 Jirka Kremser 2014-02-21 10:59:38 EST
*** Bug 1020884 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.