Bug 1015441 - hp-setup freezes on hplip plugins installation
hp-setup freezes on hplip plugins installation
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
: 922808 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-04 05:16 EDT by Pavel Alexeev
Modified: 2014-01-08 02:58 EST (History)
4 users (show)

See Also:
Fixed In Version: hplip-3.13.11-4.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-13 22:39:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Alexeev 2013-10-04 05:16:09 EDT
Description of problem:
I have tried install HP LaserJet Pro M1536dnf RU scanner module (it is MFU). After install hplip I try add printer from toolbox or hp-setup. Gui window said it should install plugins and when I press "next" button it freezes (after some time even stop rendering correctly).
I think it should give me more info from console, but it also do nothing useful.
Scanner does not functional.

After manual download http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-3.13.9-plugin.run and run it as root it start work.

Version-Release number of selected component (if applicable):
3.13.9

How reproducible:
Always
Comment 1 sotnikov123 2013-10-25 09:01:33 EDT
(googl translator:) This problem stems from the fact that it is not necessary to set some GUI components:

hp-doctor setup next packets:


DEPENDENCY AND CONFLICT RESOLUTION
----------------------------------
Running 'su -c "yum -y -d 10 -e 1 install gcc-c++"'
Running 'su -c "yum -y -d 10 -e 1 install glibc-headers"'
Running 'su -c "yum -y -d 10 -e 1 install python-devel"'
Running 'su -c "yum -y -d 10 -e 1 install cups-devel"'
Running 'su -c "yum -y -d 10 -e 1 install libusb1-devel"'
Running 'su -c "yum -y -d 10 -e 1 install libtool"'
Running 'su -c "yum -y -d 10 -e 1 install cups-devel"'
Running 'su -c "yum -y -d 10 -e 1 install libjpeg-devel"'
Running 'su -c "yum -y -d 10 -e 1 install openssl-devel"'
Running 'su -c "yum -y -d 10 -e 1 install net-snmp-devel"'
Running 'su -c "yum -y -d 10 -e 1 install avahi-tools"'
Running 'su -c "yum -y -d 10 -e 1 install dbus-devel"'
Running 'su -c "yum -y -d 10 -e 1 install sane-backends-devel"'
Running 'su -c "yum -y -d 10 -e 1 install xsane"'
HPLIP uninstallation is completed

I may say what needs for resolve that. Full log in Russian language here:
http://forum.russianfedora.ru/viewtopic.php?f=14&t=5882#p39671

Resolve is:

1. 'yum install hplip-gui' gets something what is need for console python script "hp-doctor". hp-doctor is the part of hplip. hplip and hplip-gui is different packets in f19.

2. hp-doctor can't run from root in f19. But we can run from root script from official hp site:
http://hplipopensource.com/hplip-web/index.html
After running this script from ofsite gui works fine and printer is work.
Comment 2 Tim Waugh 2013-11-25 12:22:53 EST
hp-doctor moved to gui sub-package in hplip-3.13.11-fc19.
Comment 3 Fedora Update System 2013-11-25 12:44:06 EST
hplip-3.13.11-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2013-21939/hplip-3.13.11-3.fc20
Comment 4 Fedora Update System 2013-11-26 13:01:10 EST
Package hplip-3.13.11-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hplip-3.13.11-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21939/hplip-3.13.11-3.fc20
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-11-27 14:10:51 EST
hplip-3.13.11-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2013-21834/hplip-3.13.11-4.fc19
Comment 6 Fedora Update System 2013-11-27 14:30:52 EST
hplip-3.13.11-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2013-21827/hplip-3.13.11-4.fc18
Comment 7 Fedora Update System 2013-11-29 11:02:27 EST
Package hplip-3.13.11-4.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hplip-3.13.11-4.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21939/hplip-3.13.11-4.fc20
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-12-13 22:39:57 EST
hplip-3.13.11-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Tim Waugh 2014-01-02 10:22:33 EST
*** Bug 922808 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2014-01-07 04:40:27 EST
hplip-3.13.11-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2014-01-08 02:58:19 EST
hplip-3.13.11-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.