Bug 1015447 - Adding a iscsi data storage domain throws a invalid syntax for logical_unit.id property
Adding a iscsi data storage domain throws a invalid syntax for logical_unit.i...
Status: CLOSED DUPLICATE of bug 1015975
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Sergey Gotliv
Aharon Canan
: Triaged
Depends On:
  Show dependency treegraph
Reported: 2013-10-04 05:37 EDT by Carlos Mestre González
Modified: 2016-02-10 12:07 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-10-14 07:34:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Carlos Mestre González 2013-10-04 05:37:12 EDT
Description of problem:
as the title said, adding a iscsi via cli ends in a syntax error

Version-Release number of selected component (if applicable):

How reproducible:
command example: add storagedomain --host-name host1 --type data --storage-type iscsi  --name "scsi1" --storage-address test.redhat.com --storage-logical_unit "logical_unit.target=XXXX,logical_unit.address=,logical_unit.id_=1cmg01"

Steps to Reproduce:
1. Connect to RHEVM via cli
2. Add a iSCSI storage domain

Actual results:
error: "id_" is invalid segment at option "--logical_unit.id_=1cmg01".

Expected results:
The storage domain is added to the DC.

Additional info:
Example of test failing in our jenkins servers: http://jenkins.qa.lab.tlv.redhat.com:8080/view/Storage/view/3.3/job/3.3-storage_sanity_unittest-iscsi-cli/105/artifact/logs/cli_log.log
Comment 1 Ayal Baron 2013-10-06 02:46:30 EDT
Please remove the trailing underscore from: logical_unit.id_=1cmg01
i.e. logical_unit.id=1cmg01
Comment 2 Carlos Mestre González 2013-10-07 02:49:41 EDT
That was the wrong command that I pasted in the bug's description, the output happens when I use logical_unit.id=1cmg01 without underscore.
Comment 3 Carlos Mestre González 2013-10-07 04:15:10 EDT
Please, notice to the Additional info link that contains the cli log for our storage sanity test, and the end of the log appears the same problem.

Here is the rhevm log: http://jenkins.qa.lab.tlv.redhat.com:8080/view/Storage/view/3.3/job/3.3-storage_sanity_unittest-iscsi-cli/108/artifact/logs/server.log
Comment 4 Michael Pasternak 2013-10-14 07:34:57 EDT

*** This bug has been marked as a duplicate of bug 1015975 ***

Note You need to log in before you can comment on or make changes to this bug.