Bug 1015553 - Display appropriate help text for the list --available filter --no-overlap
Display appropriate help text for the list --available filter --no-overlap
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Carter Kozak
John Sefler
:
: 1015970 (view as bug list)
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2013-10-04 09:38 EDT by Rehana
Modified: 2014-09-14 20:09 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 09:31:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rehana 2013-10-04 09:38:35 EDT
Description of problem:
Observed that the help text displayed for the option --no-overlap  is not verify clear

Version-Release number of selected component (if applicable):
subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.29-1
subscription-manager: 1.10.3-1.git.0.c59a391.el7
python-rhsm: 1.10.3-1.git.0.6ac2883.el7


How reproducible:
always

Steps to Reproduce:
1.Execute subscription-manager list --help
2.
3.

Actual results:
Observed that the help text displayed is 
" --no-overlap          show pools with this text in the name"

Expected results:
Should display appropriate help text 

Additional info:
Also would like to suggest adding "only used with --available" to the filter option's(--no-overlap,--match-installed) help text, as there are used only with --available option

Currently we display similar details for --on-date option
--ondate=ON_DATE      date to search on, defaults to today's date, only used
                        with --available (example: 2013-10-04)
Comment 1 Carter Kozak 2013-10-08 09:44:12 EDT
commit 4b7116f7d10bddfe22437f85e8c80fbbb342676f
Author: ckozak <ckozak@redhat.com>
Date:   Fri Oct 4 09:56:06 2013 -0400

    1015553: fix help message for no-overlap. display usage requirement
Comment 2 Carter Kozak 2013-10-08 09:47:17 EDT
*** Bug 1015970 has been marked as a duplicate of this bug. ***
Comment 5 Sharath Dwaral 2013-10-15 11:26:26 EDT
commit 4b7116f7d10bddfe22437f85e8c80fbbb342676f

Is not in the latest brew build of sub-man 

# subscription-manager version
subscription-manager: 1.10.3-1.el7


Moving back to POST
Comment 6 Sharath Dwaral 2014-01-24 11:32:09 EST
Version:

# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.2-1
subscription-manager: 1.10.11-1.git.2.e96f6cd.el7
python-rhsm: 1.10.11-1.git.0.17362f9.el7

Verification:

# subscription-manager list --help
Usage: subscription-manager list [OPTIONS]

List subscription and product information for this system

Options:
  -h, --help            show this help message and exit
  --proxy=PROXY_URL     proxy URL in the form of proxy_hostname:proxy_port
  --proxyuser=PROXY_USER
                        user for HTTP proxy with basic authentication
  --proxypassword=PROXY_PASSWORD
                        password for HTTP proxy with basic authentication
  --installed           list shows those products which are installed
                        (default)
  --available           show those subscriptions which are available
  --all                 used with --available to ensure all subscriptions are
                        returned
  --ondate=ON_DATE      date to search on, defaults to today's date, only used
                        with --available (example: 2014-01-24)
  --consumed            show the subscriptions being consumed by this system
  --servicelevel=SERVICE_LEVEL
                        shows only subscriptions matching the specified
                        service level; only used with --available and
                        --consumed

  --no-overlap          shows pools which provide products that are not <<<<<<< 
                        already covered; only used with --available     <<<<<<<<

  --match-installed     shows only subscriptions matching products that are
                        currently installed; only used with --available
                                                            ^^^^^^^^^^^^ 


VERIFIED
Comment 7 Ludek Smid 2014-06-13 09:31:00 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.