Bug 1015970 - help message for --all should be changed to be in sync with --servicelevel and --ondate
help message for --all should be changed to be in sync with --servicelevel an...
Status: CLOSED DUPLICATE of bug 1015553
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Carter Kozak
John Sefler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-07 03:17 EDT by Shwetha Kallesh
Modified: 2014-09-14 20:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 09:47:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shwetha Kallesh 2013-10-07 03:17:14 EDT
Description of problem:
help message for --match-installed  and --all should be changed to be in sync with --servicelevel and --ondate 

Version-Release number of selected component (if applicable):
[root@localhost ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.27-1
subscription-manager: 1.10.3-1.git.0.c59a391.el7
python-rhsm: 1.10.3-1.git.0.6ac2883.el7


How reproducible:


Steps to Reproduce:
[root@localhost ~]# subscription-manager list --help
Usage: subscription-manager list [OPTIONS]

List subscription and product information for this system

Options:
  -h, --help            show this help message and exit
  --proxy=PROXY_URL     proxy URL in the form of proxy_hostname:proxy_port
  --proxyuser=PROXY_USER
                        user for HTTP proxy with basic authentication
  --proxypassword=PROXY_PASSWORD
                        password for HTTP proxy with basic authentication
  --installed           list shows those products which are installed
                        (default)
  --available           show those subscriptions which are available
  --all                 used with --available to ensure all subscriptions are
                        returned
  --ondate=ON_DATE      date to search on, defaults to today's date, only used
                        with --available (example: 2013-10-07)
  --consumed            show the subscriptions being consumed by this system
  --servicelevel=SERVICE_LEVEL
                        shows only subscriptions matching the specified
                        service level; only used with --available and
                        --consumed
  --no-overlap          show pools with this text in the name
  --match-installed     shows only subscriptions matching products that are
                        currently installed


Actual results:
--match-installed     shows only subscriptions matching products that are
                        currently installed
--all                 used with --available to ensure all subscriptions are
                        returned
Expected results:
--match-installed     shows only subscriptions matching products that are
                        currently installed,only used with --available
--all                 used with --available to ensure all subscriptions are
                        returned,only used with --available

Just like --servicelevel and --ondate 

Additional info:
Comment 2 Carter Kozak 2013-10-08 09:47:17 EDT
Not an exact duplicate, but this was addressed in bz 1015553

*** This bug has been marked as a duplicate of bug 1015553 ***

Note You need to log in before you can comment on or make changes to this bug.