Bug 1015598 - D-Link System DWA-131 is not recognised as a wireless adapter
D-Link System DWA-131 is not recognised as a wireless adapter
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 1019525 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-04 10:56 EDT by Saggi Mizrahi
Modified: 2015-03-02 00:23 EST (History)
4 users (show)

See Also:
Fixed In Version: NetworkManager-0.9.9.0-17.git20131003.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-18 16:06:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Network manager window (24.32 KB, image/png)
2013-10-04 10:57 EDT, Saggi Mizrahi
no flags Details

  None (edit)
Description Saggi Mizrahi 2013-10-04 10:56:07 EDT
Description of problem:
After upgrading to f20 my dlink usb adapter stopped being recognized as a wireless adapter and is only recognized as an Ethernet adapter.

Since iwconfig recognizes it I assume it's a NetworkManager problem.

$ lsusb
....
Bus 003 Device 007: ID 07d1:3303 D-Link System DWA-131 802.11n Wireless N Nano Adapter(rev.A1) [Realtek RTL8192SU]
....

$ iwconfig 
enp0s20u4  unassociated  Nickname:"rtl_wifi"
          Mode:Auto  Access Point: Not-Associated   Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
lo        no wireless extensions.

em1       no wireless extensions.

$ dmesg |grep firmw
[    3.551592] usb 3-2: r8712u: Loading firmware from "rtlwifi/rtl8712u.bin"

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Saggi Mizrahi 2013-10-04 10:57:58 EDT
Created attachment 807728 [details]
Network manager window

Here showing the network manager window showing it as an ethernet instead of a wireless adapter
Comment 2 Dan Williams 2013-10-04 16:28:20 EDT
What does 'iw dev enp0s20u4 info' say?

Also, what does "journalctl -b | grep WEXT" say?

Next, what does "iwgetid --protocol" say?
Comment 3 Saggi Mizrahi 2013-10-04 18:16:11 EDT
$ iw dev enp0s20u4 info
command failed: No such device (-19)

$ journalctl -b | grep WEXT
Oct 04 17:10:03 funkotron NetworkManager[773]: <info> WEXT support is enabled

$ iwgetid --protocol
<no output>
Comment 4 Dan Williams 2013-10-16 11:43:38 EDT
*** Bug 1019525 has been marked as a duplicate of this bug. ***
Comment 5 Dan Williams 2013-10-16 12:04:19 EDT
cb-rhbugz@fishzet.co.uk, what does your device report for:

iwconfig wlan0

?
Comment 6 cb-rhbugz 2013-10-16 12:11:06 EDT
$ iwconfig wlan0
wlan0     802.11bgn  Nickname:"rtl8192E"
          Mode:Managed  Frequency=2.417 GHz  Access Point: Not-Associated   
          Bit Rate:1 Mb/s   
          Retry min limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=10/100  Signal level=0 dBm  Noise level=-100 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
Comment 7 Dan Williams 2013-10-16 13:23:08 EDT
Also, everyone please run:

cat /sys/class/net/wlan0/uevent

and report the output.  Thanks!
Comment 8 Dan Williams 2013-10-16 13:30:44 EDT
I believe I've fixed the problem upstream, the fix will appear in the next snapshot.
Comment 9 cb-rhbugz 2013-10-16 13:32:31 EDT
I get:

$ cat /sys/class/net/wlan0/uevent
INTERFACE=wlan0
IFINDEX=3
Comment 10 cb-rhbugz 2013-11-03 17:30:20 EST
FWIW, this horrible script can be used to work around the problem.

#!/bin/bash

rm -Rf /tmp/nmhack
mkdir /tmp/nmhack
echo 'DEVTYPE=wlan' > /tmp/nmhack/uevent
grep INTERFACE /sys/class/net/wlan0/uevent >> /tmp/nmhack/uevent
grep IFINDEX /sys/class/net/wlan0/uevent >> /tmp/nmhack/uevent
mount --bind /tmp/nmhack/uevent /sys/class/net/wlan0/uevent

systemctl restart NetworkManager
Comment 11 Fedora Update System 2013-11-14 12:40:35 EST
NetworkManager-0.9.9.0-17.git20131003.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/NetworkManager-0.9.9.0-17.git20131003.fc20
Comment 12 Fedora Update System 2013-11-16 02:12:55 EST
Package NetworkManager-0.9.9.0-17.git20131003.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.9.9.0-17.git20131003.fc20'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21504/NetworkManager-0.9.9.0-17.git20131003.fc20
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2013-11-18 16:06:48 EST
NetworkManager-0.9.9.0-17.git20131003.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.