Bug 1019525 - NetworkManager treats wifi as wired ethernet. Wifi doesn't work
NetworkManager treats wifi as wired ethernet. Wifi doesn't work
Status: CLOSED DUPLICATE of bug 1015598
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
20
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 20:21 EDT by cb-rhbugz
Modified: 2013-10-16 11:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-16 11:43:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cb-rhbugz 2013-10-15 20:21:58 EDT
Description of problem:
NetworkManager treats wifi as wired ethernet. Wifi doesn't work.

Version-Release number of selected component (if applicable):
NetworkManager-0.9.9.0-14.git20131003.fc20.i686

How reproducible:
100%

Steps to Reproduce:
1. Boot computer
2. Log in to XFCE (or Gnome but the network UI is less useful...)
3. Click on Network Manager applet

Actual results:
Wifi card is listed as: Ethernet network (Realtek RTL8192E/RTL8192SE)
No list of wireless networks is presented
Can also be seen using nmcli:
$ nmcli d
DEVICE  TYPE      STATE       
p4p1    ethernet  connected   
wlan0   ethernet  unavailable 
lo      loopback  unmanaged   


Expected results:
Realtek RTL8192E adaptor listed as wireless ethernet. List of wireless networks displayed in nm applet.

Additional info:
Computer is a Samsung N140 Atom Netbook from 2009. It was previously working with Fedora 19. Upgraded from Fedora 19 using fedup on 15/10/2013.
Comment 1 Dan Williams 2013-10-16 11:43:38 EDT

*** This bug has been marked as a duplicate of bug 1015598 ***

Note You need to log in before you can comment on or make changes to this bug.