This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1015883 - Can't shutdown Acer Aspire S7 392
Can't shutdown Acer Aspire S7 392
Status: CLOSED DUPLICATE of bug 1031331
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
20
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-06 09:51 EDT by Josh Chia
Modified: 2013-12-26 20:29 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-26 16:32:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Chia 2013-10-06 09:51:03 EDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.76 Safari/537.36
Build Identifier: 

If I try to shutdown, the shutdown sequence gets stuck at "reboot: Power down" but power-down doesn't actually happen.

Reproducible: Always

Steps to Reproduce:
1. Boot with kernel option "acpi_backlight=vendor". This is necessary or else the machine just gives a black screen (https://bugzilla.redhat.com/show_bug.cgi?id=1015881).
2. Login.
3. Try to shutdown from console with "sudo shutdown -h now".

Actual Results:  
Text shutdown sequence is shown, with final line "reboot: Power down", but no actual power-down.


Expected Results:  
Actual power-down.
Comment 1 Michele Baldessari 2013-11-17 14:04:06 EST
Can you try passing the various reboot= options and see if one of them work?
They are:

warm, cold, bios, smp, acpi, efi, pci, force, kbd, triple

I would start with acpi, efi, and pci as those are the most common working options.

What laptop is this?

Seems similar to:
https://bugzilla.redhat.com/show_bug.cgi?id=1031331
Comment 2 Michele Baldessari 2013-12-25 13:22:24 EST
Hi Josh,

can you try kernel 3.12.6 which has the following commit:

commit 2ab0ff9b179aadf1f30f2dfa9db2b9404324e135
Author: Khalid Aziz <khalid.aziz@oracle.com>
Date:   Wed Nov 27 15:19:25 2013 -0700

    PCI: Disable Bus Master only on kexec reboot
    
    commit 4fc9bbf98fd66f879e628d8537ba7c240be2b58e upstream.


Some reports seem to indicate that Acer laptops are able to shutdown with that
patch.

You can find the kernel here:
http://koji.fedoraproject.org/koji/buildinfo?buildID=486642

Thanks and regards,
Michele
Comment 3 Michele Baldessari 2013-12-26 16:32:39 EST

*** This bug has been marked as a duplicate of bug 1031331 ***
Comment 4 Josh Chia 2013-12-26 20:29:58 EST
3.12.6 fixes the problem for me

Note You need to log in before you can comment on or make changes to this bug.