Bug 1031331 - Shutdown, init 0, or poweroff of Fedora 19 (64bit) won't Power Off laptop ...
Shutdown, init 0, or poweroff of Fedora 19 (64bit) won't Power Off laptop ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
http://bit.ly/1ijN0hP
:
: 1015883 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-16 17:41 EST by prismalytics
Modified: 2015-09-12 01:21 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-06 08:52:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is what the final stages of "init 0" or "poweroff" look like. (1.53 MB, image/jpeg)
2013-11-16 20:21 EST, prismalytics
no flags Details

  None (edit)
Description prismalytics 2013-11-16 17:41:06 EST
Description of problem:
I have an Acer Aspire S7 laptop on which I installed Fedora 19 64bit (complete DVD). It's running kernel version: 3.11.7-200, but the below problem has
existed in prior kernel versions, too.

The problem:
Power Off of the laptop doesn't happen after "init 0"/"shutdown"/"poweroff":

When I shut down the O/S gracefully -- either by executing any of the shut down
commands, or press/releasing the power button -- the Fedora O/S shuts down gracefully, but it does not power off this laptop. This, despite acpid running (maybe I don't have it configured properly).

I have to press-and-hold the power button for 5 seconds after Fedora
finally indicates that it's okay to physically power off the laptop.

For comparative purposes, I booted Windows-7 64bit on the same laptop,
and issuing a shut down sequence there does, indeed, automatically power off
the laptop. No press and hold of the power button is needed.

Version-Release number of selected component (if applicable):
Fedora 19 x86_64;
Kernel: 3.11.7-200 and prior versions.

How reproducible:
Every single time.

Steps to Reproduce:
1. sudo init 0
2. sudo poweroff
3. press and (immediate) release of power button
4. etc.

Actual results:
The in-memory Fedora O/S itself shuts down, but the laptop does
not get powered down. Press-and-hold of the power button is necessary.

Expected results:
After O/S shutdown, power down of the laptop as well, without needing
to press-and-hold the power button.

Additional info:
Additional information was pasted on my ask.fedoraproject.org post:
http://bit.ly/1ijN0hP
Comment 1 Michele Baldessari 2013-11-16 18:25:05 EST
Can you try passing the various reboot= options and see if one of them work?
They are:

warm, cold, bios, smp, acpi, efi, pci, force, kbd, triple

I would start with acpi, efi, and pci as those are the most common working options.
Comment 2 prismalytics 2013-11-16 20:21:39 EST
Created attachment 825033 [details]
This is what the final stages of "init 0" or "poweroff" look like.

This is what the final stages of "init 0" or "poweroff" look like (attached picture).
Comment 3 prismalytics 2013-11-16 20:22:07 EST
Hi Michele:

Thank you. Per your suggestion I just now tried all of those options.

(1) At laptop power on, I pressed 'e' to enter GRUB edit mode, and
    appended 'reboot=xxx' to the end of the  kernel options line.

(2) Then I issued 'Ctrl-x' to boot with that modified parameters list.
    Once booted, I confirmed that my options took effect by inspecting
    the output of 'cat /proc/cmdline'.

(3) Then did 'init 0' or 'poweroff'.

Sadly, non of the options enabled the laptop to automatically power off.

Btw, for completness, I'll be attaching an image of what the final lines
after an 'init 0'/poweroff' look like.

Thank you!
Comment 4 Michele Baldessari 2013-11-17 06:15:36 EST
Hi,

odd. Usually one of the different reboot options fixes poweroff/reboot issues.
Out of curiosity, if you disable VT-d in your BIOS does this work?

Thanks,
Michele
Comment 5 prismalytics 2013-11-19 23:47:47 EST
Hi Michele:
 
The BIOS for the Acer Aspire S7 is pretty lean, meaning that there aren't too many options. And so to answer your question, there is no VT-d setting in my
BIOS to turn off or on..

I agree it's rather odd since booting a Live Windows-7 environment off a
USB stick that, when created, wasn't even Windows-updated (ever), works
fine. And that un-patched image came out years before this laptop.

So I'm with you that there's probably something simple to try to
get this to work with Fedora similarly.

Btw, here is my Grub2 entry (maybe that will help enlighten):

===========================================================
menuentry 'Fedora (3.11.7-200.fc19.x86_64) 19 (Schrödinger’s Cat)' --class fedora --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-3.9.5-301.fc19.x86_64-advanced-11ec043a-b629-47f3-894d-51482cd25efe' {
	load_video
	set gfxpayload=keep
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='hd1,msdos1'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint='hd1,msdos1'  11ec043a-b629-47f3-894d-51482cd25efe
	else
	  search --no-floppy --fs-uuid --set=root 11ec043a-b629-47f3-894d-51482cd25efe
	fi
	linux	/boot/vmlinuz-3.11.7-200.fc19.x86_64 root=UUID=11ec043a-b629-47f3-894d-51482cd25efe ro nomodeset rd.lvm=0 rd.dm=0 vconsole.keymap=us rd.md.uuid=3b7012ae:6873d811:b4213467:eb30e2b8  rd.md.uuid=182257f6:5fcc321b:a217a1aa:4a48fb9d rd.luks=0 vconsole.font=latarcyrheb-sun16 LANG=en_US.UTF-8 quiet selinux=0 acpi_backlight=vendor
	initrd /boot/initramfs-3.11.7-200.fc19.x86_64.img
}
================================================================

Remember that I tried each of the 'reboot=xxx' options suggested.

Thank you.
Comment 6 prismalytics 2013-12-15 16:42:35 EST
Hello... I was wondering if there is any progress on this.

Thank you.
Comment 7 George 2013-12-19 22:08:50 EST
I'm having the exact same issues on an Acer V5-573.
It looks like other distributions were having similar issues but reported they would be fixed in kernel 3.12.x.   I've installed the updates-testing 3.12.5 but I still can't shutdown the laptop.
Also reported that it may be BIOS related and I've updated to the most recent bios but still no luck.

Any updates?
Comment 8 prismalytics 2013-12-20 11:29:29 EST
George, I read the same thing about other distributions fixing the issue too, so I was hopeful.

I do wish the severity of this would be escalated because, in my case and quite likely other's too, a combination of this Power Off issue **and** the inability to Suspend/Resume VIDEO on this same ACER-S7 laptop (a bug that I reported here:
https://bugzilla.redhat.com/show_bug.cgi?id=1031335 ), I can't avoid this
Power Off bug even if I tried. Meaning ....

  ... because on this same ACER laptop VIDEO Suspend/Resume doesn't work, I HAVE to always Power off the laptop -- I can't simply Suspend or Hibernate it because (as the above bug URL explains), it won't Resume. So I HAVE to always shut down the O/S and then press & hold the power button. I hate doing that with life-sensitive SSD drives. :-(

I would appreciate help of the generous Fedora team. :). Thanks in advance!
Comment 9 prismalytics 2013-12-21 22:10:24 EST
FYI: After upgrading from Fedora-19 to Fedora-20, and now running kernel version 3.12.5-302.fc20.x86_64, the problem still persists.
Comment 10 George 2013-12-22 18:07:50 EST
FYI

Looks powerdown in ACER V5/V7s and other issues may be fixed in kernel 3.13.

https://bugzilla.kernel.org/show_bug.cgi?id=63861
Comment 11 George 2013-12-22 18:50:59 EST
FYI
I've just installed the 3.13 kernel from rawhide and shutdown appears to work.
It would be good to get 3.13 pushed to general availability.
Comment 12 prismalytics 2013-12-22 23:53:23 EST
Thanks George. The bug you sited doesn't mention the "Acer S7", but I hope it works for my case, too. =:)

Can you paste your "/etc/yum.repos.d/rawhide.repo" contents for me, please?

REASON: I installed the Rawhide repo, but a 'yum update' shows only a
newer kernel for "3.12.5-302.fc21" (i.e. "3.12" but not "3.13" as you
listed).

Thank you!
Comment 13 George 2013-12-23 02:57:06 EST
Hi nmvega,

The rawhide repository is not enabled by default so the following line should let you install the kernel

yum --enablerepo rawhide update kernel

(That's what I used)
If you still have problems then let me know and I'll paste my rawhide.repo.

Regards,
Comment 14 George 2013-12-23 03:00:27 EST
Perhaps the repository mirror you are using is not totally up to date and the new kernel will sync in the next day or so.
Comment 15 Michele Baldessari 2013-12-23 04:44:29 EST
The patch mentioned in the kernel.org bugzilla has made it in 3.12.6
commit 2ab0ff9b179aadf1f30f2dfa9db2b9404324e135
Author: Khalid Aziz <khalid.aziz@oracle.com>
Date:   Wed Nov 27 15:19:25 2013 -0700

    PCI: Disable Bus Master only on kexec reboot
    
    commit 4fc9bbf98fd66f879e628d8537ba7c240be2b58e upstream.


So once that kernel makes it to Fedora we can confirm if it fixes things or not.
Comment 16 prismalytics 2013-12-23 13:47:01 EST
Thanks George
Thanks Michele

George: Yes I did have the Rawhide repository enabled when I issued the "yum update" (but thank you). Given what Michele just added about the patch (good news for my Acer Aspire-S7 too I hope), I just sit tight for "3.12.6" in the Fedora updates repo.

I'll keep you guys/gals posted when it arrives.

Thank you!
Comment 17 Josh Boyer 2013-12-24 09:22:09 EST
3.12.6 is built in koji now.
Comment 18 George 2013-12-25 21:59:13 EST
Shutdown appears to be working in 3.12.6 available from updates-testing.
I'm sure all fedora users with shiny new Acer laptops at Christmas thank you.
I didn't expect this out over the holiday period so well done the Fedora crew.
Comment 19 prismalytics 2013-12-25 23:48:43 EST
Same here: I can confirm that for my ACER Aspire-S7 model, Shutdown, init 0, and poweroff appear to now work with kernel "3.12.6" (also installed from fedora-updates-testing repo).

Well done, and thank you very much team-Fedora and contributors! This bug appears to be solved.

Thank you.
Comment 20 Michele Baldessari 2013-12-26 13:12:30 EST
Perfect, thanks everyone for confirming. 

I assume this will be closed via the usual Errata process, so I'll leave
things as is.
Comment 21 Michele Baldessari 2013-12-26 16:32:39 EST
*** Bug 1015883 has been marked as a duplicate of this bug. ***
Comment 22 prateek.1.kohli 2015-06-15 10:03:24 EDT
hello All, I have Acer ES1 512 and exatly same issue is appearing.

[root@localhost /]# uname -sr
Linux 4.0.4-303.fc22.x86_64

Has this issue regressed?

Note You need to log in before you can comment on or make changes to this bug.