This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1015944 - Registration fails when using activation key
Registration fails when using activation key
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Ivan Necas
Hayk Hovsepyan
: Triaged
: 1012875 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-07 00:31 EDT by Mike McCune
Modified: 2014-04-24 13:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch fixing using actionvation key with rh content (786 bytes, patch)
2013-10-07 11:07 EDT, Ivan Necas
no flags Details | Diff

  None (edit)
Description Mike McCune 2013-10-07 00:31:00 EDT
1) Create a content view, publish and promote to an environment

2) Create an activation key that points at the above ENV/CV from step 1

3) register a system with that activation key:

# subscription-manager register --org localsync --activationkey akey1  --force
undefined method `provider' for nil:NilClass

errors:


[ERROR 2013-10-06 23:42:50 app 0cf1f3272a1cb4def715f123f87dc103 #32337] Autosubscribtion failed, rolling back: []
[ERROR 2013-10-06 23:42:51 app 0cf1f3272a1cb4def715f123f87dc103 #32337] NoMethodError: undefined method `provider' for nil:NilClass
 | /usr/share/katello/app/models/activation_key.rb:85:in `calculate_consumption'
 | /usr/share/katello/app/models/activation_key.rb:118:in `block in subscribe_system'
 | /usr/share/katello/app/models/activation_key.rb:115:in `each'
 | /usr/share/katello/app/models/activation_key.rb:115:in `subscribe_system'
 | /usr/share/katello/app/controllers/api/v1/systems_controller.rb:142:in `block (2 levels) in activate'
 | /usr/share/katello/app/controllers/api/v1/systems_controller.rb:141:in `each'
 | /usr/share/katello/app/controllers/api/v1/systems_controller.rb:141:in `block in activate'
 | /opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/connection_adapters/abstract/database_statements.rb:192:in `transaction'
 | /opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/transactions.rb:208:in `transaction'
 | /usr/share/katello/app/controllers/api/v1/systems_controller.rb:132:in `activate'
Comment 2 Ivan Necas 2013-10-07 11:07:01 EDT
Created attachment 808879 [details]
Patch fixing using actionvation key with rh content

Here is a patch that the quick fix should be based on (after adding tests and sending PR).

The proper fix should be better handling of marketing vs engineering products, but this is too much work for fixing the current issue (trello card created
https://trello.com/c/CEgJzLia/221-clear-fix-marketing-engineering-products-handling-for-custom-products )
Comment 3 Mike McCune 2013-10-07 11:51:15 EDT
https://github.com/Katello/katello/pull/3101
Comment 6 Mike McCune 2013-10-07 16:39:07 EDT
*** Bug 1012875 has been marked as a duplicate of this bug. ***
Comment 7 Hayk Hovsepyan 2013-10-09 11:04:50 EDT
Verified on revision:
signo-0.0.20-3.el6sat.noarch
Katello-Katello-Installation-RegisterRHNClassic-1.1-4.noarch
foreman-1.3.0-13.el6sat.noarch
katello-cli-1.4.3-18.el6sat.noarch
openldap-2.4.23-31.el6.x86_64
python-ldap-2.3.10-1.el6.x86_64
katello-certs-tools-1.4.4-1.el6sat.noarch
pulp-nodes-parent-2.3.0-0.17.beta.el6sat.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-tomcat6-0.8.25-1.el6sam.noarch
signo-katello-0.0.20-3.el6sat.noarch
katello-selinux-1.4.4-4.el6sat.noarch
ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
candlepin-cert-consumer-dionysus.usersys.redhat.com-1.0-1.noarch
Katello-Katello-Installation-Satellite6Latest-1.0-12.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
apr-util-ldap-1.3.9-3.el6_0.1.x86_64
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
foreman-proxy-1.3.0-2.el6sat.noarch
foreman-postgresql-1.3.0-13.el6sat.noarch
katello-cli-common-1.4.3-18.el6sat.noarch
katello-configure-1.4.5-9.el6sat.noarch
pulp-server-2.3.0-0.17.beta.el6sat.noarch
pulp-nodes-common-2.3.0-0.17.beta.el6sat.noarch
pulp-puppet-plugins-2.3.0-0.17.beta.el6sat.noarch
ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-0.8.25-1.el6sam.noarch
candlepin-selinux-0.8.25-1.el6sam.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-common-1.4.6-21.el6sat.noarch
katello-glue-elasticsearch-1.4.6-21.el6sat.noarch
katello-glue-pulp-1.4.6-21.el6sat.noarch
katello-all-1.4.6-21.el6sat.noarch
katello-configure-foreman-1.4.5-9.el6sat.noarch
pulp-rpm-handlers-2.3.0-0.17.beta.el6sat.noarch
katello-agent-1.4.4-3.el6sat.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
pulp-selinux-2.3.0-0.17.beta.el6sat.noarch
katello-configure-foreman-proxy-1.4.5-9.el6sat.noarch
pulp-rpm-plugins-2.3.0-0.17.beta.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
katello-glue-candlepin-1.4.6-21.el6sat.noarch
katello-1.4.6-21.el6sat.noarch
katello-foreman-all-1.4.6-21.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
Katello-Katello-Configuration-KatelloClient-1.1-53.noarch
Katello-Katello-Sanity-ImportKeys-1.2-1.noarch
Comment 8 Bryan Kearney 2014-04-24 13:10:55 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 9 Bryan Kearney 2014-04-24 13:11:59 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.