Bug 1015980 - [abrt] python-boto-2.9.6-2.fc19: auth.py:686:get_auth_handler:NoAuthHandlerFound: No handler was ready to authenticate. 1 handlers were checked. ['HmacAuthV4Handler'] Check your credentials
[abrt] python-boto-2.9.6-2.fc19: auth.py:686:get_auth_handler:NoAuthHandlerFo...
Status: CLOSED DUPLICATE of bug 821799
Product: Fedora
Classification: Fedora
Component: python-boto (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Garrett Holmstrom
Fedora Extras Quality Assurance
abrt_hash:268595a29e29dac51b48bc7700b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-07 04:01 EDT by kluksa
Modified: 2014-08-22 17:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-22 17:02:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.48 KB, text/plain)
2013-10-07 04:01 EDT, kluksa
no flags Details
File: environ (3.69 KB, text/plain)
2013-10-07 04:01 EDT, kluksa
no flags Details

  None (edit)
Description kluksa 2013-10-07 04:01:49 EDT
Version-Release number of selected component:
python-boto-2.9.6-2.fc19

Additional info:
reporter:       libreport-2.1.7
cmdline:        /usr/bin/python /usr/bin/asadmin start-domain likz
executable:     /usr/bin/asadmin
kernel:         3.11.1-200.fc19.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
auth.py:686:get_auth_handler:NoAuthHandlerFound: No handler was ready to authenticate. 1 handlers were checked. ['HmacAuthV4Handler'] Check your credentials

Traceback (most recent call last):
  File "/usr/bin/asadmin", line 260, in <module>
    autoscale = boto.connect_autoscale()
  File "/usr/lib/python2.7/site-packages/boto/__init__.py", line 192, in connect_autoscale
    **kwargs)
  File "/usr/lib/python2.7/site-packages/boto/ec2/autoscale/__init__.py", line 123, in __init__
    validate_certs=validate_certs)
  File "/usr/lib/python2.7/site-packages/boto/connection.py", line 973, in __init__
    validate_certs=validate_certs)
  File "/usr/lib/python2.7/site-packages/boto/connection.py", line 554, in __init__
    host, config, self.provider, self._required_auth_capability())
  File "/usr/lib/python2.7/site-packages/boto/auth.py", line 686, in get_auth_handler
    'Check your credentials' % (len(names), str(names)))
NoAuthHandlerFound: No handler was ready to authenticate. 1 handlers were checked. ['HmacAuthV4Handler'] Check your credentials

Local variables in innermost frame:
total_handlers: 1
checked_handlers: [<class 'boto.auth.HmacAuthV4Handler'>]
provider: <boto.provider.Provider object at 0x1965350>
host: 'autoscaling.us-east-1.amazonaws.com'
handler: <class 'boto.auth.HmacAuthV4Handler'>
names: ['HmacAuthV4Handler']
ready_handlers: []
requested_capability: ['hmac-v4']
auth_handlers: [<class 'boto.auth.HmacAuthV4Handler'>]
config: <boto.pyami.config.Config instance at 0x15b9fc8>
Comment 1 kluksa 2013-10-07 04:01:53 EDT
Created attachment 808745 [details]
File: backtrace
Comment 2 kluksa 2013-10-07 04:01:57 EDT
Created attachment 808746 [details]
File: environ
Comment 3 Fedora Admin XMLRPC Client 2014-01-02 16:27:24 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Garrett Holmstrom 2014-08-22 17:02:02 EDT

*** This bug has been marked as a duplicate of bug 821799 ***

Note You need to log in before you can comment on or make changes to this bug.