This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 821799 - [abrt] python-boto-2.3.0-1.fc17: auth.py:407:get_auth_handler:NoAuthHandlerFound: No handler was ready to authenticate. 1 handlers were checked. ['HmacAuthV1Handler'] Check your credentials
[abrt] python-boto-2.3.0-1.fc17: auth.py:407:get_auth_handler:NoAuthHandlerFo...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python-boto (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
abrt_hash:45eb1babf83a3aee62502ecbbfc...
:
: 843340 885315 905428 909492 1015980 1031242 1047170 1050792 1148914 1173010 1178064 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-15 10:11 EDT by Pierre-YvesChibon
Modified: 2015-04-08 21:38 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-02 18:04:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre-YvesChibon 2012-05-15 10:11:20 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        /usr/bin/python /usr/bin/lss3
comment:        run the lss3 command without any arguments
executable:     /usr/bin/lss3
kernel:         3.3.4-4.fc17.x86_64
time:           Tue 15 May 2012 04:10:04 PM CEST
uid:            1000
username:       pierrey

backtrace:
:auth.py:407:get_auth_handler:NoAuthHandlerFound: No handler was ready to authenticate. 1 handlers were checked. ['HmacAuthV1Handler'] Check your credentials
:
:Traceback (most recent call last):
:  File "/usr/bin/lss3", line 71, in <module>
:    s3 = boto.connect_s3()
:  File "/usr/lib/python2.7/site-packages/boto/__init__.py", line 109, in connect_s3
:    return S3Connection(aws_access_key_id, aws_secret_access_key, **kwargs)
:  File "/usr/lib/python2.7/site-packages/boto/s3/connection.py", line 155, in __init__
:    suppress_consec_slashes=suppress_consec_slashes)
:  File "/usr/lib/python2.7/site-packages/boto/connection.py", line 486, in __init__
:    host, config, self.provider, self._required_auth_capability())
:  File "/usr/lib/python2.7/site-packages/boto/auth.py", line 407, in get_auth_handler
:    'Check your credentials' % (len(names), str(names)))
:NoAuthHandlerFound: No handler was ready to authenticate. 1 handlers were checked. ['HmacAuthV1Handler'] Check your credentials
:
:Local variables in innermost frame:
:total_handlers: 1
:checked_handlers: [<class 'boto.auth.HmacAuthV1Handler'>]
:provider: <boto.provider.Provider object at 0x7f66de7eff50>
:host: 's3.amazonaws.com'
:handler: <class 'boto.auth.HmacAuthV1Handler'>
:names: ['HmacAuthV1Handler']
:ready_handlers: []
:requested_capability: ['s3']
:auth_handlers: [<class 'boto.auth.HmacAuthV1Handler'>]
:config: <boto.pyami.config.Config instance at 0x7f66de7e5680>
Comment 1 Miroslav Suchý 2013-04-05 04:01:08 EDT
*** Bug 843340 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Suchý 2013-04-05 04:01:23 EDT
*** Bug 885315 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Suchý 2013-04-05 04:02:13 EDT
*** Bug 909492 has been marked as a duplicate of this bug. ***
Comment 4 Miroslav Suchý 2013-04-05 04:06:00 EDT
*** Bug 847979 has been marked as a duplicate of this bug. ***
Comment 5 Miroslav Suchý 2013-04-05 04:07:32 EDT
*** Bug 905428 has been marked as a duplicate of this bug. ***
Comment 6 Garrett Holmstrom 2013-07-02 18:04:52 EDT
Don't forget to supply your S3 access keys to the command.
Comment 7 Pierre-YvesChibon 2013-07-03 01:12:45 EDT
I still think the error should be catch and information should be returned to the user rather than the backtrace.
Comment 8 Garrett Holmstrom 2013-07-05 14:32:55 EDT
Indeed.  You can follow that issue here:  https://github.com/boto/boto/issues/1592
Comment 9 Garrett Holmstrom 2014-08-22 17:02:02 EDT
*** Bug 1015980 has been marked as a duplicate of this bug. ***
Comment 10 Garrett Holmstrom 2014-08-22 17:02:05 EDT
*** Bug 1047170 has been marked as a duplicate of this bug. ***
Comment 11 Garrett Holmstrom 2014-08-22 17:02:24 EDT
*** Bug 1050792 has been marked as a duplicate of this bug. ***
Comment 12 Garrett Holmstrom 2014-08-22 17:03:20 EDT
*** Bug 1031242 has been marked as a duplicate of this bug. ***
Comment 13 Garrett Holmstrom 2014-11-07 14:53:30 EST
*** Bug 1148914 has been marked as a duplicate of this bug. ***
Comment 14 Garrett Holmstrom 2015-04-08 21:37:52 EDT
*** Bug 1178064 has been marked as a duplicate of this bug. ***
Comment 15 Garrett Holmstrom 2015-04-08 21:38:03 EDT
*** Bug 1173010 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.