Bug 101610 - kmail is installed, but not the address book (see also Bug 101521)
kmail is installed, but not the address book (see also Bug 101521)
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: kdenetwork (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-04 14:28 EDT by Elton Woo
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-03 15:52:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elton Woo 2003-08-04 14:28:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
As reported in Bug 101521, although the installation method selected is
Personal or Workstation default, yet the KDE desktop and a mish-mash of
KDE applications is installed. Version-Release of what *is* installed 
on my system:

]$ rpm -qa | grep kde
licq-kde-1.2.6-1  [installed by user]
kdepim-3.1.2-5    [installed by user, because kmail did not have address book
installed, though it *did* display addresses, when sending mail!!!

lockdev-1.0.0-24
kdelibs-3.1.2-7
kdegames-3.1.2-6
lockdev-devel-1.0.0-24
kdeedu-3.1.2-5    [installed by user]
kdetoys-3.1.2-3   [installed by user]
kdebase-3.1.2-13
kdeadmin-3.1.2-4  [installed by user]


Version-Release number of selected component (if applicable):
kdenetwork is NOT installed!!!

How reproducible:
Didn't try

Steps to Reproduce:
1. Start kmail, and save some addresses
2. Post messages, and select addresses
3. Click on address-book icon, to edit addresses
    

Actual Results:  Kmail complains that address-book is not installed. It *isn't*!!

Expected Results:  The address-book should be installed along with kmail, as an
integral
and necessarr component of the application.

Additional info:

(see also Bug 101521)
Comment 1 Elton Woo 2003-08-04 14:37:02 EDT
CORRECTION: see also bug 101512, NOT 101521!
Comment 2 Ngo Than 2003-08-04 15:54:59 EDT
jeremy, i think this problem is in anaconda
Comment 3 Michael Fulbright 2003-08-05 16:21:44 EDT
The comps component defines what is going to be installed - reassigning.
Comment 4 Bill Nottingham 2003-08-05 16:34:49 EDT
If kmail requires a different package to function, it needs to Require: it.
Comment 5 Ngo Than 2003-09-03 15:52:35 EDT
I have added requires: kdepim into kdenetwork-3.1.3-4.

Note You need to log in before you can comment on or make changes to this bug.