Bug 1016130 - Upgrading from Fedora 19 to20 fails. Dependency compatibility issues.
Upgrading from Fedora 19 to20 fails. Dependency compatibility issues.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fedora-upgrade (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-07 10:52 EDT by io
Modified: 2014-11-24 17:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-24 17:49:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description io 2013-10-07 10:52:18 EDT
Description of problem:
While upgrading distro from 19 to 20 Alpha, I realized that some packages in 20 Alpha are older than 19 rawhide or doesn't exist on 20 distro at all.
Please see below:

Error: Package: monotone-1.0-11.fc19.x86_64 (@fedora/19)
           Requires: libbotan-1.8.2.so()(64bit)
           Removing: botan-1.8.14-2.fc19.x86_64 (@fedora/19)
               libbotan-1.8.2.so()(64bit)
           Updated By: botan-1.10.5-4.fc20.x86_64 (fedora)
               Not found
Error: Package: python-tag-2013.1-1.fc20.x86_64 (fedora)
           Requires: libboost_python.so.1.53.0()(64bit)
           Removing: boost-python-1.53.0-14.fc19.x86_64 (@updates/19)
               libboost_python.so.1.53.0()(64bit)
           Updated By: boost-python-1.54.0-5.fc20.x86_64 (fedora)
              ~libboost_python.so.1.54.0()(64bit)
Error: Package: gazpacho-0.7.2-13.fc19.noarch (@fedora/19)
           Requires: python-kiwi-gazpacho
           Removing: python-kiwi-gazpacho-1.9.26-6.fc19.noarch (@fedora/19)
               python-kiwi-gazpacho = 1.9.26-6.fc19
           Obsoleted By: python-kiwi-glade-1.9.38-2.fc20.x86_64 (fedora)
               Not found
Error: Package: sssd-common-pac-1.11.1-1.fc19.x86_64 (@updates/19)
           Requires: sssd-common = 1.11.1-1.fc19
           Removing: sssd-common-1.11.1-1.fc19.x86_64 (@updates/19)
               sssd-common = 1.11.1-1.fc19
           Downgraded By: sssd-common-1.11.0-1.fc20.x86_64 (fedora)
               sssd-common = 1.11.0-1.fc20
Error: Package: 1:libreoffice-core-4.1.2.3-1.fc20.x86_64 (fedora)
           Requires: autocorr-en
           Removing: 1:autocorr-en-4.1.2.3-2.fc19.noarch (@updates/19)
               autocorr-en = 1:4.1.2.3-2.fc19
           Available: 1:autocorr-en-4.1.2.3-1.fc20.noarch (fedora)
               autocorr-en = 1:4.1.2.3-1.fc20


Version-Release number of selected component (if applicable):
20

How reproducible:
Have Fedora 19 distro rawhide, never moved to final release.
Trying to upgrade to 20 alpha.


Steps to Reproduce:
1. yum --releasever=20 distro-sync
2.
3.

Actual results:
Failure to upgrade because of dependencies

Expected results:
Successful upgrade

Additional info:

[root@ioFedora ~]# cat /etc/redhat-release 
Fedora release 19 (Schrödinger’s Cat)

[root@ioFedora ~]# uname -a
Linux ioFedora 3.11.3-201.fc19.x86_64 #1 SMP Thu Oct 3 00:47:03 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Comment 1 Miroslav Suchý 2013-10-07 11:03:50 EDT
This is not problem of fedora-upgrade, but problem of those packages. Can you please file individual bug reports for each package. Example of such report is bug 1003577 or bug 999397.
Comment 2 Miroslav Suchý 2014-11-24 17:49:12 EST
closing per #1

Note You need to log in before you can comment on or make changes to this bug.