Bug 10162 - "Query" button in toolbar doesn't work properly
"Query" button in toolbar doesn't work properly
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: gnorpm (Show other bugs)
1.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Alan Cox
:
: 9590 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-14 00:07 EST by Robert Walsh
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-30 03:53:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Walsh 2000-03-14 00:07:42 EST
When I click the "Query" button in the toolbar, it pops up the query
information for the selected package.  If I then select another package
and click the "Query" button in the toolbar again, it redisplays the query
information for the first package, not the new package.  The pop-up menu
for querying works as normal, however, so I can still access the query
information.

This is not super-high priority (since I can still access the query
information), but it would be nice to have fixed for the next release.
The same problem exists in 6.2beta.

The package I've installed is gnorpm-0.9-14.i386.rpm.  I have not checked
other architectures.
Comment 1 Nalin Dahyabhai 2000-03-14 10:04:59 EST
This appears to be working correctly in the latest build.  If you have multiple
packages selected, the query button on the toolbar will bring up a tabbed dialog
with the result of each query on a different tab, but the popup menu will only
bring up the results of a query on the package under the cursor when the menu is
popped up.
Comment 2 Robert Walsh 2000-03-14 16:19:59 EST
This is the exact steps I used to produce the problem:

 1) Open GnoRPM.
 2) Select a single package.
 3) Click on the query button.  This pops up a dialog box with the query
    information in it.
 4) Close the query dialog box.
 5) Select another package.  Do NOT select multiple package - I only tested
    for single selections.
 6) Click on the query button.  This again pops up a dialog box, but with the
    query information for the package selected in step 2 in it, not for the
    package selected in step 5.

If you cannot reproduce using these steps, please update the bug and I will
check if there could possibly be something else wrong, but I can reproduce it
every time with the above steps.
Comment 3 Nalin Dahyabhai 2000-03-16 08:32:59 EST
I Followed the procedure outlined above, selected Development/Languages/cpp, hit
query, verified that cpp was queried.  Unselect cpp, select dev86, hit query,
and dev86 was queried, correct description, info, and file list in both cases.

Again, this is with 0.9-15 from our build tree. Backed down to 0.9-14 from
current Raw Hide snapshot, but this scenario still works.
Comment 4 Nalin Dahyabhai 2000-03-17 15:00:59 EST
[Private email reproduced here for benefit of others]

So, how what?  I can reproduce this bug each time.  What I think I'll
do is grab the source rpm and run the whole thing through gdb.  It's
possible (though I think unlikely) that this might be something to do
with the gnome or gtk libraries.

I'll update the bug as soon as I have a chance to do this (probably
over the weekend.)
Comment 5 Robert Walsh 2000-03-24 02:35:59 EST
I know what's happening now, and this bug should be changed instead to an RFE.

I have gnuchess and xboard installed.  I select gnuchess and press query.  The
query dialog box pops up.  I dismiss the dialog box.  I then select xboard and
press query.  The query dialog pops up, and one of two things happens:

 1) There's a new tab in there for xboard, and it's the selected one.  The old
    gnuchess tab from the previous query is also there but not selected.
 2) There's a new tab in there for xboard, but the gnuchess one is still
    selected. I have to explicitly select the xboard tab.

I never even noticed that the query dialog box was adding tabs to itself each
time I selected a new package and still keeping the old tabs around. It
intermittently chooses one of the above 2 behaviours.  When I noticed the bug,
I was getting behaviour 2 most of the time.  I still do get this behaviour most
of the time.

Although the functionality is correct, from a UI point of view, one of two
things should be done (in order of preference):

 1) Change the Query dialog box so only the currently selected items are placed
    into it.  i.e. when the dialog box is dismissed, remove the items from it.

 2) If you want to keep the current behaviour (i.e. keeping the old query
    results around) ensure that one of the currently selected items is
    selected when the dialog box is displayed.
Comment 6 Robert Walsh 2000-03-24 02:38:59 EST
NOTE: the pop-up menu option (right mouse button) for query removes all old
queries from the dialog box.
Comment 7 Alan Cox 2000-08-22 10:22:13 EDT
*** Bug 9590 has been marked as a duplicate of this bug. ***
Comment 8 Alan Cox 2000-08-30 03:52:59 EDT
This is actually a bug in the selection handling. Most of it is fixed in
Rawhide, the last corner case I fixed in gnome cvs last night

Note You need to log in before you can comment on or make changes to this bug.