Bug 101628 - ISDN, no default route after hangup or reboot
ISDN, no default route after hangup or reboot
Status: CLOSED CANTFIX
Product: Red Hat Linux Beta
Classification: Retired
Component: redhat-config-network (Show other bugs)
beta1
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks: rcn-isdn
  Show dependency treegraph
 
Reported: 2003-08-04 17:02 EDT by Uwe Beck
Modified: 2007-07-26 20:18 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-26 20:18:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Uwe Beck 2003-08-04 17:02:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.08 [en] (X11; I; AIX 4.3)

Description of problem:
I create my provider by name "brickxmp".

/etc/sysconfig/network-scripts
ifcfg-eth0
ifcfg-eth1
fcfg-brickxmp <-- ifcfg-ippp0 before the new program version (see Bug 91607)

After the system was rebooted:

netstat -r
Kernel IP Routentabelle
Ziel            Router          Genmask         Flags   MSS Fenster irtt Iface
172.16.39.0     *               255.255.255.0   U         0 0          0 eth0
172.16.38.0     *               255.255.255.0   U         0 0          0 ippp0
172.16.37.0     *               255.255.255.0   U         0 0          0 eth1
169.254.0.0     *               255.255.0.0     U         0 0          0 eth1
127.0.0.0       *               255.0.0.0       U         0 0          0 lo
default         lex021          0.0.0.0         UG        0 0          0 eth0

The default route is set over eth0, but should be set over ippp0. Before this
version of redhat-config-network the ISDN-interface name was always ippp0.
This mistake comes from the loop in the if-up script and it was a random that
I have this mistake found because my providername is "brickxmp".

I see some effects if the name is ifcfg-brickxmp.

With /etc/sysconfig/network-scripts/ifcfg-brickxmp the kisdndock do not go
in the o.k. status (color gray) on the KDE desktop.
If I rename /etc/sysconfig/network-scripts/ifcfg-brickxmp in
/etc/sysconfig/network-scripts/ifcfg-ippp0 all works correct.




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a provider with name begins with a-d
2. reboot
3.
    

Additional info:

See Bug 91607 in Red Hat 9
Comment 1 Harald Hoyer 2005-07-08 11:54:58 EDT
is this still an issue?
Comment 2 Uwe Beck 2005-09-08 15:16:51 EDT
Yes, this is still an issue.
Comment 4 Bill Nottingham 2007-07-26 20:18:27 EDT
Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.