Bug 101631 - (ACPI) kernel hang initializing aic7902 U320 scsi cards with acpi enabled.
(ACPI) kernel hang initializing aic7902 U320 scsi cards with acpi enabled.
Status: CLOSED WONTFIX
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-08-04 17:37 EDT by David Lawrence
Modified: 2015-01-04 17:02 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-25 03:02:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lawrence 2003-08-04 17:37:54 EDT
Description of problem:
Loaded Severn Beta 1 on a HP xw6000 workstation. When initializing the Adaptec
cards it complains that no IRQs are found and hangs during boot process. If
booting with acpi=off it will continue to boot normally. Here is the lspci output.

00:00.0 Host bridge: Intel Corp.: Unknown device 2550 (rev 03)
00:01.0 PCI bridge: Intel Corp.: Unknown device 2552 (rev 03)
00:1d.0 USB Controller: Intel Corp. 82801DB USB (Hub #1) (rev 01)
00:1d.1 USB Controller: Intel Corp. 82801DB USB (Hub #2) (rev 01)
00:1d.2 USB Controller: Intel Corp. 82801DB USB (Hub #3) (rev 01)
00:1d.7 USB Controller: Intel Corp. 82801DB USB EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB PCI Bridge (rev 81)
00:1f.0 ISA bridge: Intel Corp. 82801DB ISA Bridge (LPC) (rev 01)
00:1f.1 IDE interface: Intel Corp. 82801DB ICH4 IDE (rev 01)
00:1f.5 Multimedia audio controller: Intel Corp. 82801DB AC'97 Audio (rev 01)
05:02.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5702 Gigabit
Ethernet (rev 02)
05:0c.0 SCSI storage controller: Adaptec AIC-7902 U320 (rev 03)
05:0c.1 SCSI storage controller: Adaptec AIC-7902 U320 (rev 03)
05:0d.0 PCI bridge: Hint Corp HB1-SE33 PCI-PCI Bridge (rev 13)
06:00.0 VGA compatible controller: nVidia Corporation NV17GL [Quadro4 200/400
NVS] (rev a3)
06:04.0 VGA compatible controller: nVidia Corporation NV17GL [Quadro4 200/400
NVS] (rev a3)

Changing IRQs in BIOS configuration has not effect

The same system works with RH9 stock kernel.
Comment 1 Bill Nottingham 2003-08-04 23:42:53 EDT
Can you post the output of 'acpidmp' and 'dmidecode'?
Comment 2 Len Brown 2003-08-05 14:28:50 EDT
Does it boot if you use just pci=noacpi ? 
 
 
Comment 3 Len Brown 2003-08-11 23:38:59 EDT
Please verify that the system has the latest BIOS.  Looks like you can create a BIOS 
1.12 install floppy from the comfort of your local linux box: 
 
http://h20004.www2.hp.com/soar_rnotes/bsdmatrix/matrix295779en_US.html#BIOS 
 
Apparently BIOS 1.15 would entail using windows in some form... 
 
If it still fails with the latest BIOS, it would be great if you can capture the failed boot 
messages via serial console. 
 
BTW. my SE7505VB2 seems to run beta1 just fine -- it doesn't have an AIC boot disk, 
but has 5 PCI NICs that all work. 
 
Comment 4 Dave Jones 2003-11-03 12:25:00 EST
PCI IRQ routing code changed dramatically between test1 and what we
have now. I'll lay odds on that this is fixed.
Comment 5 Len Brown 2004-03-24 18:07:09 EST
no response in 7 months -- close?

Note You need to log in before you can comment on or make changes to this bug.