Bug 1016383 - During interactive installation, wording of component installation prompts are inconsistent or too minimalist
During interactive installation, wording of component installation prompts ar...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
4.0
Unspecified Unspecified
low Severity low
: rc
: 4.0
Assigned To: Martin Magr
Lon Hohberger
: OtherQA, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 01:26 EDT by Bruce Reeler
Modified: 2014-10-30 18:29 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:26:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruce Reeler 2013-10-08 01:26:00 EDT
Description of problem:
During an interactive OpenStack installation using PackStack, the wording of the component installation prompts are inconsistent or minimal.

Version-Release number of selected component (if applicable):
4.0 Havana

How reproducible:
Run PackStack interactively. 
During the first ten prompts which are mostly for installing OpenStack components, some prompts are of the format:
"Should Packstack install OpenStack <component name> service (codename)", but others are:
"Should Packstack install OpenStack <component name> (codename) service".

Also, Heat installation prompt just says "Should PackStack install Heat".

Expected results:
Make all prompts similar, I'd suggest:
"Should Packstack install OpenStack <component name> service (codename)", 
for example:
Should Packstack install OpenStack Block Storage service (Cinder).

Additional info:
There is also a mix of upper and lower case for the names. This should be standardized, e.g. the component names should be capitals and "service" lower case, as in example above.
Comment 2 Alvaro Lopez Ortega 2013-11-13 13:28:48 EST
AFAIK, Francesco fixed this one already. Let's double check it before it's closed.
Comment 5 Lon Hohberger 2013-12-11 17:50:34 EST
Results:

https://bugzilla.redhat.com/show_bug.cgi?id=1030767#c5
Comment 7 errata-xmlrpc 2013-12-19 19:26:22 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.