Bug 1016444 - (festige) ReviewRequest: festige - a GUI frontend to fst and dssi vst (run Windows VST audio plugins under wine)
ReviewRequest: festige - a GUI frontend to fst and dssi vst (run Windows VST ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Extras Quality Assurance
:
Depends On: 1015958
Blocks: FE-DEADREVIEW FedoraAudio qt-reviews
  Show dependency treegraph
 
Reported: 2013-10-08 03:54 EDT by Brendan Jones
Modified: 2017-07-25 06:38 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-17 16:18:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
brendan.jones.it: needinfo-


Attachments (Terms of Use)

  None (edit)
Description Brendan Jones 2013-10-08 03:54:12 EDT
festige is a GUI for fst and dssi-vst,
allowing you to run Windows VST plugins on Linux

Optionally supports ladish sessions (bug 865699)

SRPM: http://bsjones.fedorapeople.org/reviews/festige-1.0.2-1.src.rpm
SPEC: http://bsjones.fedorapeople.org/reviews/festige.spec
Comment 1 Brendan Jones 2013-10-08 03:56:51 EDT
fst (bug 1015958) is only a runtime requirement and need not hold up this review
Comment 2 Eduardo Mayorga 2014-02-04 16:59:59 EST
Some quick comments:
* Use %{name} macro in %prep
* Add COPYING and README files as %doc
* Group tag is deprecated
* Just add one package per BuildRequire tag line

I'm not an official packager so this is just an informal review.
Comment 3 Volker Fröhlich 2014-02-10 19:22:28 EST
You should BR qt4-devel. However, PyQt4-devel transitively requires qt4-devel anyway, so you can drop it. I'm not sure what the Python modules are necessary for. BR python2 is not necessary.

Use the name macro for patches, use the name and version macro in URL. The spec file and the spec file from the RPM don't match.

You should rather delete fst in the prep section.

Please add COPYING and README as %doc.

The optflags are useless there, as nothing should be compiled.

Can you find a more elegant solution than symlinks?

With fst only being available on i686, the build of this package should be excluded too.

Will it work with Python 3?

sed -i -e 's/Qt/Sequencer/' %{buildroot}%{_datadir}/applications/%{name}.desktop -- Ideally you should not edit the desktop file manually, but through the desktop utils. However, this can go to the prep section.

The README file says:

----- COMPILE:
In order to use FeSTige, you first have to compile it.
You'll need the devel packages of:
  - Python
  - PyQt4
  - Qt4
  - Wine
  - Gtk

That seems wrong and you should let the author know, if he's still active. 
Can you get your changes upstream?
Comment 4 Kevin Kofler 2014-02-10 19:30:42 EST
This package can also be built for x86_64, using the i686-only fst that hopefully ends up in the x86_64 repository as a multilib. But any non-x86 architectures are indeed hosed, so it needs an ExclusiveArch.
Comment 5 Raphael Groner 2016-07-15 12:18:55 EDT
Hi requester,
are you still interested in this package? Maybe in doing a review swap?
Comment 6 Raphael Groner 2016-10-17 16:18:44 EDT
I'll close here. This request looks really dead to me, no response from requester since years.

Note You need to log in before you can comment on or make changes to this bug.