Bug 1016488 - Guest serial console doesn't work
Guest serial console doesn't work
Status: CLOSED DUPLICATE of bug 1016613
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
20
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 05:06 EDT by Alexander Todorov
Modified: 2013-10-09 07:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 08:19:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2013-10-08 05:06:02 EDT
Description of problem:

I performed a default install of Fedora-20-Beta-TC1 tree using the DVD ISO and virt-manager wizard. System boots fine using the graphical console. 

As per the test case:
https://fedoraproject.org/wiki/QA:Testcase_Virt_Serial_Console


The serial console doesn't work at all: 

In VM details I can see a serial device has already been added. 

Trying View -> Text Consoles -> Serial 1 doens't give me a login prompt (GUI shows login prompt at the same time). 

Trying virsh console $guest yields:

# virsh console fedora20-2
Connected to domain fedora20-2
Escape character is ^]
error: operation failed: Active console session exists for this domain

^^^ No matter if I have switched in virt-manager back to the GUI or text console or if I close entirely the VM window which shows this guest system.

Version-Release number of selected component (if applicable):

libvirt-client-1.1.3-2.fc20.x86_64
virt-manager-0.10.0-4.git79196cdf.fc20.noarch


How reproducible:
always

Steps to Reproduce:
1. See test case above.
2.
3.

Actual results:


Expected results:


Additional info:

This could be 2 different issues, I don't know yet.
Comment 1 Cole Robinson 2013-10-08 08:19:11 EDT
Duping this to your qemu-ga bug, since they are likely the same root issue

*** This bug has been marked as a duplicate of bug 1016613 ***
Comment 2 Tadej Janež 2013-10-09 07:05:00 EDT
I have some additional information regarding the guest serial console:

If I manually add the Console Device via "Add Hardware" option (Device Type: Pseudo TTY (pty), Type: virtio), I get a working console in virt-manager, e.g. I can see the login prompt an log in.

However, executing 'virsh console fedora20' still doesn't work. I get the following output:
Connected to domain fedora20
Escape character is ^]

and I can't proceed, e.g. typing something in doesn't produce anything.

Note You need to log in before you can comment on or make changes to this bug.