Bug 1016566 - Installing a package silently fails if the GPG key for the yum repo is not installed
Installing a package silently fails if the GPG key for the yum repo is not in...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-software (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
AcceptedFreezeException
:
: 1020069 (view as bug list)
Depends On:
Blocks: F20BetaFreezeException
  Show dependency treegraph
 
Reported: 2013-10-08 07:02 EDT by Tim Lauridsen
Modified: 2013-10-23 00:37 EDT (History)
4 users (show)

See Also:
Fixed In Version: PackageKit-0.8.12-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-22 01:38:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 709676 None None None Never

  None (edit)
Description Tim Lauridsen 2013-10-08 07:02:00 EDT
Description of problem:

Can't install anything using gnome-software


Version-Release number of selected component (if applicable):
3.10.0-1.f20.i686

How reproducible:
every times

Steps to Reproduce:
1. fresh installed F20 Beta TC1
2. start gnome-software and search for yumex
3. press the install button

Actual results:
An non moving spinner is shown for a while and then the install button is shown again.

Expected results:
yumex installs or some kind of error message is shown.

Additional info:
This is releated to import of the Fedora GPG key, if I install something using yum at the command line and ask yes to import the Fedora GPG key, the gnome-software will be able to install software.
Comment 1 Ryan Lerch 2013-10-08 15:10:38 EDT
Confirmed that this is still an issue on a recent trunk build of gnome-software.

On the command line, gnome-software returns the message:

(gnome-software:16760): Gs-WARNING **: failed to complete gs_plugin_app_install: could not do key question as no klass support
Comment 2 Ryan Lerch 2013-10-08 15:19:12 EDT
Thanks for your bugreport Tim!

I have confirmed this behaviour with a recent upstream build, and have filed a bug upstream in GNOME to get this issue looked at.

https://bugzilla.gnome.org/show_bug.cgi?id=709676
Comment 3 Adam Williamson 2013-10-13 09:10:38 EDT
This seems like a major problem for Beta, nominating as a Beta freeze exception. We don't require package installation to work for Beta, so it's probably not a blocker.
Comment 4 Adam Williamson 2013-10-16 13:31:17 EDT
Discussed at 2013-10-16 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-10-16/f20beta-blocker-review-4.2013-10-16-16.02.log.txt . Accepted as a freeze exception issue - obviously, package install should work after install if possible...
Comment 5 Ryan Lerch 2013-10-17 10:34:44 EDT
*** Bug 1020069 has been marked as a duplicate of this bug. ***
Comment 6 Richard Hughes 2013-10-18 05:37:24 EDT
Was a PackageKit thinko:

commit bc076b3192a6e67f781969459e122fa9576b997b
Author: Richard Hughes <richard@hughsie.com>
Date:   Fri Oct 18 10:25:12 2013 +0100

    lib: Do not have duplicate 'interactive' properties on the super and base classes
    
    If the client called pk_client_set_interactive() on a PkTask instance this was
    not being used in the derived class and the EULA and GPG auto-accept prompts
    were failing.
    
    There's no need at all to have the same property in both objects, the property
    means the same in both. Deprecate the getters and setters in the superclass.
    
    Fixes: https://bugzilla.gnome.org/show_bug.cgi?id=709676

Will do a new update now.
Comment 7 Fedora Update System 2013-10-18 10:32:54 EDT
PackageKit-0.8.12-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/PackageKit-0.8.12-1.fc20
Comment 8 Adam Williamson 2013-10-18 11:40:01 EDT
Fix doesn't seem to work for me :( I updated a clean TC5 VM with PackageKit 0.8.12 and gnome-software still cannot install packages, I still see "(gnome-software:2356): Gs-WARNING **: failed to complete gs_plugin_app_install: could not do key question as no klass support" . Persists after a reboot.
Comment 9 Adam Williamson 2013-10-18 11:42:58 EDT
<hughsie> gahh
<adamw> brown paper bag time?
<hughsie> so i only fixed gnome-software in master for the gpg fix
 no, the PK update is fine
 i'll need to tag in a gnome-software update too
Comment 10 Fedora Update System 2013-10-18 20:14:38 EDT
Package PackageKit-0.8.12-1.fc20, gnome-software-3.10.2-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing PackageKit-0.8.12-1.fc20 gnome-software-3.10.2-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19433/PackageKit-0.8.12-1.fc20,gnome-software-3.10.2-1.fc20
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2013-10-22 01:38:38 EDT
PackageKit-0.8.12-1.fc20, gnome-software-3.10.2-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Tim Lauridsen 2013-10-22 05:17:39 EDT
Tested by removing the keys unsing yum-plugin-keys and installing something using gnome-software, it installed as expected.

Is it suppossed to install gpg silently with out telling/asking the user ?

from a usabillity point of view it is nice, but not from a security point of view :)
Comment 13 Adam Williamson 2013-10-22 12:25:58 EDT
For me it prompted for the user's password, as I'd expect.
Comment 14 Tim Lauridsen 2013-10-23 00:37:10 EDT
I got a polkit password dialog, but did not catch if the dialog said any thing about a gpg key, I just thought it was releated to installing the package.

Note You need to log in before you can comment on or make changes to this bug.