Bug 1020069 - Cannot install a package if it requires import of a GPG key
Cannot install a package if it requires import of a GPG key
Status: CLOSED DUPLICATE of bug 1016566
Product: Fedora
Classification: Fedora
Component: gnome-software (Show other bugs)
20
All All
unspecified Severity urgent
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-16 19:53 EDT by Adam Williamson
Modified: 2013-10-17 10:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 10:34:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log from reproducing the issue (29.54 KB, text/plain)
2013-10-16 19:53 EDT, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2013-10-16 19:53:42 EDT
Created attachment 813145 [details]
log from reproducing the issue

Reported upstream as https://bugzilla.gnome.org/show_bug.cgi?id=710339 .

Typically, out of the box, Fedora systems do not have the package signing GPG
key installed (for $TIRESOME_WELL_KNOWN_REASONS). The first time you install a
package, any package manager should cope with offering to import the key.
Here's yum, doing it:

Downloading packages:
warning:
/var/cache/yum/x86_64/20/fedora/packages/mesa-libGLU-9.0.0-3.fc20.x86_64.rpm:
Header V3 RSA/SHA256 Signature, key ID 246110c1: NOKEY
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-20-x86_64
Importing GPG key 0x246110C1:
 Userid     : "Fedora (20) <fedora@fedoraproject.org>"
 Fingerprint: c7c9 a9c8 9153 f201 83ce 7cba 2eb1 61fa 2461 10c1
 Package    : fedora-release-20-0.7.noarch (@fedora/$releasever)
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-20-x86_64
Is this ok [y/N]: 

Here's gnome-software, not doing it:

(gnome-software:2385): Gs-WARNING **: failed to complete gs_plugin_app_install:
could not do key question as no klass support

This is after a clean install of an F20 live image built from current repos
with GNOME 3.10.1 added. Will attach full log.
Comment 1 Ryan Lerch 2013-10-17 10:34:44 EDT

*** This bug has been marked as a duplicate of bug 1016566 ***

Note You need to log in before you can comment on or make changes to this bug.