Bug 1016578 - FileAlreadyExistsException (Unable to bootstrap project org.kie.example:example-project:1.0.0-SNAPSHOT)
FileAlreadyExistsException (Unable to bootstrap project org.kie.example:examp...
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity unspecified
: ER5
: 6.0.0
Assigned To: Maciej Swiderski
Ivo Bek
:
: 1019380 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 07:16 EDT by Ryan Zhang
Modified: 2014-08-06 16:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:11:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server.log (99.57 KB, text/x-log)
2013-10-08 07:16 EDT, Ryan Zhang
no flags Details

  None (edit)
Description Ryan Zhang 2013-10-08 07:16:17 EDT
Description of problem:
I saw the following error stack when I start the bpms server the second times.
Please refer to the attachement for full server.log.

Please also note that this error didn't occure at the first startup, but it will appear on the second time startup.

19:13:06,769 ERROR [org.jbpm.console.ng.bd.backend.server.AdministrationServiceImpl] (MSC service thread 1-13) Unable to bootstrap project org.kie.example:example-project:1.0.0-SNAPSHOT in repository example-repository: org.kie.commons.java.nio.file.FileAlreadyExistsException
	at org.kie.commons.java.nio.fs.jgit.JGitFileSystemProvider.createDirectory(JGitFileSystemProvider.java:839) [kie-nio2-jgit-6.0.0-redhat-4.jar:6.0.0-redhat-4]
	at org.kie.commons.java.nio.file.Files.createDirectory(Files.java:259) [kie-nio2-api-6.0.0-redhat-4.jar:6.0.0-redhat-4]
	at org.kie.commons.io.impl.IOServiceDotFileImpl.internalCreateDirectory(IOServiceDotFileImpl.java:336) [kie-commons-io-6.0.0-redhat-4.jar:6.0.0-redhat-4]
	at org.kie.commons.io.impl.IOServiceDotFileImpl.createDirectory(IOServiceDotFileImpl.java:117) [kie-commons-io-6.0.0-redhat-4.jar:6.0.0-redhat-4]
	at org.guvnor.common.services.project.backend.server.KModuleServiceImpl.setUpKModuleStructure(KModuleServiceImpl.java:70) [guvnor-project-backend-6.0.0-redhat-4.jar:6.0.0-redhat-4]
	at org.guvnor.common.services.project.backend.server.KModuleServiceImpl$Proxy$_$$_WeldClientProxy.setUpKModuleStructure(KModuleServiceImpl$Proxy$_$$_WeldClientProxy.java) [guvnor-project-backend-6.0.0-redhat-4.jar:6.0.0-redhat-4]
	at org.guvnor.common.services.project.backend.server.ProjectServiceImpl.newProject(ProjectServiceImpl.java:417) [guvnor-project-backend-6.0.0-redhat-4.jar:6.0.0-redhat-4]
	at org.guvnor.common.services.project.backend.server.ProjectServiceImpl$Proxy$_$$_WeldClientProxy.newProject(ProjectServiceImpl$Proxy$_$$_WeldClientProxy.java) [guvnor-project-backend-6.0.0-redhat-4.jar:6.0.0-redhat-4]
	at org.jbpm.console.ng.bd.backend.server.AdministrationServiceImpl.bootstrapProject(AdministrationServiceImpl.java:227) [jbpm-console-ng-business-domain-backend-6.0.0-redhat-4.jar:6.0.0-redhat-4]
	at org.jbpm.console.ng.bd.backend.server.AdministrationServiceImpl$Proxy$_$$_WeldClientProxy.bootstrapProject(AdministrationServiceImpl$Proxy$_$$_WeldClientProxy.java) [jbpm-console-ng-business-domain-backend-6.0.0-redhat-4.jar:6.0.0-redhat-4]
	at org.kie.workbench.backend.AppSetup.assertPlayground(AppSetup.java:84) [classes:]
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [rt.jar:1.7.0_05]
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) [rt.jar:1.7.0_05]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.7.0_05]
	at java.lang.reflect.Method.invoke(Method.java:601) [rt.jar:1.7.0_05]
	at org.jboss.weld.util.reflection.SecureReflections$13.work(SecureReflections.java:267) [weld-core-1.1.13.Final-redhat-1.jar:1.1.13.Final-redhat-1]
	at org.jboss.weld.util.reflection.SecureReflectionAccess.run(SecureReflectionAccess.java:52) [weld-core-1.1.13.Final-redhat-1.jar:1.1.13.Final-redhat-1]
	at org.jboss.weld.util.reflection.SecureReflectionAccess.runAsInvocation(SecureReflectionAccess.java:137) [weld-core-1.1.13.Final-redhat-1.jar:1.1.13.Final-redhat-1]
	at org.jboss.weld.util.reflection.SecureReflections.invoke(SecureReflections.java:263) [weld-core-1.1.13.Final-redhat-1.jar:1.1.13.Final-redhat-1]
	at org.jboss.weld.introspector.jlr.WeldMethodImpl.invoke(WeldMethodImpl.java:174) [weld-core-1.1.13.Final-redhat-1.jar:1.1.13.Final-redhat-1]
	at org.jboss.weld.bean.AbstractClassBean.defaultPostConstruct(AbstractClassBean.java:402) [weld-core-1.1.13.Final-redhat-1.jar:1.1.13.Final-redhat-1]
	at org.jboss.weld.bean.ManagedBean$ManagedBeanInjectionTarget.postConstruct(ManagedBean.java:178) [weld-core-1.1.13.Final-redhat-1.jar:1.1.13.Final-redhat-1]
	at org.jboss.weld.bean.ManagedBean.create(ManagedBean.java:298) [weld-core-1.1.13.Final-redhat-1.jar:1.1.13.Final-redhat-1]
	at org.jboss.weld.context.AbstractContext.get(AbstractContext.java:101) [weld-core-1.1.13.Final-redhat-1.jar:1.1.13.Final-redhat-1]
	at org.jboss.weld.bean.proxy.ContextBeanInstance.getInstance(ContextBeanInstance.java:90) [weld-core-1.1.13.Final-redhat-1.jar:1.1.13.Final-redhat-1]
	at org.jboss.weld.bean.proxy.ProxyMethodHandler.invoke(ProxyMethodHandler.java:79) [weld-core-1.1.13.Final-redhat-1.jar:1.1.13.Final-redhat-1]
	at org.kie.workbench.backend.AppSetup$Proxy$_$$_WeldClientProxy.toString(AppSetup$Proxy$_$$_WeldClientProxy.java) [classes:]
	at org.kie.commons.services.cdi.StartupBeanExtension.runPostConstruct(StartupBeanExtension.java:83) [kie-commons-cdi-6.0.0-redhat-4.jar:6.0.0-redhat-4]
	at org.kie.commons.services.cdi.StartupBeanExtension.afterDeploymentValidation(StartupBeanExtension.java:67) [kie-commons-cdi-6.0.0-redhat-4.jar:6.0.0-redhat-4]
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [rt.jar:1.7.0_05]
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) [rt.jar:1.7.0_05]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.7.0_05]
	at java.lang.reflect.Method.invoke(Method.java:601) [rt.jar:1.7.0_05]
	at org.jboss.weld.util.reflection.SecureReflections$13.work(SecureReflections.java:267) [weld-core-1.1.13.Final-redhat-1.jar:1.1.13.Final-redhat-1]
	at org.jboss.weld.util.reflection.SecureReflectionAccess.run(SecureReflectionAccess.java:52) [weld-core-1.1.13.Final-redhat-1.jar:1.1.13.Final-redhat-1]
	at org.jboss.weld.util.reflection.SecureReflectionAccess.runAsInvocation(SecureReflectionAccess.java:137) [weld-core-1.1.13.Final-redhat-1.jar:1.1.13.Final-redhat-1]
	at org.jboss.weld.util.reflection.SecureReflections.invoke(SecureReflections.java:263) [weld-core-1.1.13.Final-redhat-1.jar:1.1.13.Final-redhat-1]
	at org.jboss.weld.introspector.jlr.WeldMethodImpl.invokeOnInstance(WeldMethodImpl.java:170) [weld-core-1.1.13.Final-redhat-1.jar:1.1.13.Final-redhat-1]
	at org.jboss.weld.introspector.ForwardingWeldMethod.invokeOnInstance(ForwardingWeldMethod.java:51) [weld-core-1.1.13.Final-redhat-1.jar:1.1.13.Final-redhat-1]
	at org.jboss.weld.injection.MethodInjectionPoint.invokeOnInstanceWithSpecialValue(MethodInjectionPoint.java:154) [weld-core-1.1.13.Final-redhat-1.jar:1.1.13.Final-redhat-1]
	at org.jboss.weld.event.ObserverMethodImpl.sendEvent(ObserverMethodImpl.java:245) [weld-core-1.1.13.Final-redhat-1.jar:1.1.13.Final-redhat-1]
	at org.jboss.weld.event.ObserverMethodImpl.sendEvent(ObserverMethodImpl.java:233) [weld-core-1.1.13.Final-redhat-1.jar:1.1.13.Final-redhat-1]
	at org.jboss.weld.event.ObserverMethodImpl.notify(ObserverMethodImpl.java:213) [weld-core-1.1.13.Final-redhat-1.jar:1.1.13.Final-redhat-1]
	at org.jboss.weld.bootstrap.events.AbstractContainerEvent.fire(AbstractContainerEvent.java:75) [weld-core-1.1.13.Final-redhat-1.jar:1.1.13.Final-redhat-1]
	at org.jboss.weld.bootstrap.events.AbstractDeploymentContainerEvent.fire(AbstractDeploymentContainerEvent.java:46) [weld-core-1.1.13.Final-redhat-1.jar:1.1.13.Final-redhat-1]
	at org.jboss.weld.bootstrap.events.AfterDeploymentValidationImpl.fire(AfterDeploymentValidationImpl.java:31) [weld-core-1.1.13.Final-redhat-1.jar:1.1.13.Final-redhat-1]
	at org.jboss.weld.bootstrap.WeldBootstrap.validateBeans(WeldBootstrap.java:382) [weld-core-1.1.13.Final-redhat-1.jar:1.1.13.Final-redhat-1]
	at org.jboss.as.weld.WeldStartService.start(WeldStartService.java:64) [jboss-as-weld-7.2.0.Final-redhat-8.jar:7.2.0.Final-redhat-8]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811)
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.7.0_05]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.7.0_05]
	at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_05]

19:13:06,932 INFO  [org.jbpm.executor.impl.ExecutorImpl] (MSC service thread 1-13) Starting Executor Component ...
 	 - Thread Pool Size: 1
 	 - Interval: 3 Seconds
 	 - Retries per Request: 3


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Ryan Zhang 2013-10-08 07:16:53 EDT
Created attachment 809221 [details]
server.log
Comment 2 Ryan Zhang 2013-10-08 07:18:20 EDT
This is found in ER4 candidate which can be download temporarily from https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/soa-team-mead-6-ip-bpms/
or 
http://jawa05.englab.brq.redhat.com/miscellaneous/bpms-6.0.0-er4/
Comment 4 Maciej Swiderski 2013-10-08 13:42:07 EDT
the issue fixed as there was missing check if the project is already created. Although it's logged it should not cause any issues with the actual usage of the system.

jbpm console ng
master
https://github.com/droolsjbpm/jbpm-console-ng/commit/d16833ad16398fb62d16bf396990d4f036862875

6.0.x
https://github.com/droolsjbpm/jbpm-console-ng/commit/9c88f033b575c612e5c214cac9cae98a89e46e32

kie-wb
master
https://github.com/droolsjbpm/kie-wb-distributions/commit/bc63b530c7ee167eff112962f99cf0d7b112e946

6.0.x
https://github.com/droolsjbpm/kie-wb-distributions/commit/a96163ea63d22d974e1944fe77b10644df35d6f6
Comment 6 Maciej Swiderski 2013-10-21 06:46:51 EDT
*** Bug 1019380 has been marked as a duplicate of this bug. ***
Comment 7 Ivo Bek 2013-12-13 06:52:33 EST
Verified in BPMS 6.0.0.ER5
Comment 8 Ivo Bek 2014-03-18 06:26:44 EDT
I believe this issue was so rare that it's not worth do a test for it.

Note You need to log in before you can comment on or make changes to this bug.