Bug 1016610 - openstack-packstack: Install mariadb55 and enable mariadb55-mysqld service (instead of mysql).
openstack-packstack: Install mariadb55 and enable mariadb55-mysqld service (i...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
4.0
x86_64 Linux
high Severity high
: async
: 5.0 (RHEL 7)
Assigned To: Ivan Chavero
Ami Jeain
:
Depends On:
Blocks: 1016685 1017210
  Show dependency treegraph
 
Reported: 2013-10-08 08:08 EDT by Omri Hochman
Modified: 2016-01-06 05:17 EST (History)
10 users (show)

See Also:
Fixed In Version: openstack-packstack-2014.1.1-0.32.1.dev1209.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1016685 (view as bug list)
Environment:
Last Closed: 2014-07-09 16:18:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Install mariadb instead of mysql in RHOS (5.39 KB, patch)
2013-10-25 19:55 EDT, Ivan Chavero
no flags Details | Diff
Install mariadb instead of mysql in RHOS and RDO (7.86 KB, patch)
2013-10-29 04:05 EDT, Ivan Chavero
no flags Details | Diff

  None (edit)
Description Omri Hochman 2013-10-08 08:08:26 EDT
openstack-packstack: Install mariadb55 and enable mariadb55-mysqld service (instead of mysql). 


Description:  
-------------
Since we're going to use mariadb55 from RHSCL with RHOS 4.0-  we should allow packstack to deploy openstack environmnet with mariadb55 instead of mysql.
Comment 3 Alan Pevec 2013-10-17 20:14:36 EDT
After having a quick look at puppetlab-mysql module[1] I think we only need to override few parameters:
        # supported are client libs and tools from baseOS
        $client_package_name = 'mysql'
        # use server from RHSCL
        $server_package_name = 'mariadb55-mariadb-server'
        $server_service_name = 'mariadb55-mysqld'
        $config_file = '/opt/rh/mariadb55/root/etc/my.cnf'
        $datadir = '/opt/rh/mariadb55/root/var/lib/mysql'
        $log_error = '/var/log/mariadb55-mysqld.log'
        $pidfile = '/opt/rh/mariadb55/root/var/run/mysqld/mysqld.pid'

[1] https://github.com/puppetlabs/puppetlabs-mysql/blob/master/manifests/params.pp#L26
Comment 4 Ivan Chavero 2013-10-25 19:55:22 EDT
Created attachment 816319 [details]
Install mariadb instead of mysql in RHOS

Installs mariadb55-server from the RHSCL repo, this repo has to be enabled manually
Comment 7 Ivan Chavero 2013-10-29 04:05:08 EDT
Created attachment 816999 [details]
Install mariadb instead of mysql in RHOS and RDO
Comment 10 Ivan Chavero 2014-07-04 15:52:14 EDT
In the latest packstack version mariadb is installed instead of mysql
Comment 11 Ryan O'Hara 2014-07-07 00:16:02 EDT
(In reply to Ivan Chavero from comment #10)
> In the latest packstack version mariadb is installed instead of mysql

Is it mariadb or mariadb-galera-server? It should be mariadb-galera-server.
Comment 12 Ivan Chavero 2014-07-07 09:36:03 EDT
(In reply to Ryan O'Hara from comment #11)
> (In reply to Ivan Chavero from comment #10)
> > In the latest packstack version mariadb is installed instead of mysql
> 
> Is it mariadb or mariadb-galera-server? It should be mariadb-galera-server.

yes, it installs mariadb-galera-server https://github.com/stackforge/packstack/blob/master/packstack/puppet/templates/mysql_install.pp#L16

Note You need to log in before you can comment on or make changes to this bug.