Bug 1017210 - RHOS 5.0 should support the installation of mariadb
RHOS 5.0 should support the installation of mariadb
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules (Show other bugs)
4.0
Unspecified Unspecified
urgent Severity high
: rc
: 5.0 (RHEL 7)
Assigned To: RHOS Maint
Omri Hochman
: FutureFeature
Depends On: 1016610
Blocks: RHOS50RFE
  Show dependency treegraph
 
Reported: 2013-10-09 08:48 EDT by Mike Orazi
Modified: 2016-04-26 09:35 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
This update provides support for installing MariaDB on Red Hat Enterprise Linux 7 using the puppet-mysql module.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-08 11:37:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Orazi 2013-10-09 08:48:34 EDT
Description of problem:  RHOS 4.0 should be able to support mariadb installation instead of mysql.
Comment 1 Charles Crouch 2013-10-09 10:06:32 EDT
I think there are at least a couple of aspects to this:
1) Making sure that Foreman can utilize mariadb 5.5 as its internal database
2) Making sure that Foreman, via its puppet modules, can support installing mariadb5.5 for use by the OpenStack cloud being deployed.
Comment 2 Mike Orazi 2013-10-28 11:59:08 EDT
This is being deferred to RHOS5
Comment 3 Omri Hochman 2014-02-02 10:29:28 EST
In order to write the test-plans, I'll need some relevant info how user will setup foreman to deploy openstack with mariadb :  for-example:  - Will it be part of the host group parameters - 'Data-base-type : mysql/mariadb' ?  

If possible please provide blue_print for this feature.
Comment 4 Ryan O'Hara 2014-05-29 10:10:37 EDT
RHOS 5.0 installations will now always get mariadb-galera-server as the database server. This is not selectable in Foreman or packstack.
Comment 5 Ryan O'Hara 2014-05-29 10:11:32 EDT
Martin, do you know what version of openstack-puppet-modules has this fix?
Comment 6 Martin Magr 2014-05-29 10:51:43 EDT
Mariadb support has been added in openstack-puppet-modules-2014.1-4, although I suggest to use the latest release, which is 2014.1-12. Note that default mariadb is overrided by mariadb-galera in packstack manifests so foreman should do the same.
Comment 7 Ami Jeain 2014-06-16 09:57:41 EDT
verified:
# rpm -qa |grep -i galera
mariadb-galera-common-5.5.37-4.el7ost.x86_64
galera-25.3.5-4.el7ost.x86_64
mariadb-galera-server-5.5.37-4.el7ost.x86_64

and verified there is no mysql server installed
Comment 10 errata-xmlrpc 2014-07-08 11:37:39 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0846.html

Note You need to log in before you can comment on or make changes to this bug.