Bug 1016616 - Error: Package: dnf-0.4.2-1.gitc1716d7.fc20.noarch Requires: python-librepo = 1.2.0
Error: Package: dnf-0.4.2-1.gitc1716d7.fc20.noarch Requires: python-librepo =...
Status: CLOSED DUPLICATE of bug 1016547
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 08:16 EDT by Davide Poletto
Modified: 2013-10-08 08:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 08:19:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Davide Poletto 2013-10-08 08:16:22 EDT
Description of problem:

Performing:

yum --releasever=20 --enablerepo=updates-testing --enablerepo=updates distro-sync

on a updated Fedora 19 (x64) dependency resolution will fail.

Version-Release number of selected component (if applicable):

Fedora 19 (x64) updated at October, 8th.
Linux localhost.localdomain 3.11.3-201.fc19.x86_64 #1 SMP Thu Oct 3 00:47:03 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:

Did yum clean all
Did rpm --rebuilddb
Did updatedb
Did yum repolist
Did yum --releasever=20 --enablerepo=updates-testing --enablerepo=updates distro-sync

In my system, by doing the yum command above.

Actual results:

--> Finished Dependency Resolution
Error: Package: dnf-0.4.2-1.gitc1716d7.fc20.noarch (updates-testing)
           Requires: python-librepo = 1.2.0
           Available: python-librepo-1.0.0-1.fc20.x86_64 (fedora)
               python-librepo = 1.0.0-1.fc20
           Available: python-librepo-1.2.1-1.fc20.x86_64 (updates-testing)
               python-librepo = 1.2.1-1.fc20
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Expected results:

Update transaction will end without errors.

Additional info:

Repositories and options involved by yum:

Loaded plugins: fastestmirror, langpacks, refresh-packagekit, verify
adobe-linux-x86_64
fedora/20/x86_64/metalink
fedora
google-talkplugin
rpmfusion-free
rpmfusion-free-updates
rpmfusion-nonfree
rpmfusion-nonfree-updates
updates/20/x86_64/metalink
updates
updates-testing/20/x86_64/metalink
updates-testing
(1/5): updates/20/x86_64/primary_db
(2/5): fedora/20/x86_64/group_gz
(3/5): updates-testing/20/x86_64/group_gz
(4/5): updates-testing/20/x86_64/primary_db
(5/5): fedora/20/x86_64/primary_db
(1/12): google-talkplugin/primary
(2/12): rpmfusion-free/20/x86_64/group_gz
(3/12): adobe-linux-x86_64/primary
(4/12): rpmfusion-nonfree/20/x86_64/group_gz
(5/12): rpmfusion-nonfree-updates/20/x86_64/group_gz
(6/12): rpmfusion-free-updates/20/x86_64/group_gz
(7/12): rpmfusion-nonfree/20/x86_64/primary_db
(8/12): rpmfusion-nonfree-updates/20/x86_64/primary_db
(9/12): rpmfusion-free/20/x86_64/primary_db
(10/12): rpmfusion-free-updates/20/x86_64/primary_db
(11/12): updates-testing/20/x86_64/pkgtags
(12/12): updates-testing/20/x86_64/updateinfo
Comment 1 Ales Kozumplik 2013-10-08 08:19:20 EDT

*** This bug has been marked as a duplicate of bug 1016547 ***

Note You need to log in before you can comment on or make changes to this bug.