Bug 1016547 - dnf requires specific version of python-librepo
dnf requires specific version of python-librepo
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
: 1016545 1016616 1016687 1016866 1016897 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 06:37 EDT by Jan Hutař
Modified: 2013-10-10 08:55 EDT (History)
9 users (show)

See Also:
Fixed In Version: dnf-0.4.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 07:38:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2013-10-08 06:37:14 EDT
Description of problem:
I have attempted to upgrade F19 to F20 and got this dependency issue:

Error: Package: dnf-0.4.2-1.gitc1716d7.fc20.noarch (updates-testing)
           Requires: python-librepo = 1.2.0
           Available: python-librepo-1.0.0-1.fc20.x86_64 (fedora)
               python-librepo = 1.0.0-1.fc20
           Available: python-librepo-1.2.1-1.fc20.x86_64 (updates-testing)
               python-librepo = 1.2.1-1.fc20


Version-Release number of selected component (if applicable):
# rpm -q dnf python-librepo yum   # on F19 system
package dnf is not installed
package python-librepo is not installed
yum-3.4.3-106.fc19.noarch
# yum --releasever=20 --enablerepo=updates-testing --enablerepo=updates list dnf python-librepo
Loaded plugins: etckeeper, refresh-packagekit, remove-with-leaves
Trying other mirror.
Available Packages
dnf.noarch                   0.4.2-1.gitc1716d7.fc20         updates-testing
python-librepo.x86_64        1.2.1-1.fc20                    updates-testing


How reproducible:
always


Steps to Reproduce:
1. # yum --releasever=20 --enablerepo=updates-testing --enablerepo=updates list dnf python-librepo


Actual results:
Dependency issue


Expected results:
No dependency issue
Comment 1 Ales Kozumplik 2013-10-08 07:38:27 EDT
Hi, thank you for the report, this has just been fixed yesterday and the new DNF (starting with 0.4.3) does not depend on exact versions.
Comment 2 Ales Kozumplik 2013-10-08 07:39:09 EDT
*** Bug 1016545 has been marked as a duplicate of this bug. ***
Comment 3 Ales Kozumplik 2013-10-08 08:19:20 EDT
*** Bug 1016616 has been marked as a duplicate of this bug. ***
Comment 4 Jan Hutař 2013-10-08 08:24:17 EDT
Thank you!
Comment 5 Ales Kozumplik 2013-10-08 12:29:18 EDT
*** Bug 1016687 has been marked as a duplicate of this bug. ***
Comment 6 Ales Kozumplik 2013-10-09 01:54:11 EDT
*** Bug 1016866 has been marked as a duplicate of this bug. ***
Comment 7 Ales Kozumplik 2013-10-09 01:54:27 EDT
*** Bug 1016897 has been marked as a duplicate of this bug. ***
Comment 8 Jay Woods 2013-10-09 10:22:48 EDT
You did a much better job than I on reporting the bug. Your approach will be used in the future.
Comment 9 Viktor 2013-10-10 03:45:40 EDT
Ales:
Apologies for the question, I have not used Fedora for very long. How long does it take for 4.3.1 to be pushed to either tree (updates-testing or fedora)? Koji [1] says it was built the other day, but it did not show up for me yet.
Thanks in advance!

[1] http://koji.fedoraproject.org/koji/buildinfo?buildID=469758
Comment 10 Ales Kozumplik 2013-10-10 04:35:29 EDT
good question. The 0.4.3-1 has been pushed to stable yesterday by collecting enough karma:

https://admin.fedoraproject.org/updates/FEDORA-2013-18516/dnf-0.4.3-2.fc20?_csrf_token=855c579a588df09792da8facf509e360ed0e7ff5

However, because there are often further elements at play, like:
:: alpha/beta/etc. freezes
:: delay between pushing to stable and repo/mirrors update
:: "inexplicable" problems like being tagged stable in bodhi yet still testing under koji[1]
:: etc.

you see there's really no telling when the users are able to see the updates.

Welcome to Fedora again, good to have you back.

[1] https://admin.fedoraproject.org/updates/FEDORA-2013-18474/librepo-1.2.1-1.fc20?_csrf_token=855c579a588df09792da8facf509e360ed0e7ff5
Comment 11 Viktor 2013-10-10 08:03:29 EDT
Thank you so much for your explanation. I'll be patient. It's good to be back and see the awesome progress made, Fedora is really getting very userfriendly. Can't wait for the coming releases, looks very promising. Keep up the good work and thanks for your quick reply!
Comment 12 Ales Kozumplik 2013-10-10 08:55:52 EDT
Thanks. FWIW, this following update also needs to reach the repos first:

https://admin.fedoraproject.org/updates/librepo-1.2.1-2.fc20

Note You need to log in before you can comment on or make changes to this bug.