Bug 1016660 - FSW 6.0.0 ER6 quickstarts/switchyard/demos/multiApp - fails - Failure to find org.switchyard.quickstarts:switchyard-quickstart-parent:pom:1.1.0.M3-redhat-2
FSW 6.0.0 ER6 quickstarts/switchyard/demos/multiApp - fails - Failure to find...
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Build Process (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity unspecified
: ER5
: ---
Assigned To: Keith Babo
ppecka
: Reopened
Depends On: 1021040
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 09:36 EDT by ppecka
Modified: 2014-06-16 19:51 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1040489 None None None Never
JBoss Issue Tracker SWITCHYARD-1774 Major Closed Broken switchyard.xml in demo/multiApp 2015-10-30 09:25 EDT

  None (edit)
Description ppecka 2013-10-08 09:36:11 EDT
Description of problem:
Quickstart demos/multiApp fails 



server.log  
=== snip ===
15:23:19,699 INFO  [org.jboss.as.server] (DeploymentScanner-threads - 1) JBAS018559: Deployed "switchy
ard-quickstart-demo-multi-web.war" (runtime-name : "switchyard-quickstart-demo-multi-web.war")
15:23:57,746 WARNING [org.apache.cxf.phase.PhaseInterceptorChain] (Camel (camel-3) thread #2 - JmsCons
umer[OrderRequestQueue]) Interceptor for {urn:switchyard-quickstart-demo:multiapp:1.0}OrderService#{ht
tp://cxf.apache.org/jaxws/dispatch}Invoke has thrown exception, unwinding now: org.apache.cxf.intercep
tor.Fault: Could not send Message.
        at org.apache.cxf.interceptor.MessageSenderInterceptor$MessageSenderEndingInterceptor.handleMe
ssage(MessageSenderInterceptor.java:64) [cxf-api-2.6.6-redhat-3.jar:2.6.6-redhat-3]
        at org.apache.cxf.phase.PhaseInterceptorChain.doIntercept(PhaseInterceptorChain.java:262) [cxf
-api-2.6.6-redhat-3.jar:2.6.6-redhat-3]
        at org.apache.cxf.endpoint.ClientImpl.doInvoke(ClientImpl.java:530) [cxf-api-2.6.6-redhat-3.ja
r:2.6.6-redhat-3]
        at org.apache.cxf.endpoint.ClientImpl.invoke(ClientImpl.java:463) [cxf-api-2.6.6-redhat-3.jar:
2.6.6-redhat-3]
        at org.apache.cxf.endpoint.ClientImpl.invoke(ClientImpl.java:366) [cxf-api-2.6.6-redhat-3.jar:
2.6.6-redhat-3]

=== snip ===


Version-Release number of selected component (if applicable):
6.0.0 ER4


Steps to Reproduce:
1. cd quickstarts/switchyard/demos/multiApp
2. mvn clean install
#from order-consumer/README.md
3. ${AS}/bin/add-user.sh  -a -u guest -p guestp.1 -r ApplicationRealm -ro guest -s
4. cp order-consumer/src/test/resources/switchyard-quickstart-demo-multi-order-consumer-hornetq-jms.xml ${AS}/standalone/deployments
cd ../
5. cp multiApp/artifacts/target/OrderService.jar ${AS}
6. cp multiApp/order-service/target/switchyard-quickstart-demo-multi-order-service.jar $AS
7. cp multiApp/order-consumer/target/switchyard-quickstart-demo-multi-order-consumer.jar $AS
8. cp multiApp/web/target/switchyard-quickstart-demo-multi-web.war $AS
9. cd multiApp/order-consumer
10. mvn exec:java




Actual results:
attached server log

mvn exec:java
[INFO] Scanning for projects...
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building Quickstart Demo: Multiple Applications - Order Consumer 1.1.0.M3-redhat-2
[INFO] ------------------------------------------------------------------------
[INFO] 
[INFO] >>> exec-maven-plugin:1.2.1-redhat-1:java (default-cli) @ switchyard-quickstart-demo-multi-order-consumer >>>
[INFO] 
[INFO] --- maven-enforcer-plugin:1.0-redhat-1:enforce (enforce-java-version) @ switchyard-quickstart-demo-multi-order-consumer ---
[INFO] 
[INFO] --- maven-enforcer-plugin:1.0-redhat-1:enforce (enforce-maven-version) @ switchyard-quickstart-demo-multi-order-consumer ---
[INFO] 
[INFO] <<< exec-maven-plugin:1.2.1-redhat-1:java (default-cli) @ switchyard-quickstart-demo-multi-order-consumer <<<
[INFO] 
[INFO] --- exec-maven-plugin:1.2.1-redhat-1:java (default-cli) @ switchyard-quickstart-demo-multi-order-consumer ---
log4j:WARN No appenders could be found for logger (org.jboss.logging).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
Submitting Order
----------------------------
<?xml version="1.0" encoding="UTF-8"?>
<orders:submitOrder xmlns:orders="urn:switchyard-quickstart-demo:multiapp:1.0">
	<order>
	    <orderId>PO-19838-XYZ</orderId>
	    <itemId>BUTTER</itemId>
	    <quantity>200</quantity>
	</order>
</orders:submitOrder>

----------------------------
Order submitted ... waiting for reply.
No reply received.
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 8.695s
[INFO] Finished at: Tue Oct 08 15:24:00 CEST 2013
[INFO] Final Memory: 58M/494M
[INFO] ------------------------------------------------------------------------


Expected results:
Quickstart passes

Additional info:
Comment 1 Keith Babo 2013-10-15 12:48:42 EDT
The endpoint address from the WSDL is being used because there is no endpointAddress specified in the SOAP reference binding in order-consumer.  This causes order-consumer to look for the service on 18001 instead of 8080 where it's actually available.  Easiest fix is to simply provide the endpointAddress config in the binding in order-consumer/src/main/resources/META-INF/switchyard.xml :

<reference multiplicity="1..1" name="OrderWebService" promote="OrderInputComponent/OrderWebService">
            <binding.soap xmlns="urn:switchyard-component-soap:config:1.0">
                <wsdl>OrderService.wsdl</wsdl>
                <endpointAddress>http://localhost:8080/quickstart-demo-multiapp/OrderService</endpointAddress>
            </binding.soap>
        </reference>
Comment 2 JBoss JIRA Server 2013-10-16 10:55:52 EDT
Keith Babo <kbabo@redhat.com> updated the status of jira SWITCHYARD-1774 to Resolved
Comment 3 JBoss JIRA Server 2013-10-16 10:55:52 EDT
Keith Babo <kbabo@redhat.com> made a comment on jira SWITCHYARD-1774

pushed
Comment 4 Len DiMaggio 2013-10-21 12:06:33 EDT
With ER6 and the online repo, this error is being seen:

mvn -e exec:java
[INFO] Error stacktraces are turned on.
[INFO] Scanning for projects...
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building Quickstart Demo: Multiple Applications - Order Consumer 1.1.0.M3-redhat-2
[INFO] ------------------------------------------------------------------------
[INFO] 
[INFO] >>> exec-maven-plugin:1.2.1-redhat-1:java (default-cli) @ switchyard-quickstart-demo-multi-order-consumer >>>
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 5.497s
[INFO] Finished at: Mon Oct 21 12:04:22 EDT 2013
[INFO] Final Memory: 52M/321M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project switchyard-quickstart-demo-multi-order-consumer: Could not resolve dependencies for project org.switchyard.quickstarts.demos:switchyard-quickstart-demo-multi-order-consumer:jar:1.1.0.M3-redhat-2: Failed to collect dependencies for [org.switchyard:switchyard-api:jar:1.1.0.M3-redhat-2 (compile), org.switchyard:switchyard-plugin:jar:1.1.0.M3-redhat-2 (compile), org.switchyard.components:switchyard-component-bean:jar:1.1.0.M3-redhat-2 (compile), org.switchyard.components:switchyard-component-camel:jar:1.1.0.M3-redhat-2 (compile), org.switchyard.components:switchyard-component-camel-core:jar:1.1.0.M3-redhat-2 (compile), org.switchyard.components:switchyard-component-soap:jar:1.1.0.M3-redhat-2 (compile), org.switchyard.quickstarts.demos:switchyard-quickstart-demo-multi-artifacts:jar:1.1.0.M3-redhat-2 (compile), org.hornetq:hornetq-core-client:jar:2.3.1.Final-redhat-1 (compile), javax.jms:jms:jar:1.1 (compile), org.switchyard:switchyard-test:jar:1.1.0.M3-redhat-2 (test), org.switchyard.components:switchyard-component-test-mixin-hornetq:jar:1.1.0.M3-redhat-2 (test), junit:junit:jar:4.10-redhat-2 (test)]: Failed to read artifact descriptor for org.switchyard.quickstarts.demos:switchyard-quickstart-demo-multi-artifacts:jar:1.1.0.M3-redhat-2: Failure to find org.switchyard.quickstarts:switchyard-quickstart-parent:pom:1.1.0.M3-redhat-2 in http://maven.repository.redhat.com/techpreview/all/ was cached in the local repository, resolution will not be reattempted until the update interval of redhat-techpreview-all-repository has elapsed or updates are forced -> [Help 1]
org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal on project switchyard-quickstart-demo-multi-order-consumer: Could not resolve dependencies for project org.switchyard.quickstarts.demos:switchyard-quickstart-demo-multi-order-consumer:jar:1.1.0.M3-redhat-2: Failed to collect dependencies for [org.switchyard:switchyard-api:jar:1.1.0.M3-redhat-2 (compile), org.switchyard:switchyard-plugin:jar:1.1.0.M3-redhat-2 (compile), org.switchyard.components:switchyard-component-bean:jar:1.1.0.M3-redhat-2 (compile), org.switchyard.components:switchyard-component-camel:jar:1.1.0.M3-redhat-2 (compile), org.switchyard.components:switchyard-component-camel-core:jar:1.1.0.M3-redhat-2 (compile), org.switchyard.components:switchyard-component-soap:jar:1.1.0.M3-redhat-2 (compile), org.switchyard.quickstarts.demos:switchyard-quickstart-demo-multi-artifacts:jar:1.1.0.M3-redhat-2 (compile), org.hornetq:hornetq-core-client:jar:2.3.1.Final-redhat-1 (compile), javax.jms:jms:jar:1.1 (compile), org.switchyard:switchyard-test:jar:1.1.0.M3-redhat-2 (test), org.switchyard.components:switchyard-component-test-mixin-hornetq:jar:1.1.0.M3-redhat-2 (test), junit:junit:jar:4.10-redhat-2 (test)]
	at org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.getDependencies(LifecycleDependencyResolver.java:196)
	at org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.resolveProjectDependencies(LifecycleDependencyResolver.java:108)
	at org.apache.maven.lifecycle.internal.MojoExecutor.ensureDependenciesAreResolved(MojoExecutor.java:258)
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:201)
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
	at org.apache.maven.lifecycle.internal.MojoExecutor.executeForkedExecutions(MojoExecutor.java:365)
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:199)
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
	at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
	at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:319)
	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
	at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
	at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
	at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
	at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
	at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
Caused by: org.apache.maven.project.DependencyResolutionException: Could not resolve dependencies for project org.switchyard.quickstarts.demos:switchyard-quickstart-demo-multi-order-consumer:jar:1.1.0.M3-redhat-2: Failed to collect dependencies for [org.switchyard:switchyard-api:jar:1.1.0.M3-redhat-2 (compile), org.switchyard:switchyard-plugin:jar:1.1.0.M3-redhat-2 (compile), org.switchyard.components:switchyard-component-bean:jar:1.1.0.M3-redhat-2 (compile), org.switchyard.components:switchyard-component-camel:jar:1.1.0.M3-redhat-2 (compile), org.switchyard.components:switchyard-component-camel-core:jar:1.1.0.M3-redhat-2 (compile), org.switchyard.components:switchyard-component-soap:jar:1.1.0.M3-redhat-2 (compile), org.switchyard.quickstarts.demos:switchyard-quickstart-demo-multi-artifacts:jar:1.1.0.M3-redhat-2 (compile), org.hornetq:hornetq-core-client:jar:2.3.1.Final-redhat-1 (compile), javax.jms:jms:jar:1.1 (compile), org.switchyard:switchyard-test:jar:1.1.0.M3-redhat-2 (test), org.switchyard.components:switchyard-component-test-mixin-hornetq:jar:1.1.0.M3-redhat-2 (test), junit:junit:jar:4.10-redhat-2 (test)]
	at org.apache.maven.project.DefaultProjectDependenciesResolver.resolve(DefaultProjectDependenciesResolver.java:139)
	at org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.getDependencies(LifecycleDependencyResolver.java:171)
	... 26 more
Caused by: org.sonatype.aether.collection.DependencyCollectionException: Failed to collect dependencies for [org.switchyard:switchyard-api:jar:1.1.0.M3-redhat-2 (compile), org.switchyard:switchyard-plugin:jar:1.1.0.M3-redhat-2 (compile), org.switchyard.components:switchyard-component-bean:jar:1.1.0.M3-redhat-2 (compile), org.switchyard.components:switchyard-component-camel:jar:1.1.0.M3-redhat-2 (compile), org.switchyard.components:switchyard-component-camel-core:jar:1.1.0.M3-redhat-2 (compile), org.switchyard.components:switchyard-component-soap:jar:1.1.0.M3-redhat-2 (compile), org.switchyard.quickstarts.demos:switchyard-quickstart-demo-multi-artifacts:jar:1.1.0.M3-redhat-2 (compile), org.hornetq:hornetq-core-client:jar:2.3.1.Final-redhat-1 (compile), javax.jms:jms:jar:1.1 (compile), org.switchyard:switchyard-test:jar:1.1.0.M3-redhat-2 (test), org.switchyard.components:switchyard-component-test-mixin-hornetq:jar:1.1.0.M3-redhat-2 (test), junit:junit:jar:4.10-redhat-2 (test)]
	at org.sonatype.aether.impl.internal.DefaultDependencyCollector.collectDependencies(DefaultDependencyCollector.java:262)
	at org.sonatype.aether.impl.internal.DefaultRepositorySystem.collectDependencies(DefaultRepositorySystem.java:345)
	at org.apache.maven.project.DefaultProjectDependenciesResolver.resolve(DefaultProjectDependenciesResolver.java:131)
	... 27 more
Caused by: org.sonatype.aether.resolution.ArtifactDescriptorException: Failed to read artifact descriptor for org.switchyard.quickstarts.demos:switchyard-quickstart-demo-multi-artifacts:jar:1.1.0.M3-redhat-2
	at org.apache.maven.repository.internal.DefaultArtifactDescriptorReader.loadPom(DefaultArtifactDescriptorReader.java:317)
	at org.apache.maven.repository.internal.DefaultArtifactDescriptorReader.readArtifactDescriptor(DefaultArtifactDescriptorReader.java:172)
	at org.sonatype.aether.impl.internal.DefaultDependencyCollector.process(DefaultDependencyCollector.java:419)
	at org.sonatype.aether.impl.internal.DefaultDependencyCollector.collectDependencies(DefaultDependencyCollector.java:243)
	... 29 more
Caused by: org.apache.maven.model.resolution.UnresolvableModelException: Failure to find org.switchyard.quickstarts:switchyard-quickstart-parent:pom:1.1.0.M3-redhat-2 in http://maven.repository.redhat.com/techpreview/all/ was cached in the local repository, resolution will not be reattempted until the update interval of redhat-techpreview-all-repository has elapsed or updates are forced
	at org.apache.maven.repository.internal.DefaultModelResolver.resolveModel(DefaultModelResolver.java:126)
	at org.apache.maven.model.building.DefaultModelBuilder.readParentExternally(DefaultModelBuilder.java:819)
	at org.apache.maven.model.building.DefaultModelBuilder.readParent(DefaultModelBuilder.java:670)
	at org.apache.maven.model.building.DefaultModelBuilder.build(DefaultModelBuilder.java:308)
	at org.apache.maven.model.building.DefaultModelBuilder.build(DefaultModelBuilder.java:232)
	at org.apache.maven.repository.internal.DefaultArtifactDescriptorReader.loadPom(DefaultArtifactDescriptorReader.java:308)
	... 32 more
Caused by: org.sonatype.aether.resolution.ArtifactResolutionException: Failure to find org.switchyard.quickstarts:switchyard-quickstart-parent:pom:1.1.0.M3-redhat-2 in http://maven.repository.redhat.com/techpreview/all/ was cached in the local repository, resolution will not be reattempted until the update interval of redhat-techpreview-all-repository has elapsed or updates are forced
	at org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:541)
	at org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:220)
	at org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolveArtifact(DefaultArtifactResolver.java:197)
	at org.apache.maven.repository.internal.DefaultModelResolver.resolveModel(DefaultModelResolver.java:122)
	... 37 more
Caused by: org.sonatype.aether.transfer.ArtifactNotFoundException: Failure to find org.switchyard.quickstarts:switchyard-quickstart-parent:pom:1.1.0.M3-redhat-2 in http://maven.repository.redhat.com/techpreview/all/ was cached in the local repository, resolution will not be reattempted until the update interval of redhat-techpreview-all-repository has elapsed or updates are forced
	at org.sonatype.aether.impl.internal.DefaultUpdateCheckManager.checkArtifact(DefaultUpdateCheckManager.java:190)
	at org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:430)
	... 40 more
[ERROR] 
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException
[ldimaggi@ldimaggi order-consumer]$
Comment 5 kconner 2013-10-30 20:44:13 EDT
Shouldn't the repository be http://maven.repository.redhat.com/techpreview/ip6/6.0.0.Beta/maven-repository/?

If I use the above repository then it works for me.
Comment 9 Keith Babo 2013-12-17 19:55:26 EST
The quickstarts parent pom has not been included in the offline Maven repository, so that's why it can't be resolved.  As a workaround, try building the SY quickstarts once from the top-level first with "mvn install".  

Julian - this is the POM I'm referring to:
https://repository.jboss.org/nexus/index.html#nexus-search;quick~switchyard-quickstart-parent
Comment 10 kconner 2013-12-17 20:00:32 EST
Can you change your settings.xml to the following url

http://download.eng.bos.redhat.com/brewroot/repos/jb-ip-6-build/latest/maven/

Then use -U on your mvn command line.
Comment 12 Martin Vecera 2013-12-18 09:27:46 EST
Verified in ER7-2.
Comment 13 ppecka 2013-12-18 10:17:15 EST
i'll set this back to MODIFIED, as we now (thanks to Martin) know it works and we have a workaround. and will push to VERIFIED whenever it gets to official online/offline repo. thus we can ensure its there when it goes out.
Comment 15 Jiri Pechanec 2014-01-24 07:30:38 EST
Verified in CR1
Comment 16 JBoss JIRA Server 2014-06-16 19:51:01 EDT
Keith Babo <kbabo@redhat.com> updated the status of jira SWITCHYARD-1774 to Closed

Note You need to log in before you can comment on or make changes to this bug.